Results 1 to 3 of 3

Thread: The letters disappear after exit de X

  1. #1
    Just burned his ISO
    Join Date
    Sep 2007
    Posts
    17

    Cool The letters disappear after exit de X

    hi guys after install bt2 in my laptop all works fine... i dont do nothing really nothing and now i startx and all works great but when i log out from X, i return to the command line and type whatever, i cant read anything, i press enter and works but i can't see what im typing.. any idea how can i fix it??

  2. #2
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by erwinvr View Post
    hi guys after install bt2 in my laptop all works fine... i dont do nothing really nothing and now i startx and all works great but when i log out from X, i return to the command line and type whatever, i cant read anything, i press enter and works but i can't see what im typing.. any idea how can i fix it??
    From what you have told us about your hardware, type of install and description of the problem, it is obvious what the problem is.

  3. #3
    Just burned his ISO
    Join Date
    Sep 2007
    Posts
    17

    Default

    ok my laptop has a neomagic video card..
    Method of instalation: (I found it @ the internet), please tell me if something its wrong..
    Code:
    Step 1: Boot Backtrack
    
    Step 2: Login (root/toor) and run startx
    
    Step 3: open a terminal and run mount to see if your HD is currently mounted (if so, run the umount <drive> command to unmount the drive)
    
    Dual Step: run qtparted
    
    Dual Step: select your HD, resize current partition to make space for BT (if not already partitioned, if so skip this step)
    
    Dual Step: File > Commit > OK
    
    Step 4: run fdisk /dev/sda
    
    Step 5: Create Partitions:
    
        * p, enter
        * n, enter
        * p, enter
        * 1, enter 2 for dual-boot
        * 'default', enter
        * +64M, enter (this is the size of your boot partition, adjust as you want
        *
        * n, enter
        * p, enter
        * 2, enter 3 for dual-boot
        * 'default', enter
        * +512M, enter (this is your swap partition, typically double your RAM)
        *
        * n, enter
        * p, enter
        * 3, enter 4 for dual-boot (may auto go to this one)
        * 'default', enter
        * 'default', enter (the rest is alloted to everything else
    
    
    Step 6: p, enter (display partition table to make sure correct), should be:
    
        * sda1 = boot sda2 for dual-boot
        * sda2 = swap sda3 for dual-boot
        * sda3 = main sda4 for dual-boot
    
    Step 7: Change sda2 to swap: sda3 for dual-boot
    
        * t, enter
        * 2, enter 3 for dual-boot
        * 82, enter
        * p, enter (verify changes are correct)
    
    Step 8: Write partitions, w, enter
    
    Step 9: Create file systems (keep in mind, you can use the ones you prefer, this is only an example):
    
        * mke2fs /dev/sda1, enter sda2 for dual
        * mkswap /dev/sda2, enter sda3 for dual
        * swapon /dev/sda2, enter sda3 for dual
        * mkreiserfs /dev/sda3, enter sda4 for dual
    
    Step 10: Create and mount directories:
    
        * mkdir /mnt/backtrack, enter
        * mount /dev/sda3 /mnt/backtrack, enter sda4 for dual
        * mkdir /mnt/backtrack/boot, enter
        * mount /dev/sda1 /mnt/backtrack/boot, enter sda2 for dual
    
    Step 11: Copy files over (this replaces the BT Installer; which wasn't working and why doing it manually is needed):
    
        * cp --preserve -R /{bin,dev,home,pentest,root,usr,etc,lib,opt,sbin,var} /mnt/backtrack, enter (this command takes some time to run)
        * mkdir /mnt/backtrack/{mnt,proc,sys,tmp}, enter
        * mount --bind /dev/ /mnt/backtrack/dev/, enter
        * mount -t proc proc /mnt/backtrack/proc/, enter
        * cp /boot/vmlinuz /mnt/backtrack/boot, enter
        * chroot /mnt/backtrack /bin/bash, enter (may receive '/dev/pts/1: no such file or directory' error, ignore it)
    
    Step 12: Configure Lilo:
    
        * nano /etc/lilo.conf, enter
        * remove all [video] comments including the uncommented 773. but keep vga=791 and uncomment it
        * change "boot" = "/dev/sda"
        * change "root" = "/dev/sda3" sda4 for dual
        * comment out the "message" line near the top
        * If you are not running dual-boot, delete the Windows boot options and leave only linux
        * save and exit
        * lilo -v, enter

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •