Results 1 to 6 of 6

Thread: wicd problems

  1. #1
    Just burned their ISO
    Join Date
    Dec 2011
    Posts
    4

    Question wicd problems

    Hi there,

    I am relatively new to backtrack but i have been using Linux systems such as fedora and Ubuntu, but I'm having some trouble with the wicd interface which I'm using as a wireless connection.

    I have checked the compatible wireless adapters and my USB adapter is in the list based on rt2800. The problem is the USB device is showing up when i issue iwconfig in console along with the driver information etc... but it seems that its not being assigned an address or picking up any networks. I have tried starting networking trying the rt2800 fix on the backtrack wiki.

    I currently have one connection that is working which is eth0 all is fine with this, the only problem is i cant seem to pick up any networks using the wicd manager although it is showing up in konsole when the commands are issued.

    Any help would be greatly appreciated

    UPDATE:

    Screens

    http://i45.tinypic.com/sffgie.jpg

    http://i48.tinypic.com/21msuhc.png

    http://i50.tinypic.com/m75qnm.png

    http://i46.tinypic.com/2na2q34.png

    Thanks

    venum.
    Last edited by venum; 11-08-2012 at 07:56 AM.

  2. #2
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    2

    Default Re: wicd problems

    Hey, im kinda new in BT also and the only advise i have is to try to connect manually.


    for non WPA:
    http://caleudum.com/how-to-connect-w...untubacktrack/

    WPA:
    http://blog.tplus1.com/index.php/200...-command-line/


    I havent tried it so far, but it is worth a shot i guess, GL.

  3. #3
    Just burned their ISO
    Join Date
    Dec 2011
    Posts
    4

    Default Re: wicd problems

    Thanks ill give it a try ! will post on updates

  4. #4
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    5

    Default Re: wicd problems

    try to open preferences in wicd, check what is written there for your interface, should be wlan0

  5. #5
    Just burned their ISO
    Join Date
    Dec 2011
    Posts
    4

    Default Re: wicd problems

    I honestly feel like a tool now something as simple as that, I go and dive in to all other sorts of problems that it could be but a simple preference change worked, much appreciated the help from everyone special thanks to dobermann1601 !

  6. #6
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: wicd problems

    I think you are little confused.

    In monitor mode, you cannot pick up or associate to any AP using WICD or Network Manager..You need to be in "managed" mode. If you are setting your interface (wlan0) in monitor mode, you need to use airodump-ng to see networks, this is done (monitor mode) to inject packets and audit wifi networks.

    If you want to associate to a network, you do not have to set monitor mode..You need to set interface in managed mode:

    ifconfig wlan0 down
    iwconfig wlan0 mode managed
    ifconfig wlan0 up

    Now you have your interface in managed mode. Now try to associate to a network using either wicd or manually..

    Ex: AP = "my_wifi_AP", channel 5, wep key 1234567890....First make sure to set the interface wlan0 in managed mode as instructed above, here I post the complete process:

    MANUAL MODE:
    ifconfig wlan0 down
    iwconfig wlan0 mode managed
    iwconfig wlan0 essid my_wifi_AP
    iwconfig wlan0 channel 5
    iwconfig wlan0 key 1234567890
    ifconfig wlan0 up

    So far, you must be associated to the AP, verify it: iwconfig

    Now, you need to ask for an IP to the AP associated to: dhclient wlan0
    You will see a DISCOVER, REQUEST, OFFER, etc..All managed by dhclient (except the OFFER, from AP)..Now you should get an valid IP.

    USING WICD:
    ifconfig wlan0 down
    iwconfig wlan0 mode managed
    ifconfig wlan0 up
    /etc/init.d/wicd start

    It will do all the above (Manually method), but need to be in "managed" mode first..

    Now open wicd GUI and see how many networks you can see. Just select the one you want to associate..

    When you use airmon-ng, you are setting wlan0 to "monitor mode", ready to inject packets and audit wifi AP's and then your new iface is phy0..If do it manually (monitor mode), your interface remains the same (wlan0)..It is up to you..Which one to use.

    PS Sometimes the manual mode fails to associate, you need to try again..I,ve seen this and sometimes try it 3 times and then it associates..Sometimes the first time will do.

    Luck.

Similar Threads

  1. WICD wont connect after R1 update, VM problems
    By anonymacs in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 08-20-2011, 10:27 PM
  2. Hercules Wireless & Wicd Network Manager Problems
    By Gambino in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 07-12-2011, 08:53 PM
  3. BT4 R2 wicd wireless connection problems
    By ceefus in forum Beginners Forum
    Replies: 3
    Last Post: 01-10-2011, 10:34 PM
  4. 1000H and WICD problems (VMware)
    By onycro in forum Beginners Forum
    Replies: 3
    Last Post: 09-26-2010, 05:52 PM
  5. UniBody MacBook Pro and Wicd upgrade problems
    By PyrO_PrOfessOr in forum OLD BackTrack 4 Software Related Issues
    Replies: 0
    Last Post: 09-02-2009, 02:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •