Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

  1. #21
    Senior Member
    Join Date
    Dec 2010
    Posts
    127

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    Hello all...sorry been busy. I pushed the changes to the master branch on github. It should be v3.7.2 with the fixes from the posts above (dhcp & sslstrip). It's been up there for a bit, just not packaged in a zip file. I was hoping others would test it out. It worked ok for me from a standard BT5R3 iso. Please let me know if issues continue.

    If you don't use git, then the quickest way to update is:
    1. Go to https://github.com/brav0hax and select easy-creds
    2. Click on easy-creds.sh
    3. Click the "Raw" button (https://raw.github.com/brav0hax/easy.../easy-creds.sh)
    4. Copy/paste into a text file
    5. Edit your application paths starting on line 121 <= Very important
    6. save as easy-creds.sh into the easy-creds folder

    You should now be rockin 3.7.2 with the dhcp & sslstrip fixes.

    Let me know if it works or not so I can package it up and see if I can't get it pushed to BT

    Best Regards,
    Eric
    @Brav0Hax

  2. #22
    Senior Member
    Join Date
    Dec 2010
    Posts
    127

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    Quote Originally Posted by wewe73 View Post
    Hi to all,

    just thought to keep this forums tidy as possible and not start new thread, the end of the day it's all about easy-creds,

    I have beautiful BackTrack5 r3 GNOME 64bit installed on my laptop

    now i know eric has fixed the path to sslstrip and dhcp issue because i downloaded the updated one from github, so many thanks for that if you reading this eric :-) and it does the job for FakeAP Attacks, Poisoning Attacks and more but when i tried out Karmetasploit Attack, Eviltwin and sidejacking attack, I had come a cross some problems, like with Eviltwin i had an error below with the airbase-ng.

    21:27:59 Created tap interface at0
    21:27:59 Trying to set MTU on at0 to 1500
    21:27:59 Trying to set MTU on mon0 to 1800
    21:27:59 Access Point with BSSID 00:C0:CA:66:42:BA started.
    Error: Got channel -1, expected a value < 256. Please report.

    now i know we don't mention channel number to airbase-ng it will give us that error, and easy-creds doesn't ask which channel i want to be on during the attack,

    for sidejacking issue everything works perfect i can see logins and passwords on ettercap and sslstrip but hamster and ferret doesn't fire up,

    Karmetasploit Attack does not start for some reason,

    i tried to fix the problem for last few days but hey am jack sh** at coding :-) i even uncommented f_findpaths and comment out static paths hoping to fix the problem but without success. any help will be appreciated,

    thanks in advance and good day
    Weird that you would get that error as I know there is a patch for that -1 issue.

    With regards to Evil Twin, you are right it does not ask for a channel, nor should it because it will run on the broadcast channel of 255.

    I'll take a look at the hamster/ferret/Karmetasploit issues over the next week. Can you provide a better statement as to what is happening exactly when you try to launch Karmetasploit, or the sidejacking?

    I made a lot of changes and sometimes I get lost in my own code :-(

    Thanks again,
    Eric

  3. #23
    Junior Member
    Join Date
    Jun 2011
    Location
    UK
    Posts
    45

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    Hi Eric

    well well well, I tried easy-creds 3.7.2 on backtrack5 r3 32bit GNOME booted on VMWare (not installed) and works perfect, no errors no nothing, that make me feel want to test backtrack r3 64 on VMWare, (not installed) and (installed) too, after all that airbase error isn't because easy-creds at all, will update here and hope others members update on here too, just a way to say thank you to Eric ;-)

    edit

    the airbase error > Error: Got channel -1, expected a value < 256. Please report I fixed it by purge the aircrak-ng and reinstall it by apt-get, job done!
    Last edited by wewe73; 12-11-2012 at 04:49 PM.

  4. #24
    Senior Member
    Join Date
    Dec 2010
    Posts
    127

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    OK I've posted v3.7.3 to sourceforge....let me know if there are issues.

    Will send to dookie to see if we can get into BT.

    Please not this version has a new file easy-creds.paths update you program path files here. Too many people complained about it being in the source code.

    http://sourceforge.net/projects/easy-creds/files/

    Happy hunting!
    Eric

    aka J0hnnyBrav0
    aka Brav0Hax
    aka Total douchebag ;-)

  5. #25
    Junior Member
    Join Date
    Jun 2011
    Location
    UK
    Posts
    45

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    Hi Sir Eric,

    i tried easy-creds v3.7.3 from http://sourceforge.net/projects/easy-creds/files/ today, wow it's rocks men ;-) thank you so much, working BEAUTIFULLY here, i highly highly thank you,

    it's like my Christmas present lol

  6. #26
    Just burned their ISO webninja's Avatar
    Join Date
    Dec 2007
    Posts
    15

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    thanks, too, eric! new version works fine, installed in /opt dir.

    if i may suggest an enhancement in your next version, it would be nice to add a MAC changer option for mon0 interface. this way, any curious bloke who scans the fake AP won't show "ALFA" (in my case i use an ALFA card) in their scans and "alarm" the user

    i added the following code in your script:

    Code:
    f_ChangeMAC(){
       ifconfig mon0 down
       macchanger --mac <new MAC address> mon0
       ifconfig mon0 up
    }
    and inserted "f_ChangeMAC" immediately after each "airmon-ng start..." entries in your script.

    more power, dude.

  7. #27
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    5

    Thumbs up Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    First, it’s good to update everything:
    apt-get update;apt-get dist-upgrade


    I had also gorked up my DHCP server, so I removed and reinstalled it:
    apt-get remove --purge dhcp3-server
    apt-get install dhcp3-server

    Then I had to fix some missing file paths and permissions. I did this by copying, chmoding and symbolic linking:

    cp /etc/dhcp3/dhcpd.conf /etc/dhcp3/dhcp.conf
    ln -s /etc/dhcp3 /etc/dhcp
    chmod +x /pentest/web/sslstrip/sslstrip.py
    ln -s /pentest/web/sslstrip/sslstrip.py /bin/sslstrip

    All should work, but sometimes setting IP forwarding fails, so:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    This will fix everything in easycreds can mods make this sticky

  8. #28
    Senior Member
    Join Date
    Dec 2010
    Posts
    127

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    Quote Originally Posted by DeWAbbit View Post
    First, it’s good to update everything:
    apt-get update;apt-get dist-upgrade


    I had also gorked up my DHCP server, so I removed and reinstalled it:
    apt-get remove --purge dhcp3-server
    apt-get install dhcp3-server

    Then I had to fix some missing file paths and permissions. I did this by copying, chmoding and symbolic linking:

    cp /etc/dhcp3/dhcpd.conf /etc/dhcp3/dhcp.conf
    ln -s /etc/dhcp3 /etc/dhcp
    chmod +x /pentest/web/sslstrip/sslstrip.py
    ln -s /pentest/web/sslstrip/sslstrip.py /bin/sslstrip

    All should work, but sometimes setting IP forwarding fails, so:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    This will fix everything in easycreds can mods make this sticky
    It's obvious you're not running the latest version. I fixed all of those issues in v3.7.3 on Sourceforge.

    If you find you still have issues...let me know.

    Thanks,
    Eric

  9. #29
    Just burned their ISO
    Join Date
    Apr 2010
    Posts
    16

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    Hello and thank you for easy-creds. An issue I'm having is this:

    Latpop with two wireless interface cards: wlan0 and wlan1. wlan0 connects to the internet on 192.168.1.0/24 network. So, am I supposed to indicate that the tunnel interface is at0 or wlan1? This question is asked two times, one for the wireless connection in which I input wlan1 and then again in the tunnel interface. So it's just a bit confusing.

    the other issue I'm seeing is that although ip_forward is set to 1, requests are not making it to the internet-connected network. I can see through Urlspoof the url being requested which makes me think that at0 is operating properly, but doing a tcpdump on the network shows that the at0 network keeps asking where is the router address.

    Downloaded latest version 3.7.3 from sourceforge.

    Thank you.

  10. #30
    Just burned their ISO
    Join Date
    Apr 2010
    Posts
    16

    Default Re: Easy-Creds v 3.7.1 - sslstrip not starting without slight change in script

    This is not working. All the xterm boxes pop up looking quiet normal. url snarf shows requests for urls. But the connecting device does not get pages or sites.

    Please advise if /etc/default/dhcp3-server needs tweaking. Thank you.

Page 3 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. easy-creds 3.6 released
    By ericmilam in forum BackTrack 5 Experts Section
    Replies: 22
    Last Post: 11-07-2012, 10:10 PM
  2. Easy-Creds Confusion
    By Fetus in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 10-08-2012, 06:24 PM
  3. easy-creds 3.3-BT5 Released
    By ericmilam in forum BackTrack 5 Experts Section
    Replies: 55
    Last Post: 12-06-2011, 09:23 AM
  4. easy-creds v3 released
    By ericmilam in forum Experts Forum
    Replies: 2
    Last Post: 01-08-2011, 10:28 PM
  5. easy-creds bash script
    By ericmilam in forum Experts Forum
    Replies: 6
    Last Post: 12-13-2010, 05:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •