Results 1 to 9 of 9

Thread: fern-wifi-cracker, remove or reinstall with package errors

Hybrid View

  1. #1
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    13

    Default fern-wifi-cracker, remove or reinstall with package errors

    BT5r3 in
    virtualbox 4.2.2 on
    macbook 10.6.8 (Host)

    Hi, was trying to install fern-wifi-cracker from https://fern-wifi-cracker.googlecode...er_1.2_all.deb

    "Before Steps", are not available, i found on other sides: i must install
    Python
    AirCrack-ng
    macchanger
    Xterm
    Subversion
    Python-qt4, so iam not sure if i have do this correctly or have all...

    Anyway i grab this and some other packages come with, like citadel and so on, later i found a update to 1.6 (https://launchpad.net/~backbox/+arch...ckbox2_all.deb), so i grab this too...
    later in Synaptic i see 1.6 is update-able...

    Later i see the message Error:
    "gem" needed and "nokogiri", simultanly i install it too, also he want "beef" and a "gdeb" for debian packages...omg*

    Now is the point, i collapse and i dont know what is going on...

    So i choice to stop all or reinstall it correctly or fix the prob with:
    Code:
    sudo apt-get o dpkg::options::="--force-confnew" -o dpkg::options:="--force-confmiss" --reinstall install /var/cache/apt/archives/fern-wifi-cracker_1.6-bt0_all.deb
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Couldnīt find package
    So i now want remove it simply:

    Code:
    apt-get remove fern-wifi-cracker
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
      fern-wifi-cracker
    0 upgraded, o newly installed, 1 to remove and 0 not upgraded
    After this operation, 3,514 kb disk space will be freed.
    Continue (y/n) y
    (Reading database ... 268007 files and directories currently installed.)
    Removing fern-wifi-cracker ...
    dpkg (subprocess): unable to execute installed pre-removal script: Exec format error
    dpkg: error processing fern-wifi-cracker (--remove):
     subprocess installed pre-removal script returned error exit status 2
    Errors were encountered while processing: fern-wifi-cracker
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    After this i installed synaptic and want to try remove with a GUI. Fern was marked for a update, i try this but:
    Code:
    An error occured
    E:/var/cache/apt/archives/fern-wifi-cracker_1.6-bt0_all.deb: there is no script in the new version of the package - giving up.
    Details from synaptic are the same:

    Code:
    dpkg (subprocess): unable to execute installed pre-removal script: Exec format error
    dpkg: warning: old pre-removal script returned error exit status 2
    dpkg - trying script from the new package instead ...
    dpkg: error processing /var/cache/apt/archives/fern-wifi-cracker_1.6-bt0_all.deb (--unpack):
    there is no script in the new version of the package - giving up.
    Errors were encountered while processing: /var/cache/apt/archives/fern-wifi-cracker_1.6-bt0_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    A package failed to install. Trying to recover.
    Now i want to erase what is coming with fern-wifi-cracker...because, actually i canīt use it no "monitor mode"...
    Hope u can help me a bit, alternate it can displaced to Beginner-Section, because i am a Beginner in Linux and Bash

    Thank for all information about this Problem.
    Regards
    dataminer

    If this solved i will install correctly the stuff and learning more about this...synaptic will help me, and i will learn!

  2. #2
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    [QUOTE=dataminer;226244]BT5r3 in
    virtualbox 4.2.2 on
    macbook 10.6.8 (Host)

    Hi, was trying to install fern-wifi-cracker from https://fern-wifi-cracker.googlecode...er_1.2_all.deb....................................
    ...............................................

    hi
    in MY bt5-r3(fresh-install) is default-install

    root@bt:~# uname -a
    Linux bt 3.2.6 #1 SMP Fri Feb 17 10:40:05 EST 2012 i686 GNU/Linux
    root@bt:~# lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 10.04.3 LTS
    Release: 10.04
    Codename: lucid
    root@bt:~# cd /pentest/wireless
    root@bt:/pentest/wireless# ls
    aircrack-ng fern-wifi-cracker freeradius-wpe giskismet horst killerbee wepcrack wifi-honey wifite
    root@bt:/pentest/wireless# cd fern-wifi-cracker
    root@bt:/pentest/wireless/fern-wifi-cracker# ls
    core execute.py fern-settings gui key-database README resources version
    root@bt:/pentest/wireless/fern-wifi-cracker# ./execute.py

  3. #3
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    13

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    [QUOTE=zimmaro;226274]
    Quote Originally Posted by dataminer View Post
    BT5r3 in
    virtualbox 4.2.2 on
    macbook 10.6.8 (Host)

    Hi, was trying to install fern-wifi-cracker from https://fern-wifi-cracker.googlecode...er_1.2_all.deb....................................
    ...............................................

    hi
    in MY bt5-r3(fresh-install) is default-install

    root@bt:~# uname -a
    Linux bt 3.2.6 #1 SMP Fri Feb 17 10:40:05 EST 2012 i686 GNU/Linux
    root@bt:~# lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description: Ubuntu 10.04.3 LTS
    Release: 10.04
    Codename: lucid
    root@bt:~# cd /pentest/wireless
    root@bt:/pentest/wireless# ls
    aircrack-ng fern-wifi-cracker freeradius-wpe giskismet horst killerbee wepcrack wifi-honey wifite
    root@bt:/pentest/wireless# cd fern-wifi-cracker
    root@bt:/pentest/wireless/fern-wifi-cracker# ls
    core execute.py fern-settings gui key-database README resources version
    root@bt:/pentest/wireless/fern-wifi-cracker# ./execute.py
    Interesting, but how you install fern-w-c, looks like it was installed in your Distribution?
    I hope u read my post a bit closer, so u find the questions i have...
    i want do something, erase or reinstall fer-w-c, but i have some errors, updates waiting and stopped after i try to delete or reinstall fern-w-c.
    a.s.o.
    Greeetz

  4. #4
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    sorry,
    * I, as always, I did not understand the question!
    anyway i use Python executable

  5. #5
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    13

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    Quote Originally Posted by zimmaro View Post
    sorry,
    * I, as always, I did not understand the question!
    anyway i use Python executable
    You are a little Genius, i think.
    The version i installed is 1.7...per synaptic is update to 1.6bt0 available, because its the latest update. If i mark to update (to a lower version) error i coming.
    How i can have 1.7? And how Synaptic have only 1.6bt0)

    Thats the first.

    Anyways, i sill remove it and i canīt so. Other updates waiting after the error of fern update.
    If i try to remove v1.6 per synaptic, if i have v1.7, he canīt remove, sounds logical.

    What is the command to remove version 1.7?
    I think i have upgrade-button used in fern-w-c, not loaded a package.

    But:
    sudo apt-get remove fern-wifi-cracker brings me a error, see below...

    Thanks for reply

  6. #6
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    [QUOTE=dataminer;226337]You are a little Genius, i think.
    ................
    .........................
    hi
    many-thanks, good ...
    could you explain it well to ... my Mother and My wife ...........................
    ........ they think I'm a "" STUPID-DONKEY "" ........
    muahahahahahahahah .....!
    fricati!
    bye

  7. #7
    Just burned his ISO
    Join Date
    Oct 2012
    Posts
    2

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    Python is already in BT5R3 isnt it? And why dont you use gerix-wifi-cracker? its already installed in BT5R3

  8. #8
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    13

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    Quote Originally Posted by mitchboy007 View Post
    Python is already in BT5R3 isnt it? And why dont you use gerix-wifi-cracker? its already installed in BT5R3
    why? why not? i read about it, if u have a good documentation of gerix, i will try...is there a nice GUI with a over dimensional logo like fern? Then i will try it too

  9. #9
    Just burned his ISO
    Join Date
    Aug 2007
    Posts
    1

    Default Re: fern-wifi-cracker, remove or reinstall with package errors

    I have the same problem as dataminer

Similar Threads

  1. Was able to use Fern Wifi Cracker once... Then something strange happened.
    By TopCaliber in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 10-18-2012, 08:05 AM
  2. WPS and Attack Automation with Fern Wifi Cracker
    By savioboyz in forum BackTrack 5 Experts Section
    Replies: 13
    Last Post: 10-05-2012, 01:29 AM
  3. Strange error with Fern Wifi cracker...
    By Nyk0n in forum BackTrack 5 Beginners Section
    Replies: 2
    Last Post: 03-22-2012, 05:22 PM
  4. New FERN WIFI CRACKER
    By savioboyz in forum Experts Forum
    Replies: 97
    Last Post: 04-26-2011, 07:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •