Results 1 to 1 of 1

Thread: Tcpreplay send packets

  1. #1
    Just burned his ISO
    Join Date
    Oct 2012
    Posts
    1

    Question Tcpreplay send packets

    BT 5 version:
    Linux bt 2.6.38 #1 SMP Thu Mar 17 20:52:18 EDT 2011 i686 GNU/Linux
    tcpreplay
    root@bt:/pentest/sniffers/tcpreplay# tcpreplay -V
    tcpreplay version: 1.3.3

    Compiled against libnet: 1.0.2
    root@bt:/pentest/sniffers/tcpreplay# ./tcpreplay -V
    tcpreplay version: 3.4.4 (build 2450)
    Copyright 2000-2010 by Aaron Turner <aturner at synfin dot net>
    Cache file supported: 04
    Compiled against libdnet: 1.12
    Compiled against libpcap: 1.0.0
    64 bit packet counters: enabled
    Verbose printing via tcpdump: enabled
    Packet editing: disabled
    Fragroute engine: enabled
    Injection method: PF_PACKET send()
    ------
    ./tcpreplay -v -i eth0 4.pcap -t --enable-file-cache
    sending out eth0
    processing file: 4.pcap
    reading from file -, link-type EN10MB (Ethernet)
    12:46:15.933687 IP x.137 > 192.168.240.2.137: NBT UDP PACKET(137): QUERY; REQUEST; UNICAST
    12:46:17.428330 IP x.137 > 192.168.240.2.137: NBT UDP PACKET(137): QUERY; REQUEST; BROADCAST
    12:46:18.928163 IP x.137 > 192.168.240.2.137: NBT UDP PACKET(137): QUERY; REQUEST; BROADCAST
    12:49:02.462844 IP x.137 > 192.168.240.2.137: NBT UDP PACKET(137): QUERY; REQUEST; UNICAST
    T
    ^Ctcpdump: pcap_loop: error reading dump file: Interrupted system call

    ^C^C^C^C^C^C^C^C
    ----
    My PC eth0 is no ip address,but x.137 mac address is same with my PC.
    ---
    When I run ,It appears this:
    root@bt:/pentest/sniffers/tcpreplay# tcpreplay -i eth0 4.pcap -R
    sending on eth0
    10279 packets (745870 bytes) sent in 0.58 seconds
    12720559.0 bytes/sec 97.05 megabits/sec 175304 packets/sec
    575 write attempts failed from full buffers and were repeated

    I found a tips in tcpreplay wensite :
    http://tcpreplay.synfin.net/wiki/FAQ...ndwererepeated

    -----
    ]I want to find the reason why tcpreplay cannt works ,Thanks.
    Last edited by mscode; 10-25-2012 at 08:25 PM.

Similar Threads

  1. Ralink RT2870/3070 - "got 0 ARP requests,0 packets send"
    By dragmnl123 in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 06-17-2012, 03:41 AM
  2. Can't get TCPreplay to run
    By SaltWaterHippo in forum BackTrack 5 General Topics
    Replies: 1
    Last Post: 02-05-2012, 08:11 AM
  3. Aireplay read packets constantly, but no packets is found.
    By mmassad in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 07-25-2011, 11:18 AM
  4. TCPReplay playing back malformed packets
    By memzback in forum OLD Newbie Area
    Replies: 8
    Last Post: 12-02-2008, 09:34 PM
  5. Tcpreplay problem.
    By c8sdd in forum OLD Newbie Area
    Replies: 3
    Last Post: 03-14-2008, 01:26 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •