For those that have an Asus G74s laptop and want your numerical pad to work correctly the fix is simple.

System -> Preferences -> Keyboard

1. Go to the Layouts tab.

2. Open the "Options" window.

3. Expand the "Miscellaneous compatibility options"

4. Select the "Default numeric keypad keys" and "Numeric keypad keys work as with Mac"

5. Close the window and select "Apply System-Wide..."

6. Enjoy your numerical pad!