Results 1 to 2 of 2

Thread: wpscan get error after update

  1. #1
    Just burned his ISO
    Join Date
    Oct 2012
    Posts
    2

    Default wpscan get error after update

    when update wpscan to the latest version,i get this error:
    Code:
    root@bt:/usr/bin# ruby /pentest/web/wpscan2/wpscan.rb
    [ERROR] no such file to load -- nokogiri
    
    Nokogiri needs some packets, please run 'sudo apt-get install libxml2 libxml2-dev libxslt1-dev' to install them. Then run the command below
    
    [TIP] Try to run 'gem install nokogiri' or 'gem install --user-install nokogiri'. If you still get an error, Please see README file or https://github.com/wpscanteam/wpscan
    but the mokogiri is allready installed:
    Code:
    root@bt:/usr/bin# gem list
    
    *** LOCAL GEMS ***
    
    abstract (1.0.0)
    actionmailer (3.0.6)
    actionpack (3.0.6)
    activemodel (3.0.6)
    activerecord (3.0.6)
    activeresource (3.0.6)
    activesupport (3.0.6)
    addressable (2.2.8)
    arel (2.0.10, 2.0.9)
    bson (1.5.2)
    bson_ext (1.5.2)
    builder (2.1.2)
    bundler (1.0.13)
    childprocess (0.3.3)
    diff-lcs (1.1.2)
    em-resolv-replace (1.1.2)
    erubis (2.6.6)
    factory_girl (1.3.3)
    ffi (1.0.11)
    fxruby (1.6.25)
    hpricot (0.8.6)
    http_configuration (1.0.4)
    i18n (0.5.0)
    json (1.7.3, 1.6.5)
    libwebsocket (0.1.3)
    mail (2.2.19)
    mime-types (1.17.2, 1.16)
    mini_exiftool (1.3.1)
    mongo (1.5.2)
    multi_json (1.3.6)
    mysql (2.8.1)
    nokogiri (1.5.5, 1.4.4)
    polyglot (0.3.1)
    rack (1.2.3, 1.2.2)
    rack-mount (0.6.14)
    rack-test (0.5.7)
    rails (3.0.6)
    railties (3.0.6)
    rake (0.9.1, 0.8.7)
    rchardet (1.3)
    RedCloth (4.2.5)
    rspec (2.6.0)
    rspec-core (2.6.3)
    rspec-expectations (2.6.0)
    rspec-mocks (2.6.0)
    rspec-rails (2.6.1)
    rubyzip (0.9.6.1)
    selenium-webdriver (2.24.0)
    spider (0.4.4)
    sqlite3-ruby (1.2.5)
    thor (0.14.6)
    treetop (1.4.9)
    typhoeus (0.3.3, 0.2.4)
    tzinfo (0.3.27)
    watobo (0.9.8.724)
    xml-simple (1.1.1, 1.1.0)
    zip (2.0.2)

  2. #2
    Just burned his ISO
    Join Date
    Oct 2012
    Location
    Germany
    Posts
    2

    Default Re: wpscan get error after update

    same problem here, the solution from the following link worked for me:

    Update WPSCAN using GIT on BackTrack 5R2:

    http://tonyonsecurity.com/2012/10/03...backtrack-5r2/

    I also had to install "gem install --user-install ffi".

    Cheers,

    phallex666

Similar Threads

  1. [ERROR] Install missing ruby gem when running wpscan
    By abraoximenes in forum BackTrack 5 Bugs
    Replies: 1
    Last Post: 10-03-2012, 02:32 PM
  2. use of wpscan
    By bmike1 in forum BackTrack 5 How-To's
    Replies: 1
    Last Post: 01-16-2012, 08:25 AM
  3. ./wpscan.py ./wpspy.py problem
    By Jaylong in forum Beginners Forum
    Replies: 1
    Last Post: 12-20-2010, 09:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •