Results 1 to 1 of 1

Thread: dkpg problem with dependencies for Ruby

  1. #1
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    12

    Default dkpg problem with dependencies for Ruby

    Hi,

    Solved below myself by "hard" removing and purging the packages and completely switching to RVM for Ruby. Will see the exact impact for use within BT. Maybe someone already knows and can enlighten me?


    I'm encountering some depency problems in BT5 r3 for Ruby. See below for the error-output:
    Code:
    root@bt:~# apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    9 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? 
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 7502 package 'magictree':
     error in Version string 'r1643-bt0': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 20959 package 'udptunnel':
     error in Version string 'r19-bt0': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 26589 package 'untidy':
     error in Version string 'beta2-bt1': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 30048 package 'pwntcha':
     error in Version string 'rev4780-bt3': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 35471 package 'android-sdk':
     error in Version string 'r20.0.1-bt0': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 49709 package 'webslayer':
     error in Version string 'rev5-bt0': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 55180 package 'wifite':
     error in Version string 'r85-bt1': version number does not start with digit
    dpkg: warning: parsing file '/var/lib/dpkg/status' near line 55718 package 'protos-sip':
     error in Version string 'r2-bt1': version number does not start with digit
    Setting up ruby1.8 (1.8.7.352-2ubuntu1) ...
    update-alternatives: error: alternative rdoc can't be slave of ruby: it is a master alternative.
    dpkg: error processing ruby1.8 (--configure):
     subprocess installed post-installation script returned error exit status 2
    dpkg: dependency problems prevent configuration of ruby:
     ruby depends on ruby1.8 (>> 1.8.7.334-1); however:
      Package ruby1.8 is not configured yet.
    dpkg: error processing ruby (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ruby-sqlite3:
     ruby-sqlite3 depends on ruby | ruby-interpreter; however:
      Package ruby is not configured yet.
      Package ruby1.8 which provides ruby is not configured yet.
      Package ruby-interpreter is not installed.
      Package ruby1.8 which provides ruby-interpreter is not configured yet.
    dpkg: error processing ruby-sqlite3 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsqlite3-ruby:
     libsqlite3-ruby depends on ruby-sqlite3; however:
      Package ruby-sqlite3 is not configured yet.
    dpkg: error processing libsqlite3-ruby (--confNo apport report written because the error message indicates its a followup error from a previous failure.
                                                              No apport report written because the error message indicates its a followup error from a previous failure.
                                                                          No apport report written because MaxReports is reached already
                                          No apport report written because MaxReports is reached already
          No apport report written because MaxReports is reached already
                                                                        No apport report written because MaxReports is reached already
                                        No apport report written because MaxReports is reached already
        No apport report written because MaxReports is reached already
                                                                      igure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libsqlite3-ruby1.8:
     libsqlite3-ruby1.8 depends on ruby-sqlite3; however:
      Package ruby-sqlite3 is not configured yet.
    dpkg: error processing libsqlite3-ruby1.8 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of rubygems:
     rubygems depends on ruby1.8; however:
      Package ruby1.8 is not configured yet.
    dpkg: error processing rubygems (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of rake:
     rake depends on ruby | ruby-interpreter; however:
      Package ruby is not configured yet.
      Package ruby1.8 which provides ruby is not configured yet.
      Package ruby-interpreter is not installed.
      Package ruby1.8 which provides ruby-interpreter is not configured yet.
     rake depends on rdoc; however:
      Package rdoc is not installed.
      Package ruby which provides rdoc is not configured yet.
     rake depends on rubygems; however:
      Package rubygems is not configured yet.
    dpkg: error processing rake (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ri1.8:
     ri1.8 depends on ruby1.8 (>= 1.8.7.352-2ubuntu1); however:
      Package ruby1.8 is not configured yet.
    dpkg: error processing ri1.8 (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of ri:
     ri depends on ri1.8 (>> 1.8.7.334-1); however:
      Package ri1.8 is not configured yet.
    dpkg: error processing ri (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     ruby1.8
     ruby
     ruby-sqlite3
     libsqlite3-ruby
     libsqlite3-ruby1.8
     rubygems
     rake
     ri1.8
     ri
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Ruby does work though, sinde using RVM for that. I am wondering if it safe to remove and prugr these packages?
    Last edited by Swiftme; 10-10-2012 at 08:53 AM. Reason: Solved myself

Similar Threads

  1. [FIX] Backtrack R3 64-Bit Package Dependencies Problem [FIX]
    By MirrorDevel in forum BackTrack 5 Fixes
    Replies: 3
    Last Post: 12-03-2012, 04:09 AM
  2. BT5R1 Ruby implementation problem??....
    By jcm4101 in forum BackTrack 5 Bugs
    Replies: 0
    Last Post: 11-06-2011, 04:35 AM
  3. Problem with Metasploit Ruby Language
    By centaurios in forum Beginners Forum
    Replies: 1
    Last Post: 10-08-2010, 10:49 AM
  4. Problem With Unmet Dependencies
    By Eternal Unknown in forum OLD BackTrack 4 Software Related Issues
    Replies: 2
    Last Post: 01-21-2010, 09:02 AM
  5. Learning ruby... My first ruby backdoor...
    By BigMac in forum OLD Programming
    Replies: 9
    Last Post: 06-03-2009, 11:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •