Results 1 to 8 of 8

Thread: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

Hybrid View

  1. #1
    Just burned his ISO omegear's Avatar
    Join Date
    May 2010
    Posts
    5

    Default [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    Hello Everyone,
    I recently tryied to install BT5 R3 on my new Asus EEE X101CH without sucess. ( USB unetbootin live )

    The problem :
    The VGA screen driver 791 seems to fail. The screen turns black if I boot in this mode. "Unbuntu 10.0.4" then * black screen *

    Pre-Solution :
    I sucessfully entered into Backtrack5r3 when I edit the default launch option from "vga=791--" to "vga=0x315" in the grub.

    Basically I fixed the problem but not entierly because I want a persistent copy on the Hardisk.

    So here is the second problem, which I'm currently stuck at. With the R3 version of Bactrack I don't have acess to the grub once it's installed on hard-disk and it seems to install it with default settings (vga=791) so basically I'm stuck because when it boots, it load everything, no login, no startx requiered and no grub acess so I can't edit anything.

    Questions :
    1. Is it possible to modify the boot option before it launch startx automatically with a hotkey or something ?
    2. If not, is it possible to modify the boot option from the ISO directly ?

    Thank you for your time

  2. #2
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    4

    Default Re: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    This is the same promblem i have also.
    Were do i change once installed, I need to change it to 'xforcevesa" it allows the live to work with no issues.
    So i know there has to be some were i can change when i use live to acces the HD and edit it.
    Thank you for any help you can give.

  3. #3
    Just burned his ISO
    Join Date
    Oct 2012
    Posts
    1

    Default Re: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    Hello Everyone too,

    I had the same problem on my Acer Aspire One, the screen went black after the Ubuntu 10.04 screen, the most appearing solution is to edit the grub.cfg file. Your problem with editing the grub.cfg sounds similar to mine, so thats what I did:

    Make sure you are editing the right file ! The file in /boot/grub/grub.cfg only have reading access so all you´re going to edit on this file will be lost after the next reboot. ( I edited this file about 5 times) Edit the file in /etc/default/grub/grub.cfg ,because there you also have writing access ( as root for sure), then you can save your changes without loosing them by rebooting. Don´t forget to update grub with "update-grub" , otherwise your changes don´t become operative.

    I hope it will help you !

    happyPancake

  4. #4
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    4

    Question

    I did the same thing lol. Oddly i dont have a grub folder in /etc/defualt/NOGRUNB .... theres a grub.d but it has no grub file.

    Quote Originally Posted by D4rkH4nd8 View Post
    I did the same thing lol. Oddly i dont have a grub folder in /etc/defualt/NOGRUNB .... theres a grub.d but it has no grub file.

    (UPDATE) I have some how gotten to boot from HD by spamming the E key when it goes to the black screen. It just starts right up. If i dont it just sits at a black screen with blinking white curser/bar what ever.
    SO thats 1/2 of the issue lol. Now if i can fix it so i dont have to spam the button. Cause some times it wont work and i have to power down 3 ~4 times and try again.
    Last edited by g0tmi1k; 11-11-2012 at 04:24 AM. Reason: Merged

  5. #5
    Just burned their ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Re: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    I'm having the same problem with my BT5R3 install. After POST I tell it to boot to the USB drive and it just sits at a black screen with a blinking cursor. I tried spamming e like you said and it doesn't work for me. Wondering if you found a fix.

  6. #6
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    2

    Default Re: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    select recovery mode at boot and then go down to the last option and open a root terminal

    login
    then

    startx

    nano /etc/default/grub

    then
    go to where it says "VGA=791"
    edit to your liking (i used "VESA=315")
    and then

    update-grub


    solved it for me and I am now typing on my asus running backtrack

  7. #7
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    3

    Default Re: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    I also had that problem after installing Backtrack 5 R3
    changed the grub to vega=0x315 runs perfectly now.

    But i dont get my resolution higher then 800x600 would like to change that to 1024x768

    anybody?

  8. #8
    Just burned their ISO
    Join Date
    Mar 2011
    Posts
    2

    Default Re: [BACKTRACK 5 R3] Blackscreen after installation on HD ( netbook )

    I have the same issue with my aspire one. After hd boot i see a purple ubuntu 10.4 splash screen and after that screen goes black. I dont have a clueon what to do, I cant get the terminal open in anyway... Anybody ?

Similar Threads

  1. Dual boot BT5R2 + Win7 on UEFI netbook with existing Win7-installation
    By fighterhayabusa in forum BackTrack 5 Beginners Section
    Replies: 16
    Last Post: 01-17-2013, 09:17 PM
  2. Replies: 9
    Last Post: 03-28-2012, 01:54 AM
  3. Backtrack 5 Blackscreen after install
    By exeption in forum BackTrack 5 Bugs
    Replies: 5
    Last Post: 02-05-2012, 06:11 PM
  4. video crashes - new netbook - HP, dm 1-3025dx, netbook
    By infrared in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 09-20-2011, 04:10 PM
  5. Backtrack Compatible/blackscreen/anthros
    By thtazinboi in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-22-2008, 02:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •