You can thank PherricOxide for this fix, he was the one that reported the bug and fix. It seems like a lot of people are having this problem with packages not installing or updating and then erroring out with odd dependency issues. I believe that the issue only occurs with a fresh install of BTR3 x64 (I'm using Gnome, not sure about KDE).

Here is the Redmine bug report (link):

Code:
The following packages have unmet dependencies:
libapr1-dev: Depends: libapr1 (= 1.3.8-1build1) but 1.3.8-1ubuntu0.3 is to be installed
libaprutil1-dev: Depends: libpq-dev but it is not going to be installed
Depends: libmysqlclient-dev but it is not going to be installed
libcurl4-gnutls-dev: Depends: libcurl3-gnutls (= 7.19.7-1ubuntu1) but 7.19.7-1ubuntu1.1 is to be installed
libnotify-dev: Depends: libdbus-glib-1-dev (>= 0.35) but it is not going to be installed
Depends: libgtk2.0-dev (>= 2.10) but it is not going to be installed
E: Broken packages
It seems that adding the updates mirror with,
Code:
deb http://updates.repository.backtrack-linux.org revolution main microverse non-free testing
in sources.list fixed the problems. If this is intentionally left out nevermind, but it seems that with the number of packages that are unable to install without it that it should be in the mirror list by default?
It worked for me, hope this helps some other people out.