Hello,

I'm building a shell script that updates the woefully out of date version of snort that ships with BT5r*. I want to know if there's a foolproof command I can run via command line to verify that the user running this script is running the script on a backtrack system, and prompts them if we fail to successfully identify the OS as running backtrack.

couple of ideas I have:

cut the text bt from uname -a or the motd
check for the existence of the /usr/share/wallpapers/backtrack directory

neither of these really seem foolproof. Any ideas?

Thanks in advance,

Also I plan on releasing this script via github when it's done, so if you have even a cursory interest, you can make it yours.