Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Problems with SVN up / msfupdate in BT5 r3

  1. #11
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    2

    Unhappy Re: Problems with SVN up / msfupdate in BT5 r3

    I have this error trying to update from apt-get pleasssssssse help:
    Setting up se-toolkit (4.2.1-bt0) ...
    svn: OPTIONS of 'http://svn.trustedsec.com/social_engineering_toolkit': could not connect to server (http://svn.trustedsec.com)
    dpkg: error processing se-toolkit (--configure):
    subprocess installed post-installation script returned error exit status 1
    Setting up w3af (1.2-bt1) ...
    tar: pybloomfiltermmap-0.2.0.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Exiting with failure status due to previous errors
    /var/lib/dpkg/info/w3af.postinst: line 4: cd: pybloomfiltermmap-0.2.0: No such file or directory
    python: can't open file 'setup.py': [Errno 2] No such file or directory
    svn: OPTIONS of 'https://w3af.svn.sourceforge.net/svnroot/w3af/trunk': could not connect to server (https://w3af.svn.sourceforge.net)
    dpkg: error processing w3af (--configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    se-toolkit
    w3af
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  2. #12
    Just burned their ISO
    Join Date
    Apr 2011
    Posts
    1

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    I got this working....

    Go to the following locations... (in my case)
    1) /opt/metasploit/apps/pro/msf3/modules/post/windows/gather/credentials/
    2) /opt/metasploit/msf3/modules/post/windows/gather/credentials/

    There you will find this "outlook.rb" and its leftover files like "outlook.rb.r15730" "outlook.rb.r16024"
    Next delete all the above files.

    And now run msfupdate , this will update the missing "outlook.rb"

    hope this will help you .

  3. #13
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    10

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    @Lancha: I've seen that same error message before after MSF didn't exit cleanly. A reboot did the trick for me.

  4. #14
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    3

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    Quote Originally Posted by Urbexx View Post
    1 - Go to Places> Search for files> Search for outlook.rb in file system!
    2 - Delete all files found
    3 - Open the terminal> msfupdate
    Ding Ding Ding!!! It's a winner.
    Thanks Urbexx.

  5. #15
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    1

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    I'm currently having similar errors. This my output for the following commands:

    root@bt:~# msfupdate[*][*] Attempting to update the Metasploit Framework...[*]
    [*] Deprecation Note: The next version of Metasploit will[*] update over the git protocol, which requires outbound[*] access to github.com:9418/TCP.[*] Please adjust your egress firewall rules accordingly.
    svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
    svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
    svn: This client is too old to work with working copy '.'. You need
    to get a newer Subversion client, or to downgrade this working copy.
    See http://subversion.tigris.org/faq.htm...-format-change
    for details.
    svn: /opt/framework/lib/libssl.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
    svn: /opt/framework/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework/lib/libserf-0.so.0)
    svn: This client is too old to work with working copy '.'. You need
    to get a newer Subversion client, or to downgrade this working copy.
    See http://subversion.tigris.org/faq.htm...-format-change
    for details.


    root@bt:/pentest/exploits/framework# svn cleanup
    svn: E155036: Please see the 'svn upgrade' command
    svn: E155036: Working copy '/opt/framework/msf3/lib' is too old (format 10, created by Subversion 1.6)
    root@bt:/pentest/exploits/framework# svn upgrade
    svn: E155019: Can't upgrade '/opt/framework/msf3' as it is not a pre-1.7 working copy directory
    svn: E150000: Missing default entry
    root@bt:/pentest/exploits/framework#


    root@bt:/pentest/exploits/framework# ./msfconsole
    /opt/framework/msf3/lib/readline_compatible.rb:34:in `require': no such file to load -- windows_console_color_support (LoadError)
    from /opt/framework/msf3/lib/readline_compatible.rb:34:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:71:in `require'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:71:in `initialize'
    from ./msfconsole:130:in `new'
    from ./msfconsole:130:in `<main>'
    root@bt:/pentest/exploits/framework#

  6. #16
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    1

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    I am having a similar problem... First my armitage and framework3 weren't updating and so I had to:

    apt-get remove framework3
    apt-get update
    apt-get upgrade
    ... and so on

    and finally :

    apt-get install framework3

    and I finally managed to get the newer version! But later on I tried the usual msfupdate and I was not able to update
    So I tried the msfupdate in the commandline instead of the terminal and finally I was able to update

    But now when I try to open any of the msfs I encounter a problem opening them. Problem with the ruby gems! (except the msfgui)
    I have done this many times but this process seems to not work. Any chance?

  7. #17
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Problems with SVN up / msfupdate in BT5 r3

    You might want to post exact problem, not just .rb issue.

    just rename the outlook.rb:

    mv /opt/metasploit-4.4.0/msf3/modules/post/windows/gather/credentials/outlook.rb /opt/metasploit-4.4.0/msf3/modules/post/windows/gather/credentials/outlook.rb.backup

    Now try to open up msfconsole, if it does not work, update: msfupdate and rerun msfconsole..

    Luck.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. BT5-Gnome-VM: msfupdate does not work
    By halo3 in forum BackTrack 5 Beginners Section
    Replies: 6
    Last Post: 05-26-2011, 09:34 PM
  2. BT5-Gnome-VM: msfupdate does not work
    By halo3 in forum BackTrack 5 Bugs
    Replies: 1
    Last Post: 05-12-2011, 05:55 AM
  3. Error al actualizar Metasploit con msfupdate
    By hackmaf in forum Soporte en Software
    Replies: 2
    Last Post: 01-17-2011, 03:30 AM
  4. Framework3-MsfUpdate not working?
    By imported_mzer0 in forum OLD Latest Public Release - BackTrack4 Beta
    Replies: 0
    Last Post: 03-03-2009, 06:53 AM
  5. Framework3 Msfupdate failed
    By Bud Jones in forum OLD Pentesting
    Replies: 7
    Last Post: 02-14-2009, 04:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •