My apologies if this is in the wrong place.

running into an issue using svn up to update MSF. I'm using to being able to use svn up to update the framework directory, but doing so in R3 nets me the following error:

Code:
this client is too old to work with working copy '.' . You need to get a newer Subversion client, or to downgrade this working copy. See http://subversion.tigris.org/faq.htm...-format-change for details.
so... I do that, get redirected to the apache subversion faq, and find this:

http://subversion.apache.org/faq.htm...-format-change

I wget the python script in question, and based off of another document I found via google-fu, run the script as such:

Code:
python change-svn-wc-format.py /pentest/exploits/framework 1.5
and get the error:
Code:
Unrecognized WC format 12 in '/pentest/exploits/framework/.svn/entries'; only formats 8,9 and 10 can be supported.
So figuring that the howto I found on google is outdated or wrong, I tried other things.

I tried updating the svn client and apt says its fully updated. As a last resort, I try the msfupdate script in the directory and that works. I'm using that for now and if this is the supported method of doing it, that's fine. Tell me to eff off, and I'll go about my business. I'm just curious as to why svn up no longer works, yet msfupdate, svn-based, does work.

Thanks,

DA