Results 1 to 6 of 6

Thread: Startx error

  1. #1
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    2

    Default Startx error

    I tried to get x server up and running by giving startx after i logged in but nothing happened. I have to note two things:
    a)it's a new problem, yesterday i had x running normally
    b)i searched the last 2 lines of the log i give below but couldn't solve it (i tried this solution only [http://www.jaredlog.com/?p=115] because the most of threads i "met" was about freebsd).

    startx output:

    Code:
    hostname: Name or service not known
    xauth: (argv):1:  bad display name "laptop:0" in "list" command
    xauth: (stdin):1:  bad display name "laptop:0" in "add" command
    
    
    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-27-server i686 Ubuntu
    Current Operating System: Linux laptop 2.6.38 #1 SMP Thu Mar 17 20:52:18 EDT 2011 i686
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.38 root=UUID=fa74469f-9530-40d5-ae4c-5cddba59c98e ro text splash nomodeset vga=791
    Build Date: 08 March 2011  08:22:50AM
    xorg-server 2:1.7.6-2ubuntu7.6 (For technical support please see http://www.ubuntu.com/support) 
    Current version of pixman: 0.16.4
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 13 16:14:35 2012
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d"
    (II) [KMS] drm report modesetting isn't supported.
      XRANDR name: VGA-0
      Connector: VGA
      CRT1: INTERNAL_DAC1
      DDC reg: 0x60
      XRANDR name: LVDS
      Connector: LVDS
      LCD1: INTERNAL_LVDS
      DDC reg: 0x1a8
      XRANDR name: DVI-0
      Connector: DVI-I
      DFP1: INTERNAL_TMDS1
      DDC reg: 0x64
    Dac detection success
    finished output detect: 0
    finished output detect: 1
    Unhandled monitor type 0
    finished output detect: 2
    finished all detect
    Dac detection success
    Unhandled monitor type 0
    Entering TV Save
    Save TV timing tables
    saveTimingTables: reading timing tables
    TV Save done
    disable LVDS
    disable primary dac
    disable LVDS
    disable LVDS
    init memmap
    init common
    init crtc1
    init pll1
    freq: 68900000
    best_freq: 68785714
    best_feedback_div: 107
    best_frac_feedback_div: 0
    best_ref_div: 7
    best_post_div: 6
    restore memmap
    restore common
    restore crtc1
    restore pll1
    finished PLL1
    set RMX
    set LVDS
    enable LVDS
    disable primary dac
    
    waiting for X server to shut down disable LVDS
    finished PLL2
    finished PLL1
    Entering Restore TV
    Restore TV PLL
    Restore TVHV
    Restore TV Restarts
    Restore Timing Tables
    Restore TV standard
    Leaving Restore TV
    error setting MTRR (base = 0xc8000000, size = 0x08000000, type = 1) Inappropriate ioctl for device (25)
     ddxSigGiveUp: Closing log
    
    
    xauth: (argv):1:  bad display name "laptop:0" in "remove" command
    Thanks for having developed such a beloved and supporting community and for your time.
    Last edited by zen3GR; 07-13-2012 at 09:48 AM.

  2. #2
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Startx error

    Please, would you post the content of:
    1. /etc/hosts
    2. /etc/hostname
    3. /etc/hosts.allow
    4. /etc/hosts.deny

    Need to check if localhost and 127.0.1.1 (your hostname) are present or has not been modify...

  3. #3
    Just burned his ISO
    Join Date
    Jul 2012
    Location
    End of the Net
    Posts
    4

    Default Re: Startx error

    It sounds to me like your hostname and hosts file don't match up. Can you post:

    cat /etc/hostname
    cat /etc/hosts

  4. #4
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    2

    Default Re: Startx error

    Thanks for your time!

    1. /etc/hosts
    Code:
    laptop
    #::1 localhost localhost.localdomain laptop.localdomain
    #127.0.0.1 localhost localhost.localdomain laptop.localdomain
    2. /etc/hostname
    Code:
    laptop
    3. /etc/hosts.allow
    Code:
    # /etc/hosts.allow: list of hosts that are allowed to access the system.
    #                   See the manual pages hosts_access(5) and hosts_options(5).
    #
    # Example:    ALL: LOCAL @some_netgroup
    #             ALL: .foobar.edu EXCEPT terminalserver.foobar.edu
    #
    # If you're going to protect the portmapper use the name "portmap" for the
    # daemon name. Remember that you can only use the keyword "ALL" and IP
    # addresses (NOT host or domain names) for the portmapper, as well as for
    # rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
    # for further information.
    #
    4. /etc/hosts.deny
    Code:
    # /etc/hosts.deny: list of hosts that are _not_ allowed to access the system.
    #                  See the manual pages hosts_access(5) and hosts_options(5).
    #
    # Example:    ALL: some.host.name, .some.domain
    #             ALL EXCEPT in.fingerd: other.host.name, .other.domain
    #
    # If you're going to protect the portmapper use the name "portmap" for the
    # daemon name. Remember that you can only use the keyword "ALL" and IP
    # addresses (NOT host or domain names) for the portmapper, as well as for
    # rpc.mountd (the NFS mount daemon). See portmap(8) and rpc.mountd(8)
    # for further information.
    #
    # The PARANOID wildcard matches any host whose name does not match its
    # address.
    #
    # You may wish to enable this to ensure any programs that don't
    # validate looked up hostnames still leave understandable logs. In past
    # versions of Debian this has been the default.
    # ALL: PARANOID

  5. #5
    Just burned his ISO
    Join Date
    Aug 2012
    Posts
    2

    Default Re: Startx error

    I'm getting the same thing with the last two RCs of Backtrack as well. I'm using the RCA out on a ATI video card and getting squat back. DVD Boots, i get a boot: prompt thru trial and error found out hitting enter gets past that (yet same releases in 64 bit didnt need it for the dual core running RC 2), i get the root@bt: prompt, k i know startx goes in there from the 64 bit version and pluhhhh..tv goes blue from no signal, DVD spins a few more times. Thats where it sits. This is the first time ive run the 32 bit versions and they aint dual cores so i cant rung the 64. Is there some Xorg Cheat idea like Puppy has to fool the installer to not use the out of the box desktop settings and force it to the output instead. Ubuntu 10,11,and 12 all pick up that output just fine and im really getting antsy to try the 32 bit RC3. No i dont have a spare monitor and thats half the problem, using tvs here...Any reply would be helpful, I am fairly noobish to this all so bear with me.

  6. #6
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    1

    Default Re: Startx error

    Quote Originally Posted by N2KMaster View Post
    I'm getting the same thing with the last two RCs of Backtrack as well. I'm using the RCA out on a ATI video card and getting squat back. DVD Boots, i get a boot: prompt thru trial and error found out hitting enter gets past that (yet same releases in 64 bit didnt need it for the dual core running RC 2), i get the root@bt: prompt, k i know startx goes in there from the 64 bit version and pluhhhh..tv goes blue from no signal, DVD spins a few more times. Thats where it sits. This is the first time ive run the 32 bit versions and they aint dual cores so i cant rung the 64. Is there some Xorg Cheat idea like Puppy has to fool the installer to not use the out of the box desktop settings and force it to the output instead. Ubuntu 10,11,and 12 all pick up that output just fine and im really getting antsy to try the 32 bit RC3. No i dont have a spare monitor and thats half the problem, using tvs here...Any reply would be helpful, I am fairly noobish to this all so bear with me.
    You should edit your /etc/hosts file. Try adding this:
    127.0.0.1 localhost.localdomain

Similar Threads

  1. Error on startx
    By sostentado in forum BackTrack 5 General Topics
    Replies: 11
    Last Post: 07-10-2011, 05:44 PM
  2. No puedo iniciar STARTX, recibo error "FATAL SERVER ERROR"
    By dfmex in forum Soporte en Hardware
    Replies: 2
    Last Post: 02-24-2011, 10:45 PM
  3. Error on Startx
    By pchanx69 in forum OLD BackTrack 4 General Support
    Replies: 1
    Last Post: 02-14-2010, 03:15 AM
  4. StartX Error
    By blarch3030 in forum OLD BackTrack 4 General Support
    Replies: 1
    Last Post: 10-01-2009, 08:21 AM
  5. startx error: Another fluxbox after typing startx!
    By Israel213 in forum OLD BackTrack 3 Final
    Replies: 4
    Last Post: 01-23-2009, 09:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •