Results 1 to 5 of 5

Thread: Issues getting Hamster / Ferret to work properly

Hybrid View

  1. #1
    Member
    Join Date
    Dec 2011
    Posts
    86

    Default Issues getting Hamster / Ferret to work properly

    I've been messing around with Hamster and Ferret lately and have gotten it to work on BT5R2 x64 to the extent that it will sniff packets and find targets and not kick back mon0 like it does out of the box (I used the fix on these forums that allows the apps to work on x64 opposed to simply x32) but now I am posed with several other issues:

    -no matter what I seem to do with iwconfig or airmon-ng I am unable to have hamster/ferret sniff on any other channel than channel 6 of my wifi adapter (mon0), the app just seems to want to default to channel 6. how can this be addressed? has anyone else had this issue or found a fix.

    -my second problem is that when I access the hamster / ferret web ui via firefox (I make sure to clear my cookies first) and when targets and database's start to populate the corresponding links to the target do not show up on the left side in the frame. my firefox uses noscript and I allow 127.0.0.1:1234 or whatever it is to the exceptions. has anyone else had this issue? is there something I am doing wrong here?

    I know this program is long since unsupported but it still seems to work for some since it is still pre-installed on backtrack. as a backup plan I was debating running the 32bit version from a virtual machine within 64bit but I was hoping to avoid this since I love RAM

    any help would be greatly appreciated, thanks!

  2. #2
    Senior Member
    Join Date
    Jul 2011
    Posts
    236

    Default Re: Training a 64-bit Ferret..

    thad0ctor,

    Check out My Fix
    V/r,
    Snafu
    Pffbt..[quote]I made a discovery today. I found a computer. Wait a second, this is cool. It does what I want it to. If it makes a mistake, it's because I screwed it up. Not because it doesn't like me... Or feels threatened by me.. Or thinks I'm a smart ass.. [/quote]

  3. #3
    Member
    Join Date
    Dec 2011
    Posts
    86

    Default Re: Issues getting Hamster / Ferret to work properly

    thanks for the reply. it was actually ur posted that got it working for me and I just figured out how to change the channel using the --channel parameter but now my issue is I'm sniffing and the hamster web ui says that there are 2 targets and 2 database but the hamster.txt file is empty and the web ui is not showing any of the clone links...

  4. #4
    Senior Member
    Join Date
    Jul 2011
    Posts
    236

    Default Re: thad0ctor

    thad0ctor,

    I myself have not run into this issue. Tonight sometime, I will setup a test lan and see what I come up with.....
    V/r,
    Snafu
    Pffbt..[quote]I made a discovery today. I found a computer. Wait a second, this is cool. It does what I want it to. If it makes a mistake, it's because I screwed it up. Not because it doesn't like me... Or feels threatened by me.. Or thinks I'm a smart ass.. [/quote]

  5. #5
    Member
    Join Date
    Dec 2011
    Posts
    86

    Default Re: thad0ctor

    on a fresh install of BT5 r2 the issue no longer persists.. odd. I'll let you know if it continues to be an issue, in the mean time I'll be struggling to get driftnet and arachni to work

Similar Threads

  1. What happened to Ferret/Hamster and Wifezoo?
    By Maverick13 in forum BackTrack 5 Tool Requests (NOW CLOSED) Please see sticky
    Replies: 2
    Last Post: 06-08-2011, 12:25 AM
  2. Hamster/Ferret not working properly
    By Omegga in forum Beginners Forum
    Replies: 0
    Last Post: 10-18-2010, 07:41 PM
  3. [Video] Session Sidejacking (Ferret and Hamster)
    By g0tmi1k in forum BackTrack Videos
    Replies: 15
    Last Post: 09-16-2010, 05:00 AM
  4. [Video] Session Sidejacking (Ferret and Hamster)
    By imported_g0tmi1k in forum OLD BackTrack 4 Howto
    Replies: 2
    Last Post: 03-19-2010, 08:57 PM
  5. ferret hamster but for *nix ?
    By opreat0r in forum OLD General IT Discussion
    Replies: 5
    Last Post: 03-20-2008, 09:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •