Trying john the ripper with the wordlist that comes with it:

Code:
root@bt:/pentest/passwords/john# ./john --wordlist:password.lst |aircrack-ng -b XX:XX:XX:XX:XX:XX -w - /tmp/wpa*.cap
but it doesn't seem to recognize the password file even though I checked it's there. The output is:

Code:
Password files required, but none specified
Opening /tmp/wpa-01.cap
Opening /tmp/wpa-02.cap
Opening /tmp/wpa-03.cap
Opening /tmp/wpa-04.cap
Reading packets, please wait...

                                 Aircrack-ng 1.1 r2076
Passphrase not in dictionary 

                              0






















Quitting aircrack-ng...
I tried various wordlists of different sizes, they all have that 0 except when I ran john without parameters (root@bt:/pentest/passwords/john# john |aircrack-ng -b, etc.) That time it said 46 instead of 0. However, the incremental attack works fine.

I have version 1.7.9-jumbo-6 [linux-x86-sse2] and bt 3.2.6. Any assistance would be appreciated.