Page 1 of 16 12311 ... LastLast
Results 1 to 10 of 159

Thread: Getting wesside-ng working on bt2 with atheros chipsets

  1. #1
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default Getting wesside-ng working on bt2 with atheros chipsets

    Scrap mot of this post nd goto post 22 sorry guys fluffed up abit lol

  2. #2
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    maybe writing a xxx.patch file could be a nice idea .......

    2 seconds but have no ath card to test it .......

    i got the same pb with wesside-ng for my rt73s.....

    was not able to fix it ...... so maybe someone got a solution......
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  3. #3
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    There is a patch on the trac.aircrack site i think for the alfa r8187 but i could not get it to work.

  4. #4
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    yea I couldn't get the patch to work so I wrote the mod like this because I can't write patches lol

  5. #5
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Well I just tried it but I couldnt get it to work. You should just upload the modded file for people to replace theirs and then do a new make && install.

  6. #6
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    What was your problem purehate?

  7. #7
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    I mean I only did it kinda fast but after editing the file I tried to make it and got a whole rash of errors.

  8. #8
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    http://rapidshare.com/files/71061230...3n.tar.gz.html

    Patched and ready for compiling Please be aware this is a quick dirty patch that worked for me and it may not work for everybody.

  9. #9
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Do I need to run the patch or is it already patched because here is my out put
    Code:
    purehate madwifi-0.9.3.3 # ls
    BuildCaps.inc   hal/
    COPYRIGHT       include/
    INSTALL         kernelversion.c
    Makefile        madwifi-ng-r2662-dirty_wesside-ng_fix.patch
    Makefile.inc    net80211/
    Module.symvers  patches/
    README          prga.log
    THANKS          regression/
    ath/            release.h
    ath_hal/        scripts/
    ath_rate/       svnversion.h
    contrib/        tools/
    docs/           wep.cap
    purehate madwifi-0.9.3.3 # patch -Np1 -i madwifi-ng-r2662-dirty_wesside-ng_fix.patch
    can't find file to patch at input line 5
    Perhaps you used the wrong -p or --strip option?
    The text leading up to this was:
    --------------------------
    |Index: ath/if_ath.c
    |===================================================================
    |--- ath/if_ath.c       (revision 2662)
    |+++ ath/if_ath.c       (working copy)
    --------------------------
    File to patch: ath/if_ath.c
    patching file ath/if_ath.c
    Reversed (or previously applied) patch detected!  Skipping patch.
    5 out of 5 hunks ignored -- saving rejects to file ath/if_ath.c.rej
    purehate madwifi-0.9.3.3 #

  10. #10
    Very good friend of the forum drgr33n's Avatar
    Join Date
    Jan 2010
    Location
    Dark side of the moon ...
    Posts
    699

    Default

    Download that file I uploaded and install, reboot and when you run wesside you should now see

    Code:
    drgr33n crap # wesside-ng -i ath1 -m 192.168.1.64 -n 192.168.1.254
    [17:14:39] Using mac 06:0F:B5:EC:8F:1A
    [17:14:39] WARNING: Appending in wep.cap
    [17:14:39] WARNING: reading prga from prga.log
    [17:14:39] Got 342 bytes of prga IV=(db:56:33) PRGA=00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
    [17:14:39] Looking for a victim...
    [17:14:39] Found SSID(BTHomeHub-A905) BSS=(00:18:F6:79:1E:51) chan=7
    [17:14:39] Authenticated
    [17:14:39] Associated (ID=1)
    [17:14:39] Sending arp request for: 192.168.1.254
    [17:14:39] Got arp reply from (00:18:F6:79:1E:50)
    [17:15:33] WEP=000010162 (next crack at 10000) IV=89:f4:6e (rate=140)
    [17:15:33] Starting crack PID=7661
    [17:15:35] WEP=000010606 (next crack at 20000) IV=7a:f5:6e (rate=211)
    
    [17:15:37] Stopping crack PID=7661
    Are you trying to patch the package I uploaded ? or a fresh download?? or have you tried to patch the driver before? Duno why you got that error purehate?

    Also I found that before I was only getting around 80 to 120 iv's sec with the madwifi new drivers but with the patch im now getting 400

Page 1 of 16 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •