Results 1 to 7 of 7

Thread: Prevent BackTrack from connecting on the net

  1. #1
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    7

    Default Prevent BackTrack from connecting on the net

    ok, i know this is awkward, but i'm having some problems from preventing BackTrack to wake up my network cards (wifi and ethernet).

    When I first installed BT (persistent install with dual-boot), I took a look the FAQ page, in order to automatically connect my laptop with Internet (me dumb...).

    I followed the instruction that you can find here (Getting Networking to Work), so I updated my /etc/network/interfaces file with my information.

    Then i realized that was quite stupid to do so, so I tried to revert everything to the origin.
    Sadly, I couldn't.

    First of all remove every line from the interface file, then i removed the upstart job:
    Code:
    update-rc.d -f networking remove
    everything seems to work fine, except that when i rebooted my pc, i got every interface up and running.
    the weird thing is that if i try to remove that job again (without the force options) , i get:
    Code:
    /etc/init.d/networking exists during rc.d purge (use -f to force)
    and so again and again.. i really can't remove this job from the upstart...

    where am i wrong?

  2. #2
    Member
    Join Date
    Feb 2010
    Location
    Somewhere in the hell
    Posts
    91

    Default Re: Prevent BackTrack from connecting on the net

    @tampe125,

    I think the simply way is to re-install Back|Track 5 R2.

    Samiux

  3. #3
    Just burned his ISO
    Join Date
    Sep 2010
    Posts
    7

    Default Re: Prevent BackTrack from connecting on the net

    ok, i just re-intalled everything and...
    my interfaces are still up.

    this is weird

    any help?

  4. #4
    Senior Member VulpiArgenti's Avatar
    Join Date
    Sep 2011
    Location
    lost
    Posts
    174

    Default Re: Prevent BackTrack from connecting on the net

    Unfortunately BT5 boots with networking enabled. This describes my workaround:

    http://www.backtrack-linux.org/forum...ad.php?t=47118

    Please post a better solution if you find one.

  5. #5
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Prevent BackTrack from connecting on the net

    Remove wicd and reinstall it, or install the Network-Manager, it will automatically uninstall wicd....If you have the Network manager installed, do the reverse way, install the wicd, it will automatically remove the Network Manager.

    Check if the service (wicd or Network Manager) is up and running (type ps -A and look for the wicd or NetworkManager), if so, need to kill the deamon or try to avoid loading it.

    Please, read the: chkconfig command...It may very well help you...

    Here is a link (spanish), but just read the commands and it will help you: http://www.linuxtotal.com.mx/index.p...info_admon_003

    You do not need to speak spanish to understand it..Any translation help, let me know. By the way, use the Translation option in Firefox or Iceweasil....

  6. #6
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    14

    Default Re: Prevent BackTrack from connecting on the net

    Just comment out the interface in /etc/network/interfaces you want to prevent connecting and type:
    Code:
    iface [interface] off

  7. #7
    Very good friend of the forum maverik35's Avatar
    Join Date
    Sep 2009
    Location
    Debian land
    Posts
    734

    Default Re: Prevent BackTrack from connecting on the net

    Quote Originally Posted by schizodroid View Post
    Just comment out the interface in /etc/network/interfaces you want to prevent connecting and type:
    Code:
    iface [interface] off
    He needs to avoid networking deamon at start up, during boot, not disable iface...It can be done by removing the link Sxxwicd or network-manager and create a new link just changing the S for a K: Kxxwicd or network-manager, then run the update-rc.d script default...

    Need to know the default runlevel for BT5. This can be done by typing "who -r".. Or edit the /etc/inittab file, and look for the line with:
    # The default runlevel.
    id:X:initdefault:
    The X is the runlevel.

    Then if run level is, per say 2, need to go to folder /etc/rc2.d, under wihich you will see all links.....Every link goes to /etc/init.d, the S means "Start", the "k" means Kill..The scripts under /etc/init.d allow parameters : start, stop restart, status. So if you have a link to /etc/init.d/ to stop wicd or Network-Manager, you need to send this during boot, as I stated before,...Ex. K21wicd which is a link to /etc/init.d/wicd stop (because of the K at the begining of K21wicd)....

    If you want to avoid all this things, use chkconfig, it will do it for you, just type:
    chkconfig --level X wicd off (the X is the runlevel where wicd service or daemon starts)

    Need to install chkconfig. See if it is in the BT5 repos, if not, download it.

    Hope it helps...
    Last edited by maverik35; 07-02-2012 at 11:14 AM.

Similar Threads

  1. A tool/theory to prevent all MiTM attacks for any computer
    By ShadowMaster in forum BackTrack 5 Experts Section
    Replies: 18
    Last Post: 02-03-2012, 12:50 PM
  2. Prevent aireplay-ng DeAuth attack
    By TuxSudo in forum BackTrack 5 Beginners Section
    Replies: 1
    Last Post: 09-16-2011, 12:04 AM
  3. Can some router prevent arp spoofing ?
    By ronin101 in forum BackTrack 5 General Topics
    Replies: 10
    Last Post: 07-24-2011, 04:20 PM
  4. Prevent Mounting of NTFS drives?
    By thorin in forum OLD BT3final Support
    Replies: 4
    Last Post: 05-12-2009, 08:50 AM
  5. How to Prevent Brute-Force Cracking?
    By radioraiders in forum OLD Wireless
    Replies: 10
    Last Post: 10-13-2008, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •