Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: ALSA error while loading backtrack

Hybrid View

  1. #1
    confuded
    Guest

    Default ALSA error while loading backtrack

    Hi all .

    I've got an Acer Ferrai 1000 notebook and I am trying to boot into LIVE cd (via my disk C:\ since firewire drives are not supported by backtrack; first i boot from firewire drive thought). I get the folowing error every time I want to boot (half way through install):

    ...tmp/2.6.20/src-drivers/alsa-driver-1.0.14rc2/pci/hda/hda_codec.c:216 hda_code invalid dep_range_value...

    It repeats a million times so it is hard to read it . BUT eventually it stops an continues loading and boots backtrack normaly. NOW I've made an HD install and it does it again every time!

    PLEASE tell what might be the problem and how to fix it. I think ALSA is something to do with sound (driver maybe).

    THANKS ").

  2. #2
    confuded
    Guest

    Default Comm on!

    So nobody know a command how to stop loading this sound driver on boot? I don't need sound at all! Anyone know how to disable all the ALSA (sound) drivers on boot?

  3. #3
    Member imported_blackfoot's Avatar
    Join Date
    Jun 2007
    Posts
    386

    Default polling

    There appears to be a polling issue (unresolved here) between slax the foundation for the bt distribution and alsa.

    Since the problem is relatively shortlived and booting continues normally I suggest that you contact the alsa support forum and post a query regarding slax and alsa to resolve your issues.

    http://www-old.alsa-project.org/
    Lux sit

  4. #4
    confuded
    Guest

    Default

    Heh, thanks for the info. I would rather just disable the whole ALSA thing. I don't need sound in BackTrack . Thought if anyone knows the command or a way , that will be really helpful .

    Thanks again .

    P.S. I have to wait 10 minutes for it to stop repeating the rror so how is that 'short lived'?

  5. #5
    Just burned his ISO
    Join Date
    Oct 2006
    Posts
    12

    Default there is probably a better way

    I know there is probably a better way, however you could pull apart the iso and delete /opt/kde/share/sounds/KDE_Start_up_1.ogg to stop the KDE soundstart. Then repack the iso. This might work however, I have never done this.

  6. #6
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by confuded View Post
    Hi all .

    I've got an Acer Ferrai 1000 notebook and I am trying to boot into love cd (via my dick C;\ since firewire drives are not supported by backtrack; first i boot from firewire drive thought). I get the folowing error every time I want to boot (half way through install):

    ...tmp/2.6.20/src-drivers/alsa-driver-1.0.14rc2/pci/hda/hda_codec.c:216 hda_code invalid dep_range_value...

    It repeats a million times so it is hard to read it . BUT eventually it stops an continues loading and boots backtrack normaly. NOW I've made an HD install and it does it again every time!

    PLEASE tell what might be the problem and how to fix it. I think ALSA is something to do with sound (driver maybe).

    THANKS ").
    And that is supposed to mean what ?

    Forget it, come back when you can ask a proper question.

  7. #7
    confuded
    Guest

    Default

    DAMN, it was just a spelling mistake lol. I just realized what I wrote . I wrote in a hurry and didnt do the spell checker (i wrote it in IE not firefox lol). lo lol lol lol The live CD was copied to my C:\ drive on windows (i got this idea from PCLinuxOS since it suggested it when it failed to gind the firewire drive).

  8. #8
    killswitch92
    Guest

    Default

    i have the same error too when i try and boot it from the cd. i dont intend to install it just run it off the cd. so basically i just have to disable the sound or something?

    i have an acer aspire 5100 laptop

  9. #9
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

  10. #10
    Just burned his ISO
    Join Date
    Mar 2006
    Posts
    5

    Default

    My apologies for bringing up an old thread, but I want to give a possible solution for some of the people with this sound error...

    I own a Gateway MT6452 which uses the SB450 HDA Audio driver (ATI) which is in many other laptops, so the solution should apply to most of the laptops with an ATI chipset and sigmatel sound...

    - First navigate to /etc/modprobe.d/

    - Now create a file and call it "sound" (w/o quotes)

    - Open the file and insert

    Code:
    options snd-hda-intel probe_mask=3 position_fix=3
    - Then save the file and restart...

    Now when you boot up you should no longer receive the ALSA error spamming at you and you will be greeted with the beautiful sound of the BT boot

    It took me a couple hours of googling and thread searching to find this so I figured I'd make it a little bit easier on those still suffering from this problem...

    Credits for the solution go to
    burghardt.pl/2007/11/debian-gnulinux-on-acer-aspire-5102wlmi/

    ^^ Sorry couldn't link (<15 posts)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •