Results 1 to 5 of 5

Thread: Trying to play with WEP on a WAP11, but...

Hybrid View

  1. #1
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default Trying to play with WEP on a WAP11, but...

    Pulled this little guy off the shelf today so I could take my first crack at cracking WEP. Here's the hardware I'm playing with:

    Toshiba U305-S5077 laptop
    ALFA AWUS036H wireless card
    Linksys WAP11 access point

    I powered on the linksys and the ssid came up as "office", so I held down the reset button for 10+ seconds to reset it. I switched my card over to monitor mode to make sure the wap was broadcasting beacons, and it is. However, kwifimanager doesn't see it. So using the wap mac I got from wireshark, I manually associated with the ap, and iwconfig correctly reports me as associated and the essid as "linksys".

    The linksys is not plugged into a network, btw. The default setting on this thing is supposed to have its IP set to 192.168.1.251. Its just an access point, so no DHCP to hand out. So I issued ifconfig wlan1 192.168.1.250 followed by ifconfig wlan1 netmask 255.255.255.0. Pings wouldn't respond from 192.168.1.251, and a nmap ping sweep of the subnet showed only my computer.

    On the windows side, I tried plugging in the wap to the network and then connecting to it from XP. I got a dhcp address on my wireless card, meaning the wap is able to send and receive traffic and forward it on to the rest of the network.

    Can anyone see anything I'm missing? I can't play with wep if I can't configure the blasted wap to use wep. I'm just about ready to wop it.

  2. #2
    Member imported_blackfoot's Avatar
    Join Date
    Jun 2007
    Posts
    386

    Default sequencing

    With respect I think that you are mixing too many ideas at once.

    As you appear comfortable with the Windows OS perhaps you might connect to your AP and configure it by opening a browser and entering the admin section. You can configure WEP there.

    Once you are satisfied that you can access the system then move to using Linux.

    In Linux you will need to ensure that your card is listed in response to the command ifconfig and furthermore you can then utilise iwconfig to enter your parameters for connection. You will need to use a wpa_supplicant as you move to WPA variants.

    Kwifimanager is buggy I recall though it may have been updated.

    Finally you will need to manually call for the issue of an IP address once associated using dhcpcd interfacedevice

    You might then try to connect to the internet assuming that your AP has been appropriately connected.

    Finally, do progress to searching the forum here for details and advice for your card.
    Lux sit

  3. #3
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default

    That's just it, I can't connect directly to the AP at all, windows or backtrack. I can connect through it (which is why I mentioned doing so in XP), just not to it. This has nothing to do with my wireless card or WPA. Of course my wireless card is listed in ifconfig. Otherwise if I were to type "ifconfig wlan1 192.168.1.250" (like I said in the original post) I would get an error message. And how do you suppose I could switch my card over to monitor mode and pull beacons off with wireshark if in fact it wasn't showing up at all??!!

    The problem is either with the WAP itself or somewhere in my network settings. And for the record, a search of this forum produced zero threads referring to the WAP11, and wading through several pages of Google results produced none with the same problem. All of those just assume that a reset will allow you to connect on the default IP, which I can't.

  4. #4
    Senior Member streaker69's Avatar
    Join Date
    Jan 2010
    Location
    Virginville, BlueBall, Bird In Hand, Intercourse, Paradise, PA
    Posts
    3,535

    Default

    Quote Originally Posted by skiamakhe View Post
    That's just it, I can't connect directly to the AP at all, windows or backtrack. I can connect through it (which is why I mentioned doing so in XP), just not to it. This has nothing to do with my wireless card or WPA. Of course my wireless card is listed in ifconfig. Otherwise if I were to type "ifconfig wlan1 192.168.1.250" (like I said in the original post) I would get an error message. And how do you suppose I could switch my card over to monitor mode and pull beacons off with wireshark if in fact it wasn't showing up at all??!!

    The problem is either with the WAP itself or somewhere in my network settings. And for the record, a search of this forum produced zero threads referring to the WAP11, and wading through several pages of Google results produced none with the same problem. All of those just assume that a reset will allow you to connect on the default IP, which I can't.
    I'm seeing that the WAP11 has a possibility of two Default IP addresses, the one you stated, but it could also be 192.168.1.245.
    A third party security audit is the IT equivalent of a colonoscopy. It's long, intrusive, very uncomfortable, and when it's done, you'll have seen things you really didn't want to see, and you'll never forget that you've had one.

  5. #5
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default

    Yeah, i saw that, too. But I did a nmap ping sweep of the whole subnet and found nothing but my own IP. I went home over lunch to get an old d-link I have as well to see if I have better luck with it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •