Hello
Firstly, sorry for my bad english.

I recently installed Backtrack 5 R2 GNOME 64bits in my hard disk and I have a problem with the screen resolution.
My laptop is an ASUS N53SN with a Nvidia graphic card (Nvidia Geforce GT 550M CUDA 2GB).
The problem is that Backtrack doesn't recognize my real screen resolution, 1920x1080 in Windows 7 and Ubuntu 12.04 LTS but I only have three option in BT. In System -> Preferences -> Monitors. I have 1280x1024(5:4), 1280x768(4:3) and 800x600(4:3) and I'm still using 1280x1024 (5:4) however my real resolution is 4:3, but my desktop with 1280x768 is so huge.

This is the lspci | grep VGA result:

Code:
root@bt:~# lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df6 (rev a1)
I would add the /etc/X11/xorg.conf file, but it does not exists

I've tried to install the nvidia drivers for my card model. But when it creates a xorg.conf and I tap startx, it says
Code:
fatal error: no screens found.
So I tap rm /etc/X11/xorg.conf, then startx and nothing has changed.
I've tried to upgrade the nouveau driver, but failed because resolution doesn't change.
I've tried to add a new resolution with xrandr but give back an error.
I've looked for several xorg.conf in the web but some doesn't work and the others doesn't change anything or even downgrade the resolution. Just one upgrade my resolution a little. But it was 16:9 and awful. I modified it writting 1920x1080 in modes(Screen section), but nothing.
I've search the intel HD graphics driver and downloaded it but dont know how I can install it.
I've tried to solve the problem searching someone with a similar problem but have not any solution.

Here is the lspci output:

Code:
root@bt:~# lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation Device 0df6 (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
04:00.0 USB Controller: Fresco Logic FL1000G USB 3.0 Host Controller (rev 04)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
Also I have search a solution for this problem in this forum, but have not found.
After almost each attempt I have formatted the partition and resintall Backtrack.

I hope you can help me in this forum. Thanks so much.