Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Error in metasploit after UPDATE !!

  1. #1
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    18

    Default Error in metasploit after UPDATE !!

    when I update Metasploit Framework in BT5 R1 , show this error in console :

    /opt/framework/msf3/lib/msf/core/exploit/snmp.rb:2:in `require': no such file to load -- snmp (LoadError)
    from /opt/framework/msf3/lib/msf/core/exploit/snmp.rb:2:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core/exploit/mixins.rb:47:in `require'
    from /opt/framework/msf3/lib/msf/core/exploit/mixins.rb:47:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:217:in `require'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:217:in `<class:Exploit>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:29:in `<module:Msf>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:4:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core.rb:52:in `require'
    from /opt/framework/msf3/lib/msf/core.rb:52:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:1:in `require'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console.rb:10:in `require'
    from /opt/framework/msf3/lib/msf/ui/console.rb:10:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui.rb:10:in `require'
    from /opt/framework/msf3/lib/msf/ui.rb:10:in `<top (required)>'
    from /opt/framework/msf3/msfconsole:118:in `require'
    from /opt/framework/msf3/msfconsole:118:in `<main>'

  2. #2
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    1

    Default Re: Error in metasploit after UPDATE !!

    same over here, anyone an idea?

  3. #3
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    7

    Default Re: Error in metasploit after UPDATE !!

    Same error here after updating.

  4. #4
    Just burned his ISO
    Join Date
    Feb 2006
    Posts
    7

    Default Re: Error in metasploit after UPDATE !!

    I tested this on a fresh BT5R1 install.

    Before the update msfconsole works fine.

    After running msfupdate, msfconsole no longer works.
    Last edited by consumption; 09-07-2011 at 12:56 PM.

  5. #5
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    2

    Default Re : Error in metasploit after UPDATE !!

    i Have that Probleme TOO
    what We Can Do ?????????????


    Quote Originally Posted by datalife View Post
    when I update Metasploit Framework in BT5 R1 , show this error in console :

    /opt/framework/msf3/lib/msf/core/exploit/snmp.rb:2:in `require': no such file to load -- snmp (LoadError)
    from /opt/framework/msf3/lib/msf/core/exploit/snmp.rb:2:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core/exploit/mixins.rb:47:in `require'
    from /opt/framework/msf3/lib/msf/core/exploit/mixins.rb:47:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:217:in `require'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:217:in `<class:Exploit>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:29:in `<module:Msf>'
    from /opt/framework/msf3/lib/msf/core/exploit.rb:4:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/core.rb:52:in `require'
    from /opt/framework/msf3/lib/msf/core.rb:52:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:1:in `require'
    from /opt/framework/msf3/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui/console.rb:10:in `require'
    from /opt/framework/msf3/lib/msf/ui/console.rb:10:in `<top (required)>'
    from /opt/framework/msf3/lib/msf/ui.rb:10:in `require'
    from /opt/framework/msf3/lib/msf/ui.rb:10:in `<top (required)>'
    from /opt/framework/msf3/msfconsole:118:in `require'
    from /opt/framework/msf3/msfconsole:118:in `<main>'

  6. #6
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    1

    Default Re: Error in metasploit after UPDATE !!

    Revert to the previous version of the file.

    This is what I did:

    svn co http://metasploit.com/svn/framework3/trunk/ metasploit

    cd to metasploit/lib/msf/core/exploit
    svn up -r 11300
    backup your current snmp.rb file under /opt/framework/msf3/lib/msf/core/exploit
    copy the snmp.rb file from your snv copy

    Msfconsole starts up fine no errors but not sure if it breaks anything else

  7. #7
    Just burned his ISO
    Join Date
    Mar 2011
    Posts
    11

    Default Re: Error in metasploit after UPDATE !!

    same problem. Updated metasploit and got same error

  8. #8
    Just burned his ISO
    Join Date
    Aug 2011
    Posts
    2

    Default Re : Re: Error in metasploit after UPDATE !!

    doest work

  9. #9
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    2

    Default Re: Error in metasploit after UPDATE !!

    Found you can start msfconsole by going to he msf3 folder and executing it from there using the commands:

    cd /opt/framework/msf3
    ./msfconsole

    Anyone confirm it? Or is it just me?

  10. #10
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    1

    Red face Re: Error in metasploit after UPDATE !!

    CONFIRMED ABOVE!! This makes me feel so much better.

Page 1 of 3 123 LastLast

Similar Threads

  1. Metasploit Error after update
    By SajberKod in forum BackTrack 5 Bugs
    Replies: 11
    Last Post: 08-05-2011, 02:41 AM
  2. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  3. Ruby Gems Error after Metasploit Update
    By blakhal0 in forum BackTrack Bugs
    Replies: 7
    Last Post: 01-19-2011, 03:21 AM
  4. metasploit wont update:error
    By BigMac in forum OLD Newbie Area
    Replies: 7
    Last Post: 01-01-2010, 09:06 AM
  5. Svn Update Metasploit Error
    By fload in forum OLD Newbie Area
    Replies: 2
    Last Post: 02-27-2009, 09:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •