Results 1 to 5 of 5

Thread: Backtrack 5 R2 - Scapy

  1. #1
    Just burned his ISO
    Join Date
    Apr 2012
    Posts
    3

    Default Backtrack 5 R2 - Scapy

    Hallo!

    I am using the Live-Cd Backtrack 5 R2 Gnome. The installed version of scapy of this Live-CD is v2.0.1. In this version, I think there is a bug. When I am executing an ELF that uses scapy, it allways gives an error that tells me that tcpdump is not installed despite it is installed. I found out that the error comes from a wrong path definition in the file the linux.py.

    But the ELF I want to execute needs scapy v2.2.0. Therefor I went to http://www.secdev.org/projects/scapy/, downloaded v2.2.0 and installed it:
    # chmod +x scapy.py
    # ./scapy install

    But when I execute scapy, Backtrack tells me, that v2.0.1 is installed a not v2.2.0. I am not able to install v2.2.0.

    Can anyone tell me how to install v2.2.0 correctly?

    Thany you very much!

    Regards
    triplexxx

  2. #2
    Just burned his ISO
    Join Date
    Apr 2012
    Posts
    3

    Default Re: Backtrack 5 R2 - Scapy

    Solved!!

    You have to install scapy using the following command:
    # cd scapy-2.2.0
    # chmod +x setup.py
    # ./setup.py install --user

    --user was missing!

    Now it works pretty fine!

  3. #3
    Just burned his ISO lajjr's Avatar
    Join Date
    Feb 2010
    Location
    Open Net
    Posts
    15

    Default Re: Backtrack 5 R2 - Scapy

    triplexxx,

    The reason that this is happening is that both the scapy and the python-scapy is installed. the version of just scapy is 2.2.0-dev.
    Code:
    apt-get purge python-scapy
    and just install scapy
    Code:
    apt-get install scapy
    this fixes my error.
    I do get this error:
    WARNING: No route found for IPv6 destination :: (no default route?)
    Welcome to Scapy (2.2.0-dev)
    but the this can be suppress if you like by adding
    Code:
    import logging
    logging.getLogger("scapy.runtime").setLevel(logging.ERROR)
    before importing Scapy to suppress all messages below error messages
    Regards,
    Leo

  4. #4
    Just burned his ISO
    Join Date
    May 2012
    Posts
    1

    Default Re: Backtrack 5 R2 - Scapy

    Trying use trace3d and get an error:
    Code:
    >>> res.trace3d()
    Traceback (most recent call last):
      File "<console>", line 1, in <module>
      File "/usr/lib/pymodules/python2.6/scapy/plist.py", line 72, in __getattr__
        return getattr(self.res, attr)
    AttributeError: 'list' object has no attribute 'trace3d'
    Can anyone help???

  5. #5
    Just burned their ISO
    Join Date
    May 2012
    Posts
    3

    Default Re: Backtrack 5 R2 - Scapy

    Quote Originally Posted by lajjr View Post
    triplexxx,

    The reason that this is happening is that both the scapy and the python-scapy is installed. the version of just scapy is 2.2.0-dev.
    Code:
    apt-get purge python-scapy
    and just install scapy
    Code:
    apt-get install scapy
    this fixes my error.
    I do get this error:
    WARNING: No route found for IPv6 destination :: (no default route?)
    Welcome to Scapy (2.2.0-dev)
    but the this can be suppress if you like by adding
    Code:
    import logging
    logging.getLogger("scapy.runtime").setLevel(logging.ERROR)
    before importing Scapy to suppress all messages below error messages
    Regards,
    Leo
    Getting some other errors, besides the IPv6 dest one:

    INFO: Can't import python gnuplot wrapper . Won't be able to plot.
    INFO: Can't import PyX. Won't be able to use psdump() or pdfdump().

    ... any ideas?!?

    Thanks,
    Stefan

Similar Threads

  1. Problems with Scapy
    By ekisner in forum BackTrack 5 General Topics
    Replies: 0
    Last Post: 08-12-2011, 05:01 PM
  2. WifiZoo 1.3 and Scapy 2.x
    By joker5bb in forum OLD BackTrack 4 (pre) Final
    Replies: 1
    Last Post: 11-14-2009, 01:37 AM
  3. scapy bluetooth
    By valerio in forum OLD Programming
    Replies: 0
    Last Post: 11-02-2009, 03:57 PM
  4. scapy - MAC not found
    By zahizahir in forum OLD Newbie Area
    Replies: 0
    Last Post: 08-02-2009, 02:53 PM
  5. Scapy problem.
    By Lasperic in forum OLD Newbie Area
    Replies: 1
    Last Post: 06-02-2009, 09:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •