Results 1 to 1 of 1

Thread: Dell XPS 14z (L412Z) Core i7 Nvidia GT520M Optimus

Hybrid View

  1. #1
    Senior Member
    Join Date
    Feb 2010
    Posts
    146

    Default Dell XPS 14z (L412Z) Core i7 Nvidia GT520M Optimus

    Compatible BT5-R2 KDE 64 bit/Gnome 64 bit

    wifi injection works
    bluetooth works
    sound works (Master channel needs to be manually set under Kmix)
    encrypted installation works as well
    Dell hot keys and backlit keyboard detected and work (the eject button needs to have it's action mapped manually, and the wifi kill switch spits the following out)
    iwlwifi 0000:08:00.0: RF_KILL bit toggled to disable radio.
    iwlwifi 0000:08:00.0: Not sending command - RF KILL
    iwlwifi 0000:08:00.0: Error sending REPLY_RXON: enqueue_hcmd failed: -5
    iwlwifi 0000:08:00.0: Error clearing ASSOC_MSK on BSS (-5)
    iwlwifi 0000:08:00.0: Not sending command - RF KILL
    iwlwifi 0000:08:00.0: Error sending REPLY_LEDS_CMD: enqueue_hcmd failed: -5

    so i'll need to figure that out.


    here are the steps i took to get the video working, note these ppa's are not supported by the backtrack team. if you follow these steps and have problems, the support you receive from them will be limited if any, they have better things to do. but generally you can revert back to stock by (apt-get install ppa-purge, ppa-purge <name of ppa>)

    apt-add-repository ppa:ubuntu-x-swat/x-updates
    apt-add-repository ppa:xorg-edgers/ppa
    apt-add-repository ppa:bumblebee/stable
    apt-get update
    apt-get upgrade

    nano /etc/default/grub

    "i915.modeset=1 i915.i915_enable_rc6=1 i915.lvds_downclock=1 i915.i915_enable_fbc=1 pcie_aspm=force"

    nano /etc/modprobe.d/blacklist.conf

    add "blacklist nouveau"

    nano /etc/modules

    add "i915'

    update-initramfs -u -k all

    //also we're gonna need to install bumblebee, i tried using the distro without it and was chewing through my battery fast.

    apt-get install bumblebee

    //you should not need to add yourself to the bumblebee group unless you are a user that's not root

    //also, i suggest you don't try to "optirun" programs, as doing so generally ends in a crash or reboot.

    reboot

    ANOTHER NOTE: while this isn't the most stable solution, it will get you your desktop cube or whatever other kwin effects you use. we might just have to wait until updated X packages or BT6 comes out to get a real fix for this.

    good luck

    update-- upgrading to the A.05 Bios will break this fix... and pretty much any i915 support that backtrack 5 kernel 3.2.6 has. if you want the shiny new Bios you'll need to downgrade the kernel
    Last edited by crweedon; 06-28-2012 at 02:28 PM. Reason: update info for new bios
    open source = open minds, human knowledge belongs to the world

Similar Threads

  1. Installation of Nvidia with Optimus Tech
    By W1K3D in forum BackTrack 5 Beginners Section
    Replies: 9
    Last Post: 02-29-2012, 04:16 PM
  2. All new 2nd generation Intel i3 i5 i7 now have NVIDIA’s Optimus
    By cybershock in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 12-06-2011, 09:11 PM
  3. Nvidia Optimus problem
    By s0me0ne in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 07-17-2011, 02:48 PM
  4. Nvidia optimus
    By amithiel in forum Beginners Forum
    Replies: 2
    Last Post: 02-10-2011, 09:26 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •