Hi everyone,
I'm using BT5 R2 and I'm facing problems trying to install TI chipset(acx 111) driver. I'm using "D-Link AirPlusG+ DWL-G650+ Wireless Cardbus Adapter". I want to run it on AirCrack-ng.

I followed the guide on http://sourceforge.net/apps/mediawik...X#Introduction
I have found out this page on how to install ACX Drivers, but there isn't support for BackTrack.
I'm i missing out something or is it really the case?

I tried and got error at the Installing section: (I'm suspecting it is this one) "then this probably means that you don't have a properly matching kernel build environment as outlined above: retry."
What's actually "matching kernel build environment" and "appropriate kernel header files" for BackTrack 5 R2? Is it because BT5 R2 has a kernel version which is too "new"?

ERROR as the following:

root@root:/usr/src/acx-20080210# make -C /lib/modules/`uname -r`/build M=`pwd`
make: Entering directory `/usr/src/linux-source-3.2.6'

WARNING: Symbol version dump /usr/src/linux-source-3.2.6/Module.symvers
is missing; modules will have no dependencies and modversions.

CC [M] /usr/src/acx-20080210/wlan.o
In file included from include/linux/pci.h:55,
from /usr/src/acx-20080210/acx_struct.h:1609,
from /usr/src/acx-20080210/acx.h:5,
from /usr/src/acx-20080210/wlan.c:49:
include/linux/irqreturn.h:11: error: expected identifier before ‘=’ token
include/linux/irqreturn.h:16: error: conflicting types for ‘irqreturn_t’
/usr/src/acx-20080210/wlan_compat.h:224: note: previous declaration of ‘irqreturn_t’ was here
In file included from /usr/src/acx-20080210/acx.h:6,
from /usr/src/acx-20080210/wlan.c:49:
/usr/src/acx-20080210/acx_func.h:109:1: warning: "printk_ratelimited" redefined
In file included from include/linux/kernel.h:20,
from include/linux/skbuff.h:17,
from include/linux/if_ether.h:133,
from include/linux/netdevice.h:29,
from include/linux/if_arp.h:26,
from /usr/src/acx-20080210/wlan.c:45:
include/linux/printk.h:244:1: warning: this is the location of the previous definition
make[1]: *** [/usr/src/acx-20080210/wlan.o] Error 1
make: *** [_module_/usr/src/acx-20080210] Error 2
make: Leaving directory `/usr/src/linux-source-3.2.6'

Files I've used:
1)acx-20080210.tar.bz2
2)acx-20070101.patch
3)linux-source-3.2.6.tar.bz2
4)linux-headers-3.2.6_3.2.6-10.00.Custom_i386_2.deb
5)linux-headers_2.0-bt1_all.deb

Hope that someone could really help me out step-by-step as I'm really i newbie to Linux
Any help would be much appreciated

Hope to have replies soon, Thanks Guys