Results 1 to 8 of 8

Thread: BT 5 R2 KDE 64bit - installing samba Broken packages

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Unhappy BT 5 R2 KDE 64bit - installing samba Broken packages

    Hello,

    I am trying to install samba, I never faced this problem with other backtrack distro's but on the new BT5 R2 when running the command

    apt-get update
    apt-get install samba

    I get the following error

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    samba: Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.6) but 2:3.4.7~dfsg-1ubuntu3.8 is to be installed
    Depends: libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.6) but 2:3.4.7~dfsg-1ubuntu3.8 is to be installed
    E: Broken packages


    Does this really mean that I have requested an impossible situation? anybody know how to fix this? I need samba for the nmbd and smbd services

  2. #2
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    hy try
    root@bt:~# apt-get install samba -y
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Suggested packages:
    openbsd-inetd inet-superserver smbldap-tools ldb-tools
    The following NEW packages will be installed:
    samba
    0 upgraded, 1 newly installed, 0 to remove and 109 not upgraded.
    Need to get 6,278kB of archives.
    After this operation, 17.2MB of additional disk space will be used.
    Get:1 http://32.repository.backtrack-linux.org/ revolution/main samba 2:3.4.7~dfsg-1ubuntu3.6 [6,278kB]
    Fetched 6,278kB in 43s (144kB/s)
    Preconfiguring packages ...
    Selecting previously deselected package samba.
    (Reading database ... 212476 files and directories currently installed.)
    Unpacking samba (from .../samba_2%3a3.4.7~dfsg-1ubuntu3.6_i386.deb) ...
    Processing triggers for man-db ...
    Processing triggers for ufw ...
    Processing triggers for ureadahead ...
    Setting up samba (2:3.4.7~dfsg-1ubuntu3.6) ...
    Generating /etc/default/samba...
    Importing account for nobody...ok
    Importing account for postgres...ok
    update-alternatives: using /usr/bin/smbstatus.samba3 to provide /usr/bin/smbstatus (smbstatus) in auto mode.
    smbd start/running, process 3210
    nmbd start/running, process 3219
    root@bt:~#

  3. #3
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    another hi
    now i tested on my bt5-r2 kde64(excuse was the first 32bit gnome)

    root@bt:~# apt-get install samba -y
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Suggested packages:
    smbldap-tools ldb-tools
    The following NEW packages will be installed:
    samba
    0 upgraded, 1 newly installed, 0 to remove and 6 not upgraded.
    Need to get 6,826kB of archives.
    After this operation, 18.4MB of additional disk space will be used.
    Get:1 http://updates.repository.backtrack-linux.org/ revolution/main samba 2:3.4.7~dfsg-1ubuntu3.8 [6,826kB]
    Fetched 6,826kB in 29s (234kB/s)
    Preconfiguring packages ...
    Selecting previously deselected package samba.
    (Reading database ... 237044 files and directories currently installed.)
    Unpacking samba (from .../samba_2%3a3.4.7~dfsg-1ubuntu3.8_amd64.deb) ...
    Processing triggers for ureadahead ...
    Processing triggers for ufw ...
    Processing triggers for man-db ...
    Setting up samba (2:3.4.7~dfsg-1ubuntu3.8) ...
    Generating /etc/default/samba...
    Importing account for nobody...ok
    Importing account for postgres...ok
    update-alternatives: using /usr/bin/smbstatus.samba3 to provide /usr/bin/smbstatus (smbstatus) in auto mode.
    smbd start/running, process 2264
    nmbd start/running, process 2274

    root@bt:~#
    bye

  4. #4
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Default Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    Hello zimmaro,

    It didnt work =(

    When I load the live CD and run the "apt-get install samba" it installs fine but when I do apt-get update and then the apt-get install samba I get that error message

    I am still in the middle of my linux+ course but I thought I would try asking in here why this happens after the apt-get update

    I appreciate your help thank you

  5. #5
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    3

    Default Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    Hello, I managed to install it using the following commands

    apt-get upgrade
    apt-get update
    apt-get install samba

    Thanks for your help!

  6. #6
    Just burned his ISO
    Join Date
    Dec 2008
    Posts
    1

    Talking Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    Quote Originally Posted by sp000k3y View Post
    Hello,

    I am trying to install samba, I never faced this problem with other backtrack distro's but on the new BT5 R2 when running the command

    apt-get update
    apt-get install samba

    I get the following error

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    samba: Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.6) but 2:3.4.7~dfsg-1ubuntu3.8 is to be installed
    Depends: libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.6) but 2:3.4.7~dfsg-1ubuntu3.8 is to be installed
    E: Broken packages


    Does this really mean that I have requested an impossible situation? anybody know how to fix this? I need samba for the nmbd and smbd services
    The solution for me was to use aptitude with the following command:

    aptitude install samba

    Code:
    aptitude install samba
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Writing extended state information... Done
    The following packages are BROKEN:
      samba 
    0 packages upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
    Need to get 6,278kB of archives. After unpacking 17.2MB will be used.
    The following packages have unmet dependencies:
      samba: Depends: samba-common (= 2:3.4.7~dfsg-1ubuntu3.6) but 2:3.4.7~dfsg-1ubuntu3.10 is installed.
             Depends: libwbclient0 (= 2:3.4.7~dfsg-1ubuntu3.6) but 2:3.4.7~dfsg-1ubuntu3.10 is installed.
    The following actions will resolve these dependencies:
    
    Downgrade the following packages:
    libwbclient0 [2:3.4.7~dfsg-1ubuntu3.10 (now) -> 2:3.4.7~dfsg-1ubuntu3.6 (stable)]
    samba-common [2:3.4.7~dfsg-1ubuntu3.10 (now) -> 2:3.4.7~dfsg-1ubuntu3.6 (stable)]
    smbclient [2:3.4.7~dfsg-1ubuntu3.10 (now) -> 2:3.4.7~dfsg-1ubuntu3.6 (stable)]
    smbfs [2:3.4.7~dfsg-1ubuntu3.10 (now) -> 2:3.4.7~dfsg-1ubuntu3.6 (stable)]
    winbind [2:3.4.7~dfsg-1ubuntu3.10 (now) -> 2:3.4.7~dfsg-1ubuntu3.6 (stable)]
    
    Score is 140
    
    Accept this solution? [Y/n/q/?] Y
    The following packages will be DOWNGRADED:
      libwbclient0 samba-common smbclient smbfs winbind 
    The following NEW packages will be installed:
      samba 
    0 packages upgraded, 1 newly installed, 5 downgraded, 0 to remove and 7 not upgraded.
    Need to get 24.5MB of archives. After unpacking 17.5MB will be used.
    Do you want to continue? [Y/n/?] Y
    Writing extended state information... Done
    Get:1 http://all.repository.backtrack-linux.org/ revolution/main samba-common 2:3.4.7~dfsg-1ubuntu3.6 [397kB]
    Get:2 http://32.repository.backtrack-linux.org/ revolution/main smbclient 2:3.4.7~dfsg-1ubuntu3.6 [11.5MB]
    Get:3 http://32.repository.backtrack-linux.org/ revolution/main smbfs 2:3.4.7~dfsg-1ubuntu3.6 [1,857kB]      
    Get:4 http://32.repository.backtrack-linux.org/ revolution/main winbind 2:3.4.7~dfsg-1ubuntu3.6 [4,408kB]    
    Get:5 http://32.repository.backtrack-linux.org/ revolution/main libwbclient0 2:3.4.7~dfsg-1ubuntu3.6 [107kB] 
    Get:6 http://32.repository.backtrack-linux.org/ revolution/main samba 2:3.4.7~dfsg-1ubuntu3.6 [6,278kB]      
    Fetched 24.5MB in 54s (450kB/s)                                                                              
    Preconfiguring packages ...
    dpkg: warning: downgrading smbclient from 2:3.4.7~dfsg-1ubuntu3.10 to 2:3.4.7~dfsg-1ubuntu3.6.
    (Reading database ... 259389 files and directories currently installed.)
    Preparing to replace smbclient 2:3.4.7~dfsg-1ubuntu3.10 (using .../smbclient_2%3a3.4.7~dfsg-1ubuntu3.6_i386.deb) ...
    Unpacking replacement smbclient ...
    dpkg: warning: downgrading smbfs from 2:3.4.7~dfsg-1ubuntu3.10 to 2:3.4.7~dfsg-1ubuntu3.6.
    Preparing to replace smbfs 2:3.4.7~dfsg-1ubuntu3.10 (using .../smbfs_2%3a3.4.7~dfsg-1ubuntu3.6_i386.deb) ...
    Unpacking replacement smbfs ...
    dpkg: warning: downgrading winbind from 2:3.4.7~dfsg-1ubuntu3.10 to 2:3.4.7~dfsg-1ubuntu3.6.
    Preparing to replace winbind 2:3.4.7~dfsg-1ubuntu3.10 (using .../winbind_2%3a3.4.7~dfsg-1ubuntu3.6_i386.deb) ...
     * Stopping the Winbind daemon winbind                                                                [ OK ] 
    Unpacking replacement winbind ...
    dpkg: warning: downgrading samba-common from 2:3.4.7~dfsg-1ubuntu3.10 to 2:3.4.7~dfsg-1ubuntu3.6.
    Preparing to replace samba-common 2:3.4.7~dfsg-1ubuntu3.10 (using .../samba-common_2%3a3.4.7~dfsg-1ubuntu3.6_all.deb) ...
    Unpacking replacement samba-common ...
    dpkg: warning: downgrading libwbclient0 from 2:3.4.7~dfsg-1ubuntu3.10 to 2:3.4.7~dfsg-1ubuntu3.6.
    Preparing to replace libwbclient0 2:3.4.7~dfsg-1ubuntu3.10 (using .../libwbclient0_2%3a3.4.7~dfsg-1ubuntu3.6_i386.deb) ...
    Unpacking replacement libwbclient0 ...
    Selecting previously deselected package samba.
    Unpacking samba (from .../samba_2%3a3.4.7~dfsg-1ubuntu3.6_i386.deb) ...
    Processing triggers for man-db ...
    Processing triggers for ureadahead ...
    Processing triggers for ufw ...
    Setting up samba-common (2:3.4.7~dfsg-1ubuntu3.6) ...
    
    Setting up libwbclient0 (2:3.4.7~dfsg-1ubuntu3.6) ...
    
    Setting up smbclient (2:3.4.7~dfsg-1ubuntu3.6) ...
    Setting up smbfs (2:3.4.7~dfsg-1ubuntu3.6) ...
    Setting up winbind (2:3.4.7~dfsg-1ubuntu3.6) ...
     * Starting the Winbind daemon winbind                                                                [ OK ] 
    
    Setting up samba (2:3.4.7~dfsg-1ubuntu3.6) ...
    Generating /etc/default/samba...
    Importing account for nobody...ok
    Importing account for postgres...ok
    update-alternatives: using /usr/bin/smbstatus.samba3 to provide /usr/bin/smbstatus (smbstatus) in auto mode.
    smbd start/running, process 10132
    nmbd start/running, process 10142
    
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    Reading package lists... Done             
    Building dependency tree       
    Reading state information... Done
    Reading extended state information      
    Initializing package states... Done
    Writing extended state information... Done

  7. #7
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    2

    Default Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    aptitude didn't install it.

    I had to do this command to install samba4

    apt-get install samba4

    now everything works.

  8. #8
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    6

    Default Re: BT 5 R2 KDE 64bit - installing samba Broken packages

    just want to add what worked for me.
    fistly i entered:
    #apt-get install samba4
    and received info about unresolved dependancies (some packages cannot be installed).
    BT asked me to do the following:
    #apt-get -f install
    notice that no package name should be given to the above. type Y if asked to.
    Then again type:
    #apt-get install samba4
    All is going to be installed. For me it was over 300MB. sound too much...


    I just followed BT - it asked me to do the following (After I got the message with unresolved dependancies):

Similar Threads

  1. BackTrack 5, Tor & Broken Packages
    By 73511 in forum BackTrack 5 Bugs
    Replies: 4
    Last Post: 01-22-2013, 10:41 PM
  2. Kdelibs-dev, kdelibs4-dev broken packages
    By kirbuchi in forum BackTrack Bugs
    Replies: 5
    Last Post: 02-11-2011, 12:42 AM
  3. installing downloaded packages
    By phoenix989 in forum OLD Newbie Area
    Replies: 1
    Last Post: 01-24-2010, 01:32 AM
  4. k3b install ,E: Broken packages
    By loop4me in forum OLD BackTrack 4 Software Related Issues
    Replies: 2
    Last Post: 07-15-2009, 12:25 PM
  5. Replies: 6
    Last Post: 07-03-2008, 10:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •