Hello all!

My computer specs:
  • HP EliteBook 8560w
  • Intel Core i7 2630QM 2.0GHz
  • 8 gigs of ram
  • AMD FirePro M5950 Mobility Professional Graphics Card
  • Windows 7 Enterprise 64bit
  • Docking station
  • Two external monitors (both plugged into docking station - VGA and DVI)
  • BT 5 R2 64bit via VMware workstation 8


I recently installed BT 5 R2 on my VMware workstation 8. Everything ran perfect and I started to get used to using it. I am currently taking the PWB course and it would be nice to really dive into this system outside of VMware workstation. I have wanted to find a good Distro to replace my Windows OS. Before formatting my pc, I tried out the Live CD to make sure everything worked. I noticed that I was unable to get my secondary monitor to display. It would not even show up in the "Display and Monitor" settings. I tried to play around with it, but thought it might be pointless to do on a Live CD. SO I pulled out an external HD and installed BT on it. Everything worked great other than my external monitor. I searched for about 8 hours today trying to figure it out with no luck.

I tried on and off my docking station via VGA.
I noticed that before I would enter into X Desktop, it would work on my DVI. It would mirror my laptop and the DVI monitor. It did not do it every time. Once I entered into X Desktop, I could not get either of them to work. I know that I may not be so lucky to get all three working like I have setup on my Windows side (would be awesome), but I need to have a least one external monitor working. Therefore, it is able to detect the DVI monitor on the docking station in the boot/CLI, but unable to in the X Desktop.
I tried searching for drivers for my graphics card all over the Internet to include AMD (does not have one for my card), HP (only have drivers for SUSE and RH), and other third party sites.
I noticed that looking at the sysinfo, it displayed an incorrect graphic card installed. It believe it was an "AMD FirePro M7740 or M7820" listed.
I installed the proprietary AMD Catalyst drivers as suggested in other forums but when trying to get into the application, it would tell me that I did not have any supported products.
I can get dual monitors in my VMware workstation. I know VMware uses their own drivers, but they were able to get it to work.

Anyone having any insight as to BT 5 R2 not working with the "HP Elitebook 8560w" or the "AMD FirePro M5950 Mobility Professional Graphics Card"? Is there a way to get at least one of my external monitors working with BT 5 R2?