Results 1 to 4 of 4

Thread: Error: insmod: error inserting './com_on_air_cs.ko': -1 Invalid module format

  1. #1
    Just burned their ISO
    Join Date
    Jan 2010
    Posts
    15

    Question Error: insmod: error inserting './com_on_air_cs.ko': -1 Invalid module format

    Hello

    I am using Backtrack 5 R2 and i try to use from the wiki the dedected tutorial...

    I follow the steps not using manual installation and when i am on Load drivers section i run:

    Code:
    cd /pentest/telephony/dedected/com-on-air_cs-linux
    make node
    Then i insert my pcmcia card Com on air and run:

    Code:
    make load
    And i am getting an error here:

    Code:
    root@bt:/pentest/telephony/dedected/com-on-air_cs-linux# make load
    insmod ./com_on_air_cs.ko && \
    pccardctl insert 0
    insmod: error inserting './com_on_air_cs.ko': -1 Invalid module format
    make: *** [load] Error 1

    Is this a problem with the software or i have to do something else to load my pcmcia drivers?

    Some more info:

    Code:
    dmesg | tail -n50
    Code:
    root@bt:~# dmesg | tail -n50
    [ 11.169901] cfg80211: (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 11.169904] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [ 11.169908] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 11.169911] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 12.452058] pcmcia_socket pcmcia_socket0: pccard: PCMCIA card inserted into slot 0
    [ 12.452074] pcmcia_socket pcmcia_socket0: cs: memory probe 0xfe200000-0xfea6ffff: clean.
    [ 12.465753] pcmcia 0.0: pcmcia: registering new device pcmcia0.0 (IRQ: 3)
    [ 12.465922] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x100-0x3af: excluding 0x170-0x177 0x1f0-0x1f7 0x370-0x377
    [ 12.467990] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x3e0-0x4ff: excluding 0x3f0-0x3f7 0x400-0x41f 0x480-0x4bf 0x4d0-0x4d7
    [ 12.468612] pcmcia_socket pcmcia_socket0: cs: IO port probe 0x820-0x8ff: excluding 0x820-0x87f
    [ 12.469045] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xc00-0xcf7: clean.
    [ 12.469817] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff: excluding 0xc0000-0xcffff 0xe0000-0xfffff
    [ 12.469876] pcmcia_socket pcmcia_socket0: cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff
    [ 12.469933] pcmcia_socket pcmcia_socket0: cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff
    [ 12.469994] pcmcia_socket pcmcia_socket0: cs: IO port probe 0xa00-0xaff: clean.
    [ 13.006606] iwl3945 0000:03:00.0: loaded firmware version 15.32.2.9
    [ 13.077913] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 13.080117] r8169 0000:02:00.0: eth0: link down
    [ 13.080307] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 13.400003] snd_hda_intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
    [ 13.400088] snd_hda_intel 0000:00:1b.0: irq 45 for MSI/MSI-X
    [ 13.400124] snd_hda_intel 0000:00:1b.0: setting latency timer to 64
    [ 14.768335] r8169 0000:02:00.0: eth0: link up
    [ 14.768600] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 25.696029] eth0: no IPv6 routers present
    [ 42.231375] pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    [ 42.346143] [drm] Initialized drm 1.1.0 20060810
    [ 42.417559] [drm] radeon defaulting to userspace modesetting.
    [ 42.418313] pci 0000:01:00.0: setting latency timer to 64
    [ 42.418505] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).
    [ 42.418508] [drm] No driver support for vblank timestamp query.
    [ 42.418512] [drm] Initialized radeon 1.33.0 20080528 for 0000:01:00.0 on minor 0
    [ 43.001050] [drm] Setting GART location based on new memory map
    [ 43.001814] [drm] Loading R500 Microcode
    [ 43.070933] [drm] Num pipes: 1
    [ 43.070942] [drm] writeback test succeeded in 1 usecs
    [ 118.450239] cdrom: sr0: mrw address space DMA selected
    [ 118.644406] UDF-fs: Partition marked readonly; forcing readonly mount
    [ 118.682928] UDF-fs: INFO Mounting volume 'New', timestamp 2012/04/23 17:59 (10b4)
    [ 386.744679] com_on_air_cs: version magic '2.6.38 SMP mod_unload ELAN ' should be '3.2.6 SMP mod_unload CORE2 '
    [ 554.545848] ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 554.644110] r8169 0000:02:00.0: eth0: link down
    [ 554.644122] r8169 0000:02:00.0: eth0: link down
    [ 554.644472] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 554.707094] r8169 0000:02:00.0: eth0: link down
    [ 554.707441] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 556.342863] r8169 0000:02:00.0: eth0: link up
    [ 556.343199] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    [ 566.960050] eth0: no IPv6 routers present
    [ 689.106238] com_on_air_cs: version magic '2.6.38 SMP mod_unload ELAN ' should be '3.2.6 SMP mod_unload CORE2 '
    Thank you

  2. #2
    My life is this forum thorin's Avatar
    Join Date
    Jan 2010
    Posts
    2,629

    Default Re: Error: insmod: error inserting './com_on_air_cs.ko': -1 Invalid module format

    Are you talking about this guide?
    http://www.backtrack-linux.org/wiki/...ffing_Dedected
    I'm a compulsive post editor, you might wanna wait until my post has been online for 5-10 mins before quoting it as it will likely change.

    I know I seem harsh in some of my replies. SORRY! But if you're doing something illegal or posting something that seems to be obvious BS I'm going to call you on it.

  3. #3
    Just burned their ISO
    Join Date
    Jan 2010
    Posts
    15

    Default Re: Error: insmod: error inserting './com_on_air_cs.ko': -1 Invalid module format

    Yes exactly

  4. #4
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    1

    Default Re: Error: insmod: error inserting './com_on_air_cs.ko': -1 Invalid module format

    I had the same problem, so in case you haven't figured it out yourself by now:

    In the tutorial above with BT5R2 you need to run "make && make -C tools" (without the quotation marks) directly before "make node".
    This did the trick for me.

    And for converting back, you will have to refer to this page:
    https://dedected.org/trac/wiki/COM-ON-AIR-Linux

    Good luck!
    Jon

Similar Threads

  1. Replies: 0
    Last Post: 11-06-2011, 08:19 PM
  2. Error: Invalid Band(0) ---- please help----
    By ENi159 in forum BackTrack 5 Beginners Section
    Replies: 0
    Last Post: 08-19-2011, 02:21 PM
  3. Invalid module format (com_on_air_cs.ko)
    By ASTRAPI in forum Beginners Forum
    Replies: 3
    Last Post: 08-07-2010, 08:35 PM
  4. Replies: 9
    Last Post: 06-20-2008, 07:44 PM
  5. Problem Inserting module
    By n00b_h4xx0r in forum OLD BT3beta General
    Replies: 4
    Last Post: 03-04-2008, 02:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •