Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Startup File???

  1. #1
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    14

    Default Startup File???

    Installed BT2 to hd, dual boot with xp. When I boot from CD had to enter BT irqpoll. Now when boot from hd, lilo comes up, I select BT2, nowhere to enter irqpoll, what file do I need to edit to insert irqpoll. Newbie here, so be nice, I have been searching on this fourm for ~1 hour now. Thanks in advance for any help.

  2. #2
    Senior Member shamanvirtuel's Avatar
    Join Date
    Mar 2010
    Location
    Somewhere in the "Ex" human right country
    Posts
    2,988

    Default

    you need to reinstall lilo and add irqpoll to the append kernel parameter line
    Watch your back, your packetz will belong to me soon... xD

    BackTrack :
    Giving Machine Guns to Monkeys since 2006

  3. #3
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    14

    Default

    don't want to screw this up now. All I need to do is add

    append = irqpoll

    place it under read-only in the linux boot partition section

    Thanks for the quick reply.

  4. #4
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    post your lilo.conf and I will modify it for you

  5. #5
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    14

    Default

    # LILO configuration file
    # generated by 'liloconfig'
    #
    # Start LILO global section
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    boot = /dev/hda
    #message = /boot/boot_message.txt
    prompt
    timeout = 1200
    # Override dangerous defaults that rewrite the partition table:
    change-rules
    reset
    # VESA framebuffer console @ 1024x768x256
    vga = 773
    # Normal VGA console
    # vga = normal
    # VESA framebuffer console @ 1024x768x64k
    # vga=791
    # VESA framebuffer console @ 1024x768x32k
    # vga=790
    # VESA framebuffer console @ 1024x768x256
    # vga=773
    # VESA framebuffer console @ 800x600x64k
    # vga=788
    # VESA framebuffer console @ 800x600x32k
    # vga=787
    # VESA framebuffer console @ 800x600x256
    # vga=771
    # VESA framebuffer console @ 640x480x64k
    # vga=785
    # VESA framebuffer console @ 640x480x32k
    # vga=784
    # VESA framebuffer console @ 640x480x256
    # vga=769
    # End LILO global section
    # Linux boot partition
    image = /boot/vmlinuz
    root = /dev/hda4
    label = BackTrack2
    read-only
    # End Linux Boot partition
    # Windows bootable partition config begins
    other = /dev/hda1
    label = Windows
    table = /dev/hda
    # Windows bootable partition config ends

  6. #6
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Ok there you

    Code:
    # LILO configuration file 
    # generated by 'liloconfig' 
    # 
    # Start LILO global section 
    lba32 # Allow booting past 1024th cylinder with a recent BIOS 
    boot = /dev/hda 
    #message = /boot/boot_message.txt 
    prompt 
    timeout = 1200 
    # Override dangerous defaults that rewrite the partition table: 
    change-rules 
    reset 
    # VESA framebuffer console @ 1024x768x256 
    vga = 773 
    # Normal VGA console 
    # vga = normal 
    # VESA framebuffer console @ 1024x768x64k 
    # vga=791 
    # VESA framebuffer console @ 1024x768x32k 
    # vga=790 
    # VESA framebuffer console @ 1024x768x256 
    # vga=773 
    # VESA framebuffer console @ 800x600x64k 
    # vga=788 
    # VESA framebuffer console @ 800x600x32k 
    # vga=787 
    # VESA framebuffer console @ 800x600x256 
    # vga=771 
    # VESA framebuffer console @ 640x480x64k 
    # vga=785 
    # VESA framebuffer console @ 640x480x32k 
    # vga=784 
    # VESA framebuffer console @ 640x480x256 
    # vga=769 
    # End LILO global section 
    # Linux boot partition 
    image = /boot/vmlinuz 
    root = /dev/hda4 
    label = BackTrack2
    append = irqpoll 
    read-only 
    # End Linux Boot partition 
    # Windows bootable partition config begins 
    other = /dev/hda1 
    label = Windows 
    table = /dev/hda 
    # Windows bootable partition config ends
    make your lilo.conf like that save it and the apply in the same way as you did the first time.

    Good luck

    Let us know how you get on

  7. #7
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    14

    Default

    now no lilo, turn on computer, get a letter L and about 10 lines on the number 40. I love this stuff.

  8. #8
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    14

    Default

    Now when I boot, no Lilo, I get a letter L and about 10 lines of the number 40

  9. #9
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    OMG I am really sorry about that.

    Give me a minute and I will sort out a solution.

    For some reason I put the append line in the wrong place, I have no idea why I did that.

    Are your partitions laid out the same as the dualboot video ?

  10. #10
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    14

    Default

    did not use the video. Have 4 partitions,
    hda1 windows
    hda2 linux
    hda3 swap
    hda4 linux

    used a guide from different forum

    Where was the append line supposed to go??

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •