i just replaced my broadcomm internal wifi card for an Atheros AR928x , but there are a few issues.

1) It doesnt display WEP networks, only WPA/WPA2 , is there a patch or something i have missed if so how do i install it?

2) There are less networks displayed, so the range is less than my other card.

I'm happy to provide more info if needed

iwconfig diplays

Code:
root@bt:~# iwconfig
wlan2     IEEE 802.11bgn  ESSID:"MY BROADBAND "  
          Mode:Managed  Frequency:2.442 GHz  Access Point: 11:22:33:44:55:66   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:846  Invalid misc:860   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.

root@bt:~#
dmesg | grep -e ath -e wlan

Code:
root@bt:~# dmesg | grep -e ath -e wlan
[   12.014654] ath9k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[   12.014670] ath9k 0000:02:00.0: setting latency timer to 64
[   12.449616] ath: EEPROM regdomain: 0x65
[   12.449619] ath: EEPROM indicates we should expect a direct regpair map
[   12.449622] ath: Country alpha2 being used: 00
[   12.449624] ath: Regpair used: 0x65
[   12.493465] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
[   12.494047] Registered led device: ath9k-phy0
root@bt:~#
lspci | grep 928

Code:
02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
root@bt:~#
Please can someone point me in the right direction?

Thanks in advance