Hi,
I just installed BT5 R2 on a USB drive and booted with my 2011 Macbook air 13".

I found out here that my card (PCI-Id 14e4:4353) is well supported by b43 drivers, and I also found out somewhere in the forum that injection is working with my chipset (BCM43224).
So, following this guide, I enabled b43 drivers.
But, after that, wifi stopped working.

Wicd doesn't show any network.

ifconfig shows just l0

tried /etc/init.d/networking start but nothing changes.

airmon-ng tells this:
Code:
Interface      Chipset      Driver
wlan0          Broadcom   b43 - [phy0]
Then I tried airmon-ng start wlan0:
Code:
Something about a process (dhclient3) running on same interface

Interface      Chipset      Driver
wlan0          Broadcom   b43 - [phy0]SIOCSIFFLAGS: Cannot assign requested address
(monitor mode enabled on mon0)

airodump-ng mon0:
Code:
ioctl(SIOCSIFFLAGS): Cannot assign requested address
iwconfig
Code:
l0            no wireless extensions.

mon0       IEEE 802.11bg   Mode:Monitor   Tx-Power=0 dBm
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:on

wlan0      IEEE 802.11bg   ESSID:off/any
              Mode:Managed   Access Point: Not-Associated   Tx-Power=0 dBm
              Retry  long limit:7   RTS thr:off   Fragment the:off
              Encryption key:off
              Power Management:on
Maybe I'm missing something, or maybe I did something wrong while enabling b43.
Can anyone help me to solve this?

Thank you very much in advance.
MR