Page 1 of 2 12 LastLast
Results 1 to 10 of 34

Thread: Atheros AR5007EG not functioning in BT

Hybrid View

  1. #1
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default Atheros AR5007EG not functioning in BT

    I need some help getting my wireless card working:
    Toshiba Satellite U305-5077
    Atheros AR5007EG minipci card (as reported by Vista)
    Dual boot Vista Ultimate/BT 2.0 Final config

    Card works fine in vista, so I don't think it's a hardware problem. Here's the relevant line from lspci:
    06:00.0 Ethernet controller: Atheros Communications, Inc. Unknown device 001c (rev 01)

    Here's what I've tried:

    forums.remote-exploit.org/showthread.php?t=7719&highlight=ar5007eg&page=5
    I got to the step where I look at the dmesg output, and here it is:

    ndiswrapper version 1.47 loaded (smp=no)
    ndiswrapper: driver net5211 (,01/20/2006,4.2.2.7) loaded
    PCI: Enabling device 0000:06:00.0 (0000 -> 0002)
    ACPI: PCI Interrupt 0000:06:00.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
    PCI: Setting latency timer of device 0000:06:00.0 to 64
    ndiswrapper (NdisWriteErrorLogEntry:192): log: C0001389, count: 4, return_address: f98b25d4
    ndiswrapper (NdisWriteErrorLogEntry:195): code: 0xf76a8e00
    ndiswrapper (NdisWriteErrorLogEntry:195): code: 0x28
    ndiswrapper (NdisWriteErrorLogEntry:195): code: 0xf9821000
    ndiswrapper (NdisWriteErrorLogEntry:195): code: 0xf9821000
    ndiswrapper (mp_init:216): couldn't initialize device: C000009A
    ndiswrapper (pnp_start_device:439): Windows driver couldn't initialize the device (C0000001)
    ndiswrapper (mp_halt:258): device f748ba80 is not initialized - not halting
    ndiswrapper: device eth%d removed
    ACPI: PCI interrupt for device 0000:06:00.0 disabled
    ndiswrapper: probe of 0000:06:00.0 failed with error -22

    I used an ndiswrapper 1.47 source and net5211.inf from this post in an Ubuntu forum:
    ubuntuforums.org/showthread.php?t=512828

    Since it didn't work, I removed the blacklist line for ath_pci and tried this:
    forums.remote-exploit.org/showpost.php?p=34233&postcount=2
    Again, dmesg shows no love:
    ndiswrapper: probe of 0000:06:00.0 failed with error -22
    usbcore: registered new interface driver ndiswrapper
    NET: Registered protocol family 10
    lo: Disabled Privacy Extensions
    [drm] Initialized drm 1.1.0 20060810
    ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
    [drm] Initialized i915 1.6.0 20060119 on minor 0
    eth0: no IPv6 routers present
    ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    wlan: 0.8.4.2 (0.9.3.1)
    ath_pci: 0.9.4.5 (0.9.3.1)
    ACPI: PCI Interrupt 0000:06:00.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
    PCI: Setting latency timer of device 0000:06:00.0 to 64
    wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
    ACPI: PCI interrupt for device 0000:06:00.0 disabled

    This result is not entirely unexpected, as the madwifi compatibility page says my chipset is not supported:
    madwifi.org/wiki/Compatibility/Atheros

    But why wouldn't the ndiswrapper method work? Can anyone shed any light on what else I should try?

  2. #2
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Is ndiswrapper necessary with an Atheros chipped card?? Since when?? OOhhh..wait a sec...your doing this in windows. Just buy a good old supported Atheros chipped card but look the aircrack main site for a confirmed working one first. I suggest the airlink AWLC 4130..its what I use. No problems..and very modable.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  3. #3
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default Doing this in windows?

    Not sure what you mean by that, but I have dual boot configuation, and I was booted into Backtrack for all the stuff I listed.

  4. #4
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Sorry! I saw vista..and well..you know the rest..lol

    did you look at my video tutorial??

    Code:
    http://forums.remote-exploit.org/showthread.php?t=7633


    sorry but I have absolutely NO personal experience with ndiswrapper.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  5. #5
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default

    What atheros chipset is your card? Mine is AR5007EG. And did you have to install a separate driver, or did BT find it on its own?

    Your card is obviously functioning in your video, so I'm not sure what you expected me to see in it that would help, as mine is not currently recognized by BT.

  6. #6
    Developer
    Join Date
    Mar 2007
    Posts
    6,124

    Default

    Quote Originally Posted by skiamakhe View Post
    What atheros chipset is your card? Mine is AR5007EG. And did you have to install a separate driver, or did BT find it on its own?

    Your card is obviously functioning in your video, so I'm not sure what you expected me to see in it that would help, as mine is not currently recognized by BT.
    I just went through this with another kid. If the mad wifi site does not support your card then your probably SOL. Im not to good with the ndsiwrapper but this net5211.inf is the atheros wild packets driver for windows so the chances of this working are slim.Its like I say to every one .we all have a lot of different wifi cards.If you dont have the cash to purchase a working card then HOW in the world are you gonna take over the planet.

    The commview drivers will support a atheros card in vista.I dont know about yours but my netgearwg511t even injects.

  7. #7
    Developer balding_parrot's Avatar
    Join Date
    May 2007
    Posts
    3,399

    Default

    Quote Originally Posted by -=Xploitz=- View Post
    Sorry! I saw vista..and well..you know the rest..lol

    did you look at my video tutorial??

    Code:
    http://forums.remote-exploit.org/showthread.php?t=7633


    sorry but I have absolutely NO personal experience with ndiswrapper.
    Looks like you missed the point twice, not sure that the video is going to help yet

    Quote Originally Posted by skiamakhe View Post
    This result is not entirely unexpected, as the madwifi compatibility page says my chipset is not supported:
    madwifi.org/wiki/Compatibility/Atheros

    But why wouldn't the ndiswrapper method work? Can anyone shed any light on what else I should try?
    No experience with ndiswrapper, except you are better off getting a supported card to be honest.

  8. #8
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    Quote Originally Posted by balding_parrot View Post
    Looks like you missed the point twice, not sure that the video is going to help yet
    I've had a long day at the office here. Thats my excuse and I'm sticking to it dammit! Time for me to punch out. Ill try re-reading this thread for the 3rd time tomorrow or tonight possibly. I need a break. See ya'll.
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  9. #9
    Senior Member
    Join Date
    Apr 2007
    Posts
    3,385

    Default

    I'm using the madwifi-0.9.3.1.tar.gz

    Code:
     modprobe ath_pci
    didnt help??
    [CENTER][FONT=Book Antiqua][SIZE=5][B][COLOR=blue][FONT=Courier New][COLOR=red]--=[/COLOR][/FONT]Xploitz[FONT=Courier New][COLOR=red]=--[/COLOR][/FONT][/COLOR][/B][/SIZE][/FONT][FONT=Courier New][COLOR=Black][SIZE=6][B] ®[/B][/SIZE][/COLOR][/FONT][/CENTER]
    [CENTER][SIZE=4][B]Remote-Exploit.orgs Master Tutorialist.[/B][/SIZE][SIZE=6][B]™
    [/B][/SIZE]
    [URL="http://forums.remote-exploit.org/showthread.php?t=9063"][B]VIDEO: Volume #1 "E-Z No Client WEP Cracking Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=7872"][B]VIDEO: Volume #2 "E-Z No Client Korek Chopchop Attack Tutorial"[/B]
    [/URL]
    [URL="http://forums.remote-exploit.org/showthread.php?t=8230"][B]VIDEO: Volume #3 "E-Z WPA/WPA2 Cracking Tutorial"[/B][/URL]

    [URL="http://forums.remote-exploit.org/showthread.php?t=8041"][B]VIDEO: Volume #4 "E-Z Cracking WPA/WPA2 With Airolib-ng Databases"[/B][/URL]
    [/CENTER]

  10. #10
    Member skiamakhe's Avatar
    Join Date
    Jul 2007
    Posts
    80

    Default

    Nope. See the second dmesg output from my original post. Madwifi says my card won't work, though.

    Arrrggg!! I bought this laptop specifically because it had an atheros chip card in it. I didn't think about it being so new that there wouldn't be compatible drivers for it. Even the omnipeek drivers on the windows side only go up to 5006, not 5007, so I can't use aircrack for windows either. ARRRGGHH!!!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •