@Bl4ckSky, you are using Google DNS (cue posts about privacy )
The script expects local DNS (e.g. 192.168.1.1)
Your easiest option might be to add a local DNS address (usually the same as your router/gateway) to your network (which should then update resolv.conf automatically).