hello to all:


I've been trying to run my usb device tp-link tl-wn722n.
I've installed compat-wireless and firmware.
doing "dmesg" ...

Code:
root @ bt: ~ # dmesg | grep ath9k
[9.151578] usbcore: registered new interface driver ath9k_htc
[126.548050] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 51272
[126.785872] ath9k_htc 1-1:1.0: ath9k_htc: HTC initialized with 33 credits
[126.990928] ath9k_htc 1-1:1.0: ath9k_htc: FW Version: 1.1
[126.990944] ath9k_htc 1-1:1.0: ath9k_htc: Please upgrade to version 1.3 FW
[127.001713] ath9k_htc: probe of 1-1:1.0 failed with error -22
i tried, several times, to download and copy, from "http://linuxwireless.org/download/htc_fw/"]http://linuxwireless.org/download/htc_fw/, into /lib/firmware, by replacing the 1.1version by the 1.3version, but get same results.

how do i update the firmware.
Thanks.

rcc