Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

  1. #1
    Just burned his ISO
    Join Date
    May 2011
    Posts
    4

    Default nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    Hi all,

    unfortunately nmap 5.51 in Metasploit 3.8.0 on BT5 Gnome 64bit running inside VMWare Fusion is not working correctly:

    msf > db_status
    [*] postgresql connected to msf3

    msf > db_nmap -A 192.168.1.0/24
    [*] Nmap: Starting Nmap 5.51SVN ( http://nmap.org ) at 2011-05-23 12:44 CEST[*] Nmap: 'nmap: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference'

    msf > nmap -A 192.168.1.0/24
    [*] exec: nmap -A 192.168.1.0/24

    Starting Nmap 5.51SVN ( http://nmap.org ) at 2011-05-23 12:46 CEST

    nmap: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

    msf > exit

    root@bt:~# nmap -A 192.168.178.0/24
    Starting Nmap 5.51 ( http://nmap.org ) at 2011-05-23 12:47 CEST

    *** Here nmap is working ok! ***

    Tried to fix it, but with no success:

    root@bt:~# which nmap
    /usr/local/bin/nmap
    root@bt:~# find / -name nmap -type f
    /opt/framework3/bin/nmap
    /usr/local/bin/nmap
    root@bt:~# cp /opt/framework3/bin/nmap /opt/framework3/bin/nmap.old
    root@bt:~# cp /usr/local/bin/nmap /opt/framework3/bin/nmap

    msf > db_nmap -A 192.168.178.0/24
    [*] Nmap: 'nmap: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by nmap)'
    [*] Nmap: 'nmap: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by nmap)'
    [*] Nmap: Starting Nmap 5.51 ( http://nmap.org ) at 2011-05-23 12:55 CEST
    [*] Nmap: 'NSE: failed to initialize the script engine:'
    [*] Nmap: '/opt/framework3/share/nmap/nse_main.lua:543: attempt to call field 'fetchscript' (a nil value)'
    [*] Nmap: 'stack traceback:'
    [*] Nmap: '/opt/framework3/share/nmap/nse_main.lua:543: in function 'Entry''
    [*] Nmap: '/opt/framework3/share/nmap/scripts/script.db:7: in function 'db_closure''
    [*] Nmap: '/opt/framework3/share/nmap/nse_main.lua:566: in function 'get_chosen_scripts''
    [*] Nmap: '/opt/framework3/share/nmap/nse_main.lua:1006: in main chunk'
    [*] Nmap: '[C]: ?'
    [*] Nmap: 'QUITTING!'

    msf > nmap -A 192.168.178.0/24[*] exec: nmap -A 192.168.178.0/24

    nmap: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by nmap)
    nmap: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by nmap)
    Starting Nmap 5.51 ( http://nmap.org ) at 2011-05-23 12:55 CEST
    NSE: failed to initialize the script engine:
    /opt/framework3/share/nmap/nse_main.lua:543: attempt to call field 'fetchscript' (a nil value)
    stack traceback:
    /opt/framework3/share/nmap/nse_main.lua:543: in function 'Entry'
    /opt/framework3/share/nmap/scripts/script.db:7: in function 'db_closure'
    /opt/framework3/share/nmap/nse_main.lua:566: in function 'get_chosen_scripts'
    /opt/framework3/share/nmap/nse_main.lua:1006: in main chunk
    [C]: ?

    QUITTING!

    Any ideas?

    Cheers & thank you,
    Roland

  2. #2
    Just burned his ISO mcurran's Avatar
    Join Date
    Aug 2010
    Location
    Abington - MA
    Posts
    9

    Default Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    BUMP! I am also receiving this error with nmap:[*] Nmap: 'nmap: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference'

  3. #3
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    3

    Default Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    unfortunately i can confirm this also on Gnome 64 hdd install

  4. #4
    Just burned his ISO mcurran's Avatar
    Join Date
    Aug 2010
    Location
    Abington - MA
    Posts
    9

    Default Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    I fixed this issue by downloading nscd and changing the following line in /etc/nscd.conf:

    enable-cache hosts no
    to:
    enable-cache hosts yes

  5. #5
    Just burned his ISO
    Join Date
    Jun 2011
    Posts
    2

    Exclamation AW: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    Same problem here.
    Backtrack5 64bit, metasploit v3.7.1-release [core:3.7 api:1.0]

    Code:
    [*] Nmap: 'nmap: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

  6. #6
    Just burned his ISO deathrock's Avatar
    Join Date
    Jun 2011
    Posts
    1

    Default Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    Same issue from a freshly downloaded 32-bit GNOME VM before and after msfupdate. Tried replacing /opt/framework3/bin/nmap with /usr/local/bin/nmap but that didn't work. Tried downgrading framework3 but that also didn't do anything.

  7. #7
    Member shadowzero's Avatar
    Join Date
    Jun 2011
    Location
    ${HOME}
    Posts
    94

    Thumbs up Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    A solution that worked for me was to install a separate version of msf3. The installation procedure is detailed in https://community.rapid7.com/docs/DOC-1293 but I'll summarize the steps here:

    1. Download the UNIX tarball http://www.metasploit.com/download/
    As of this post, the version is 3.7.2. I decided to download it into /pentest:
    Code:
    cd /pentest
    wget http://updates.metasploit.com/data/releases/framework-3.7.2.tar.bz2
    tar xvjf framework-3.7.2.tar.bz2
    You should now have an alternate metasploit installation on /pentest/msf3

    2. We don't want this install to blow away the default install from BT5, so we can create our own $HOME/msfbin directory and create symlinks there, and update our PATH accordingly:
    Code:
    mkdir $HOME/msfbin
    ln -sf /pentest/msf3/msf* $HOME/msfbin
    export PATH=$HOME/msfbin:$PATH
    If you type msfconsole it should launch the one in $HOME/msfbin now.

    3. When you start msfconsole, you won't be connected to a database, so you'll need to set it up. I followed these instructions to setup Postgres but could not get it to work: http://www.backtrack-linux.org/forum...ostgresql.html So I setup a standalone MySQL database instead using these instructions and was able to get the database working with metasploit: http://www.backtrack-linux.org/forum...ne-server.html

    To summarize getting MySQL running with metasploit:
    Code:
    apt-get install libmysqlclient-dev
    Then run the following and select ruby 1.8:
    Code:
    update-alternatives --config ruby
    gem install mysql
    4. Do an msfudpate if you like before starting msfconsole. After all this, the following command finally works without spitting the nmap relocation error message:
    Code:
    db_nmap -sS -A -O 192.168.1.0/24
    Hope this helps someone.

  8. #8
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    1

    Default Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    Quote Originally Posted by mcurran View Post
    I fixed this issue by downloading nscd and changing the following line in /etc/nscd.conf:

    enable-cache hosts no
    to:
    enable-cache hosts yes
    +1 - worked for me, thanks

  9. #9
    Just burned his ISO
    Join Date
    May 2011
    Posts
    9

    Default Respuesta: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    I have a different error:

    [*] Nmap: Starting Nmap 5.51SVN ( http://nmap.org ) at 2011-08-13 03:12 PDT[*] Nmap: 'nmap: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference'

  10. #10
    Just burned his ISO
    Join Date
    Sep 2011
    Posts
    4

    Default Riferimento: Re: nmap 5.51 inside MSF 3.8.0 on BT5 Gnome 64bit VM not working

    Quote Originally Posted by 1ofd3m0n35 View Post
    +1 - worked for me, thanks

    worked for mee too

Page 1 of 2 12 LastLast

Similar Threads

  1. Mantra won't start (BT5 Gnome 64bit)
    By c4ncelled in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 05-23-2011, 10:44 AM
  2. BT5 gnome 64bit reboots when conecting to wifi
    By Lowformat in forum BackTrack 5 Bugs
    Replies: 4
    Last Post: 05-14-2011, 12:12 PM
  3. 64bit and Gnome - any chance in BT4 ??
    By dogscahonas in forum OLD BT4 Feature Requests
    Replies: 5
    Last Post: 08-25-2009, 04:14 PM
  4. NON-WORKING tablet PC---solution inside--
    By soysanti in forum OLD BT3beta NON-WORKING HARDWARE
    Replies: 0
    Last Post: 01-21-2008, 01:40 PM
  5. NON-WORKING tablet PC---solution inside--
    By soysanti in forum OLD Newbie Area
    Replies: 6
    Last Post: 01-13-2008, 01:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •