Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 41

Thread: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PPA's

  1. #31
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    4

    Thumbs up Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    OMG your my hero THANK YOU. i think this should be sticky Like NOW lol.

    I made it work and im a linux nub so thank you again. I learned a lot along the way.

  2. #32
    Junior Member Malko's Avatar
    Join Date
    Oct 2010
    Location
    Portugal, Porto
    Posts
    41

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    OMFG! =) finally I put this working, thanks to you =) Great tutorial, and worked perfectly.

  3. #33
    Just burned their ISO
    Join Date
    Oct 2012
    Posts
    9

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    The process works great, but i have a different issue, might be a simple fix but im not sure...
    after i try to "startx", i get a black screen, startup music in background plays and it seems like it just hasnt refreshed my monitor,

    Xorg.0.log shows an error;


    (EE) Oct 29 16:47:20 NVIDIA(0): Failed to initiate mode change.
    (EE) Oct 29 16:47:20 NVIDIA(0): Failed to complete mode change


    Anyone shed any light on this error that is making my session not show??

  4. #34
    Just burned their ISO Parad0x001's Avatar
    Join Date
    Oct 2012
    Posts
    6

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    YOU ARE THE MAN! IT'S WORKING!!!!

    (spec: LG A310 i3 intel graphic 2000)

  5. #35
    Just burned their ISO
    Join Date
    Nov 2012
    Posts
    1

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    Awesome post, thanks very much for this. Huge help for many of us dealing with the whole nvidia optimus mess.

  6. #36
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    1

    Red face Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    Works Perfect!! thanks alottt

  7. #37
    Just burned their ISO
    Join Date
    Jan 2013
    Posts
    1

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    Great post, I found this fix a while back in another location but this thread is much more productive.

    I have had some issue though running on a Thinkpad T410. After running this fix I have consistently been able to load the GUI fine, however, Backtrack runs very laggy. I am currently only adding "modprobe i915 modeset=1" before running startx as I have not had the time to go through the full configuration and modify the load out. This may be the problem and I will do some more testing.

    In the mean time, does anyone have any ideas of what the problem may be off the top of their heads? The system is usable but frustrating to use. It almost feels like I am trying to run it over a slow remote connection.

    I will post more details when I have the time to do some deeper testing.

    Thanks,

  8. #38
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    6

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    hi,
    I spent 3 months finding how I can install BT5 on my Lenovo t410 but finally managed - partially due to this post and similar about installing driver for Intel HD graphic card.
    initially I used iso of BT5r3 but non of it worked. I've read somewhere that when your caps lock is blinking then keep pressing ENTER untill it goes through. I havent checked that, as I came up with my own way...
    I downloaded BT5.0 from backtrack-linux.org I guess. no releases, no additions etc. Like in previous attempts of installation I created bootable USB stick. Notice that my problem was that I was getting black screen just after hitting 'startx' before going to Xs with 'install BT' icon on it.
    once I put BT5.0 on the stick the whole installation went without any problems.
    now, shortly after rebooting, dont enter 'startx' - just fix your graphic diver in /etc/default/grub
    by means of vi edit grub file with the line below:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.modeset=1 vga=791"
    then get out of the edited file and update grub:
    #update-grub
    (or something like that).
    reboot system and it should work for any T410.

    p.s. obviously put # to block line which includes details of initial driver being active (or just delete the line, replace by the above, whatever ).

    thanks to all who posted any info in relation to similar issue.
    good luck!

  9. #39
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    6

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    hi whitecatwondering,
    I installed BT5.0 32bit on my T410 (KDE) and it works fine. as I wrote in my previous post, I edited the grub file with: "quiet splash i915.modeset=1 vga=791" and dont see any issues. The same with my server (some miniATX Intel Mainboard) - works great. The issues I have is Firefox (it doesnt scrall windows smoothly, e.g. FB), but that's java, flash or similar issue, which is ahead of me.
    the issue with BT is that initially I used BTr3 iso and it didnt let me install it on T410.
    The above might not be very helpful, but I try my best I am new to this stuff... . good luck!

  10. #40
    Just burned their ISO
    Join Date
    Mar 2013
    Posts
    1

    Default Re: [GUIDE] Loading the i915 driver in the 3.2.6 kernel without adding unsupported PP

    Registered to thank you for the info, James2k.

    My Alienware M14x now at least presents it native resolution. I'll worry about getting the NVIDIA 555m chip to work another day; from what I understand it hasn't been worked through yet and damned if I'm the geek that's going to figure that out.

    Kudos, sir.

Page 4 of 5 FirstFirst ... 2345 LastLast

Similar Threads

  1. For those unable to load the Intel i915 driver
    By VulpiArgenti in forum BackTrack 5 Fixes
    Replies: 13
    Last Post: 05-02-2012, 10:03 AM
  2. Intel Graphics Driver (i915) with 3.2.6 Kernel not loaded
    By James2k in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 03-18-2012, 04:23 AM
  3. Recompilation of BT`s kernel [2.6.38] - Adding Xen Support
    By HitMe in forum BackTrack 5 Experts Section
    Replies: 1
    Last Post: 08-11-2011, 10:08 PM
  4. Loading Kernel and other questions.
    By Mortrin in forum OLD Newbie Area
    Replies: 5
    Last Post: 07-01-2009, 12:44 AM
  5. Adding Driver To Whax Bootable Image
    By thedark_master in forum OLD Newbie Area
    Replies: 5
    Last Post: 01-04-2008, 01:22 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •