Results 1 to 3 of 3

Thread: AUTOPWN in Metasploit

  1. #1
    Member Vagabond's Avatar
    Join Date
    Feb 2010
    Posts
    50

    Unhappy AUTOPWN in Metasploit

    Hi evryone !

    With some Script I found in the forum I finally got the
    Autopwn thing in Metasploit working...or ALMOST...

    I am just getting nuts here because for some reason, the
    db_nmap option doesnt add the found hosts to the list
    db_hosts never shows anything !!! Same with the NMAP XML inport.
    It does work though if I add the manually via the DB_add_host option.....but thats not the idea....

    Whatss wrong ? A write permission problem maybe ?

    PLEAAASEE:..HEEELPPP

  2. #2
    Just burned his ISO
    Join Date
    Jul 2007
    Posts
    19

    Default

    Hi Vegabound,

    Try going to the start menu, then services, then stop postgres
    Wait a second or two
    Then go to the start menu, then services, then start postgres

    Open a terminal and type the following

    cd /pentest/exploits/framework3
    svn update (because there's new code being added daily)
    msfconsole
    load db_postgres
    db_connect
    db_nmap 192.168.2.1-255
    db_services


    and it should list all open ports on your local network. Let us know how you get on.

    Joe

  3. #3
    Member Vagabond's Avatar
    Join Date
    Feb 2010
    Posts
    50

    Default

    Thanx, but I found the error already...I wasn´t aware that it doesn´t add hosts with filtered or closed ports....duuuuuh...Now I´m trying to figuere out why i get a read error when I try to import a Nessus-nbe file....maybe a version issue ? I use the latest 3.0.6.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •