Results 1 to 3 of 3

Thread: Hopefully the last Backtrack w/ MAC OSX thread ever! [SSL Stripping w/ Ettercap]

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    1

    Default Hopefully the last Backtrack w/ MAC OSX thread ever! [SSL Stripping w/ Ettercap]

    Okay I'll make this as short and simple as possible. For the past month or so I've been doing lots of research on here, other forums, and google searching for answers of the million dollar question which I still cannot find:

    Can a Macbook Pro running OSX 10.5 using VMWare, VirtualBox, or Bootcamp successfully perform SSL Strips or any similar network injection with its default networking hardware?

    I've came across posts that have said it only works with USB Wifi cards, while other posts have said they've been successful without mentioning anything about USB Wifi cards. I have also came across posts that have mentioned running 2 VMWares at once. Finally, I've seen posts which speak of editing etter.conf (change ec_uid and ec_gid from 65534 to 0, and also remove the comment '#' from ipchains OR iptables). I just want a final answer.

    This is my current configuration and procedure in which fails when using ettercap to perform sslstripping. Maybe someone can spot something:

    -Running BT5 using VirtualBox (I also have VMWare, and a windows XP Partition on my HDD but this is my procedure using VB w/ Mac OSX 10.5)




    -My VirtualBox network configuration is as follows:

    -Adapter 1: Enabled as NAT using Adapter Type: PCnet-FAST III

    -Adapter 2: Enabled as Bridged Adapter (en0) using Adapter Type:
    PCnet-FAST III with Promiscuous Mode as 'Allow All'.

    -Adapter 3: Enabled as Bridged Adapter (en1) also using the same adapter as
    above w/ promiscuous mode 'allow all'.






    1) Inside BT, I open up Ettercap gui

    2) Under options I only have 'Promisc Mode' checked

    3) Sniff -> Unified Sniffing ->

    -If I select eth0, I see IP Addresses that I believe are VirtualBox assigned
    Therefore I will use eth1 since it is my Ethernet connection in VirtualBox
    going directly into my HOME router.

    4) Hosts -> Scan for hosts -> After finding my clients, Host List

    5) I have seen some people say to add the router into Target 1, while others say to use Target 2 for the router . In this case, I will use Target 1 for the router (192.168.1.1) and my own computers ethernet card as Target 2 (192.168.1.6).

    6) Mitm -> Arp poisoning -> Check 'Sniff remote connections' -> OK.

    The second I poison my ethernet card I lose connectivity to the internet. My router works fine as all of the other clients can still ping the internet. When I stop the attack it comes back online.

    I have tried this same proccess with other computers, and cell phones on my network with the same result. Any help would greatly be appreciated. Thanks!

  2. #2
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    3

    Default Re: Hopefully the last Backtrack w/ MAC OSX thread ever! [SSL Stripping w/ Ettercap]

    thank u have share..

  3. #3
    Junior Member L21ZIFER's Avatar
    Join Date
    Nov 2011
    Posts
    47

    Default Re: Hopefully the last Backtrack w/ MAC OSX thread ever! [SSL Stripping w/ Ettercap]

    Show us your etter.conf.

Similar Threads

  1. Strange ettercap behaviour in Backtrack
    By cloud9 in forum Beginners Forum
    Replies: 3
    Last Post: 06-16-2010, 07:21 PM
  2. ettercap, backtrack 4 and VMware
    By been_1990 in forum OLD BackTrack 4 General Support
    Replies: 0
    Last Post: 01-22-2010, 12:44 PM
  3. can someone help me with ettercap
    By ins26 in forum OLD Newbie Area
    Replies: 3
    Last Post: 07-21-2009, 03:49 PM
  4. Replies: 2
    Last Post: 06-12-2009, 06:05 PM
  5. Stripping BT2
    By letterhope in forum OLD BackTrack v2.0 Final
    Replies: 15
    Last Post: 03-21-2008, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •