Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: The Fix for Metasploit update in BackTrack 5-R2

  1. #21
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    4

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    on the console when I type svn update
    appears:

    svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    Skipped '.'

    when I type msfupdate
    appears:

    svn: PROPFIND of '/svn/!svn/vcc/default': SSL negotiation failed: Connection reset by peer (https://www.metasploit.com)


    HeLP!!!

  2. #22
    Just burned their ISO
    Join Date
    Jul 2012
    Posts
    1

    Unhappy Re: The Fix for Metasploit update in BackTrack 5-R2

    Also, I have the same problem like this.
    And then, after I input msfupdate.
    reply:
    svn: PROPFIND of '/svn/framework3/trunk/lib/active_support/vendor/tzinfo-0.3.12/tzinfo/timezone_info.rb': could not connect to server (https://www.metasploit.com)
    And then, I input svn update.
    reply:
    svn: PROPFIND of '/svn/framework3/trunk/lib/active_support/vendor/tzinfo-0.3.12/tzinfo/timezone_info.rb': could not connect to server (https://www.metasploit.com) , too.

    Please help me.

  3. #23
    Just burned his ISO
    Join Date
    Jul 2012
    Posts
    1

    Exclamation Re: The Fix for Metasploit update in BackTrack 5-R2

    hello guys......i have a problem i am trying to update metasploit.....it is slowing me down...:-(

    svn: In directory 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters'
    svn: Error processing command 'modify-wcprop' in 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters'
    svn: 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/column.rb' is not under version control
    svn: Working copy '.' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)

    How can I fix this?

  4. #24
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    4

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    Is there Any Changres done from Metasploit.com on their Update Servers ??

    MSFUPDATE was working like acharm prevoiusly but now even after downloading the Files the process gets terminated at the last step

    U external/source/armitage/src/armitage/ArmitageApplication.java
    U external/source/armitage/src/armitage/ArmitageMain.java
    U external/source/armitage/resources/about.html
    A external/source/armitage/scripts-cortana
    A external/source/armitage/scripts-cortana/internal-ui.sl
    A external/source/armitage/scripts-cortana/internal.sl
    A external/source/armitage/scripts-cortana/cortanadb.sl
    A external/source/armitage/scripts-cortana/internal-ui-support.sl
    U external/source/armitage/build.xml
    U external/source/armitage/whatsnew.txt
    U msfvenom
    U msfpayload
    svn: REPORT of '/svn/!svn/vcc/default': Could not read response body: Connection reset by peer (https://metasploit.com)
    root@B0X:/opt/metasploit/msf3#
    root@B0X:/opt/metasploit/msf3#

    Guys any hint ?

    I tried the fix mentioned in the thread but no luck.

  5. #25
    Just burned his ISO
    Join Date
    Aug 2012
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    hi all! I have a problem with update msfupdate.
    [*][*] Attempting to update the Metasploit Framework...[*]

    svn: OPTIONS of 'https://www.metasploit.com/svn/framework3/trunk': could not connect to server (https://www.metasploit.com)

    i use proxy.
    I set up a proxy in the configuration files
    apt-get worked (/etc/apt/proxy)
    wget worked (/etc/wgetrc)

    why could´t connect to https://www.metasploit.com?

  6. #26
    Just burned his ISO
    Join Date
    Sep 2012
    Location
    Kenya
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    Quote Originally Posted by jenbo View Post
    Do you get an

    [*] msfupdate[*] Attempting to update the Metasploit Framework...[*]
    svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)

    error ?

    hears the FIX


    cd /opt/metasploit/common/lib

    mv libcrypto.so.0.9.8 libcrypto.so.0.9.8-b

    mv libssl.so.0.9.8 libssl.so.0.9.8-backup

    ln -s /usr/lib/libcrypto.so.0.9.8

    ln -s /usr/lib/libssl.so.0.9.8

    msfupdate
    This worked well.Another way i Have mine running was completely uninstalling the previous version of metaspoilt and installing the latest
    heres the commands.

    1.cd /opt/metaspoilt
    2. ./uninstall
    3.reboot
    4.download the latest version of metaspoilt from www.metaspoilt.com
    5.after run chmod u+x metaspoilt...latestversion.run
    6. ./metaspoilt...latestversion.run
    7.install metaspoilt as a service with the default port.Do not start the web console as this will cause a conflict
    8.finish install
    9.run msfupdate this should run the update smoothly

  7. #27
    Just burned his ISO
    Join Date
    Feb 2010
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    I went ahead and did the above fix of renaming the files and I was still getting the errors. So what did fix the issue was running
    apt-get update
    apt-get upgrade
    Had to run that twice to get everything fully updated.
    After that I was able to run msfupdate and it worked just fine. Now I am up to date with the latest version of metasploit on backtrack 5R2.
    Cheers.

  8. #28
    Just burned their ISO
    Join Date
    Jun 2011
    Posts
    2

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    I am attempting to do what the person above me suggested after going through and doing all of the other fixes. I have been working on getting metasploit and armitage working all morning. Will update as soon as the apt-get upgrade is done.

  9. #29
    Just burned their ISO
    Join Date
    Feb 2013
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    me metasploit is worked but when i update its not working and updating!
    how to fix this error :
    update error :
    Code:
    [*][*] Attempting to update the Metasploit Framework...[*]
    [*] Deprecation Note: The next version of Metasploit will[*] update over the git protocol, which requires outbound[*] access to github.com:9418/TCP.[*] Please adjust your egress firewall rules accordingly.
    svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
    svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
    svn: /opt/framework3/lib/libssl.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
    svn: /opt/framework3/lib/libcrypto.so.0.9.8: no version information available (required by /opt/framework3/lib/libserf-0.so.0)
    svn: OPTIONS of 'https://metasploit.com/svn/framework3/trunk': Server certificate verification failed: issuer is not trusted (https://metasploit.com)
    run error :
    Code:
    root@bt:~# msfconsole
    /opt/framework3/msf3/lib/msf/core/exploit/ipv6.rb:14:in `require': no such file to load -- racket (LoadError)
    	from /opt/framework3/msf3/lib/msf/core/exploit/ipv6.rb:14:in `<module:Ipv6>'
    	from /opt/framework3/msf3/lib/msf/core/exploit/ipv6.rb:12:in `<module:Msf>'
    	from /opt/framework3/msf3/lib/msf/core/exploit/ipv6.rb:5:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit/mixins.rb:30:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit/mixins.rb:30:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:217:in `require'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:217:in `<class:Exploit>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:29:in `<module:Msf>'
    	from /opt/framework3/msf3/lib/msf/core/exploit.rb:4:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/core.rb:52:in `require'
    	from /opt/framework3/msf3/lib/msf/core.rb:52:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui/console/driver.rb:1:in `require'
    	from /opt/framework3/msf3/lib/msf/ui/console/driver.rb:1:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui/console.rb:10:in `require'
    	from /opt/framework3/msf3/lib/msf/ui/console.rb:10:in `<top (required)>'
    	from /opt/framework3/msf3/lib/msf/ui.rb:10:in `require'
    	from /opt/framework3/msf3/lib/msf/ui.rb:10:in `<top (required)>'
    	from /opt/framework3/msf3/msfconsole:118:in `require'
    	from /opt/framework3/msf3/msfconsole:118:in `<main>'

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  2. not able to update metasploit
    By mia_tech in forum Beginners Forum
    Replies: 1
    Last Post: 09-23-2010, 09:41 PM
  3. update metasploit help
    By mvk1mvk2mvk3 in forum Beginners Forum
    Replies: 2
    Last Post: 09-20-2010, 11:14 PM
  4. Metasploit update
    By baslifrog in forum Beginners Forum
    Replies: 3
    Last Post: 03-19-2010, 12:25 AM
  5. How to Update Metasploit
    By purehate in forum OLD Announcements
    Replies: 0
    Last Post: 11-07-2009, 06:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •