Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: The Fix for Metasploit update in BackTrack 5-R2

  1. #11
    Just burned his ISO
    Join Date
    Dec 2010
    Posts
    14

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    didn't fix my problem, getting same issue

  2. #12
    Just burned his ISO
    Join Date
    May 2012
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    i did that already. but after a few minutes i got this message at the end of the update :
    svn: PROPFIND of '/svn/framework3/trunk/lib/active_support/vendor/tzinfo-0.3.12/tzinfo/timezone_info.rb': could not connect to server (https://www.metasploit.com)
    i chechked the metasploit in its still the same version, so . . . how do i fix this?

  3. #13
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    2

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    Fix Worked For Me Thanx

  4. #14
    Just burned his ISO
    Join Date
    May 2012
    Posts
    4

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    I have this same problem too... Also with W3AF... have tried everything now I think

  5. #15
    Just burned their ISO
    Join Date
    Jun 2012
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    Quote Originally Posted by jenbo View Post
    Do you get an

    [*] msfupdate[*] Attempting to update the Metasploit Framework...[*]
    svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libssl.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)
    svn: /opt/metasploit/common/lib/libcrypto.so.0.9.8: no version information available (required by /opt/metasploit/common/lib/libserf-0.so.0)

    error ?

    hears the FIX


    cd /opt/metasploit/common/lib

    mv libcrypto.so.0.9.8 libcrypto.so.0.9.8-b

    mv libssl.so.0.9.8 libssl.so.0.9.8-backup

    ln -s /usr/lib/libcrypto.so.0.9.8

    ln -s /usr/lib/libssl.so.0.9.8

    msfupdate
    I originally had this error with Metasploit so I used this fix. Now a new error appeared:

    svn: In directory 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters'
    svn: Error processing command 'modify-wcprop' in 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters'
    svn: 'lib/gemcache/ruby/1.9.1/gems/activerecord-3.2.2/lib/active_record/connection_adapters/column.rb' is not under version control
    svn: Working copy '.' locked
    svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details)

    How can I fix this?

  6. #16
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    All great, it worked perfectly for me too, Thanks alot

  7. #17
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    I'm new to backtrack but below given steps solved my metasploit update problem:
    1. Open Terminal
    2. Type cd /opt/metasploit/msf3/
    3.Type msfupdate and hit enter

    Hope this will solve your problem............

  8. #18
    Senior Member
    Join Date
    Feb 2012
    Location
    Cyberspace
    Posts
    174

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    Fix worked for me as well. But anyway previously I always updated this way:
    first
    cd /opt/metasploit/msf3
    and then
    svn update

  9. #19
    Just burned his ISO
    Join Date
    Jun 2012
    Posts
    1

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    Even though msfupdate worked with those error message, this fixed it, thanks!

  10. #20
    Just burned his ISO anon3355's Avatar
    Join Date
    Jun 2012
    Posts
    2

    Default Re: The Fix for Metasploit update in BackTrack 5-R2

    I am gettin the following message:
    Code:
    svn: OPTIONS of 'https://www.metasploit.com/svn/framework3/trunk': Could not resolve hostname `www.metasploit.com': No address associated with hostname (https://www.metasploit.com)
    any clue..

Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. Replies: 1
    Last Post: 05-07-2011, 01:35 PM
  2. not able to update metasploit
    By mia_tech in forum Beginners Forum
    Replies: 1
    Last Post: 09-23-2010, 09:41 PM
  3. update metasploit help
    By mvk1mvk2mvk3 in forum Beginners Forum
    Replies: 2
    Last Post: 09-20-2010, 11:14 PM
  4. Metasploit update
    By baslifrog in forum Beginners Forum
    Replies: 3
    Last Post: 03-19-2010, 12:25 AM
  5. How to Update Metasploit
    By purehate in forum OLD Announcements
    Replies: 0
    Last Post: 11-07-2009, 06:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •