Results 1 to 2 of 2

Thread: oclHashcat+ errors

  1. #1
    Junior Member
    Join Date
    Jul 2006

    Default oclHashcat+ errors

    Has anyone got this to work! in BT5 R1 | 64bit KDE

    I keep getting

    ./oclHashcat-plus32.bin: error while loading shared libraries: cannot open shared object file: No such file or directory

    The path is defined! correctly to libOpenCL

    my gpu is configured correctly is working fine in pyrit. (HD Radeon 6770 , AMD FX-4100 CPU)

    snip of .bashrc

    # enable programmable completion features (you don't need to enable
    # this, if it's already enabled in /etc/bash.bashrc and /etc/profile
    # sources /etc/bash.bashrc).
    #if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    #    . /etc/bash_completion
      export HISTCONTROL=ignoreboth
    export PATH=$PATH:/etc/alternatives/gem-bin
    export AMDAPPSDKROOT=/opt/AMD-APP-SDK-v2.5-RC2-lnx64/
    export AMDAPPSDKSAMPLESROOT=/opt/AMD-APP-SDK-v2.5-RC2-lnx64/
    also if any help

    HTML Code:
    root@bt:/pentest/passwords/oclhashcat+# ./oclHashcat-plus32.bin
                                                              ./oclHashcat-plus32.bin: error while loading shared libraries: wrong ELF class: ELFCLASS64
    root@bt:/pentest/passwords/oclhashcat+# ./oclHashcat-plus64.bin
                                                               bash: ./oclHashcat-plus64.bin: cannot execute binary file
    all the latest updates from repo have been applied.

    I'd appreciate any help been as i've been at this for hours and my brains mangled with it.
    Tarmac Terrorist

  2. #2
    Just burned his ISO
    Join Date
    Feb 2010

    Default Re: oclHashcat+ errors

    I have same problem.
    ./oclHashcat-plus64.bin: error while loading shared libraries: cannot open shared object file: No such file or directory
    Pyrit seems to be working though, and it uses OpenCL, as far as I know...

    What's the deal?

    I have Ati hd4870.

    Edit: I solved it by installing the AMD APP SDK:

    whereis libOpenCL returns "libOpenCL: /usr/lib/" now.
    Last edited by Persuadatron; 03-14-2012 at 10:42 AM. Reason: solution

Similar Threads

  1. Oclhashcat Nvidia 560M
    By Black0p in forum BackTrack 5 Bugs
    Replies: 0
    Last Post: 02-18-2012, 08:55 PM
  2. Oclhashcat+
    By Nazagul in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 08-23-2011, 12:36 AM
  3. oclhashcat bug in backtrack r1
    By Xploit in forum BackTrack Bugs
    Replies: 8
    Last Post: 03-26-2011, 10:36 AM
  4. Oclhashcat
    By purehate in forum BackTrack Howtos
    Replies: 1
    Last Post: 06-20-2010, 07:42 PM
  5. Dell Latitude D531 boot errors. (media errors)
    By Dutch in forum OLD BackTrack 4 NON working hardware
    Replies: 2
    Last Post: 08-20-2009, 05:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts