Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: apt-get install libssl-dev failing

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    1

    Default apt-get install libssl-dev failing

    Hi All,

    I just recently started with a fresh hardware install of BT5R2. When attempted to apt-get install libssl-dev, I get the following error.

    Code:
    root@TheRig:/pentest/passwords/mpijohn/src# apt-get install libssl-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.6) but 0.9.8k-7ubuntu8.8 is to be installed
    E: Broken packages
    Any ideas why this is happening, or what I can do to by pass this. I need this installed for jtr over mpi.

    Thanks,
    Lix

  2. #2
    Administrator sickness's Avatar
    Join Date
    Jan 2010
    Location
    Behind the screen.
    Posts
    2,921

    Default Re: apt-get install libssl-dev failing

    What Backtrack5 R2 have you downloaded ? What architecture / flavor ? Does the MD5SUM correspond ?
    I can not reproduce the issue:

    Code:
    root@bt:~# apt-get install libssl0.9.8 libssl-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libssl0.9.8 is already the newest version.
    The following packages were automatically installed and are no longer required:
      libdmraid1.0.0.rc16 python-pyicu libdebian-installer4 cryptsetup libecryptfs0 reiserfsprogs rdate bogl-bterm
      ecryptfs-utils libdebconfclient0 dmraid
    Use 'apt-get autoremove' to remove them.
    The following NEW packages will be installed:
      libssl-dev
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 2,012kB of archives.
    After this operation, 5,857kB of additional disk space will be used.
    Get:1 http://updates.repository.backtrack-linux.org/ revolution/main libssl-dev 0.9.8k-7ubuntu8.8 [2,012kB]
    Fetched 2,012kB in 3s (532kB/s)       
    Selecting previously deselected package libssl-dev.
    (Reading database ... 237523 files and directories currently installed.)
    Unpacking libssl-dev (from .../libssl-dev_0.9.8k-7ubuntu8.8_i386.deb) ...
    Processing triggers for man-db ...
    Setting up libssl-dev (0.9.8k-7ubuntu8.8) ...
    root@bt:~#
    Back|track giving machine guns to monkeys since 2007 !

    Do not read the Wiki, most your questions will not be answered there !
    Do not take a look at the: Forum Rules !

  3. #3
    Just burned their ISO MI1c00k's Avatar
    Join Date
    Jul 2011
    Location
    Slovakia
    Posts
    9

    Default Re: apt-get install libssl-dev failing

    Same here, BackTrack 5 R2, 32bit, KDE. libssl0.9.8 is fine:

    apt-get install libssl0.9.8
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libssl0.9.8 is already the newest version.
    i need libssl-dev too:

    apt-get install libssl-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.6) but 0.9.8k-7ubuntu8.8 is to be installed
    E: Broken packages

  4. #4
    Just burned his ISO
    Join Date
    Jan 2009
    Posts
    1

    Default Re: apt-get install libssl-dev failing

    Hi,

    Same Issue here. I'm using BT 5 R2 32bit Gnome installed direct to my harddrive.

    root@bt:~# apt-get install libssl0.9.8 libssl-dev
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libssl0.9.8 is already the newest version.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.6) but 0.9.8k-7ubuntu8.8 is to be installed
    E: Broken packages
    root@bt:~#

  5. #5
    Just burned his ISO
    Join Date
    Dec 2007
    Posts
    7

    Default Re: apt-get install libssl-dev failing

    Same problem with my BT5R2. I tried the VM one and installed from ISO. When trying to install libssl-dev it complains. Also complains when trying to install dhcp3-server

    I got around the libssl-dev issue by installing the Ubuntu version that Backtrack was complaining about, but I would rather not go this route.
    http://launchpadlibrarian.net/924504...tu8.8_i386.deb

  6. #6
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    1

    Default Re: apt-get install libssl-dev failing

    I too, have the same issue. I have followed many, many different tutorials to get my ATI Radeon processor working with pyrit, however all of them have involved libssl-dev. I'm rather peeved at this too, since I'm only getting 1500 k/s and with pyrit, I should be getting well over 20,000 k/s.

  7. #7
    Just burned his ISO
    Join Date
    Oct 2010
    Posts
    1

    Default Re: apt-get install libssl-dev failing

    Also having the same problem and other ones:
    Code:
    apt-get install libroot-python-dev libboost-python-dev zlib1g-dev libssl-dev cmake libboost1.40-all-dev
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    zlib1g-dev is already the newest version.
    zlib1g-dev set to manually installed.
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libboost1.40-all-dev: Depends: libboost-iostreams1.40-dev but it is not going to be installed
                            Depends: libboost-regex1.40-dev but it is not going to be installed
      libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.6) but 0.9.8k-7ubuntu8.8 is to be installed
    E: Broken packages
    Code:
    apt-get install libboost-regex1.40-dev
    
    The following packages have unmet dependencies:
      libboost-regex1.40-dev: Depends: libicu-dev but it is not going to be installed
    E: Broken packages
    Code:
    apt-get install libicu-dev
    
    The following packages have unmet dependencies:
      libicu-dev: Depends: libicu42 (= 4.2.1-3) but 4.2.1-3ubuntu0.10.04.1 is to be installed
    E: Broken packages

  8. #8
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    2

    Default Re: apt-get install libssl-dev failing

    I'm using BT5R2-GNOME-64 release.
    I'm trying to run cpyrit and to install it it needs openssl. So I tried to "apt-get install openssl-dev" and "apt-get install libssl-dev". The first command replays with:
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    E: Couldn't find package openssl-dev
    The second says:
    Code:
    eading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libssl-dev: Depends: libssl0.9.8 (= 0.9.8k-7ubuntu8.6) but 0.9.8k-7ubuntu8.8 is to be installed
    E: Broken packages
    Some suggestions would be greatly appreciated.

  9. #9
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    2

    Default Re: apt-get install libssl-dev failing

    I found solution to the problem!
    Add the following to /etc/apt/sources.list :

    deb http://security.ubuntu.com/ubuntu lucid-security main
    type in the terminal:
    Code:
    apt-get update
    Then, delete the newly added entry of the sources.list.
    After that "apt-get install libssl-dev" should be working.

    This solved the problem for me!
    Thanks to samiux!

  10. #10
    Just burned his ISO
    Join Date
    Sep 2012
    Posts
    4

    Default Re: apt-get install libssl-dev failing

    Quote Originally Posted by sashkom View Post
    I found solution to the problem!

    After that "apt-get install libssl-dev" should be working.

    This solved the problem for me!
    Thanks to samiux!
    Thanks worked for me too!!

Page 1 of 2 12 LastLast

Similar Threads

  1. Nvidia driver install failing due to nouveau driver
    By daquicker in forum BackTrack 5 Beginners Section
    Replies: 4
    Last Post: 02-08-2012, 01:35 PM
  2. Replies: 1
    Last Post: 12-28-2011, 03:21 AM
  3. Startx failing
    By Bukva in forum BackTrack 5 Beginners Section
    Replies: 11
    Last Post: 05-13-2011, 04:27 AM
  4. Backtrack 4 Failing to Install on HDD
    By DarkOwnage in forum Beginners Forum
    Replies: 6
    Last Post: 06-19-2010, 03:08 PM
  5. Booting keeps failing. Help me?
    By UnknownError in forum Beginners Forum
    Replies: 4
    Last Post: 01-17-2010, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •