Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Nvidia driver install on BT5r2 Kernel 3.2.6

  1. #11
    Good friend of the forums zimmaro's Avatar
    Join Date
    Mar 2010
    Location
    milano
    Posts
    407

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    Compiz procedure only for gnome after enable effect in system-aspect...
    Kde have default install compiz
    Sorry my english!

  2. #12
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    5

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    hi to all..
    I made a clean install of bt5 r2 64bit on a dual OS with win7.
    I have an optimus graphics geForce 520MX 1gb with intel graphics controller.
    it seems that none of the methods of official tutorials and how-to's is working for me...
    the only way to get the driver(latest 295.20) working is Bumblebee.
    The 'dev' driver just cant be installed...complaining for 'nvidia.ko'
    the Bumblebe thing helped me to install Cuda n' Sdk properly...
    The point is nvidia settings cannot make the right xorg.conf file or X cannot load nvidia driver...
    First time said cannot find nvidia module,screen not found...etc.I dealed with that by adding 'nvidia' (just one word) to file /etc/module.
    Second time after that said Primary Device is: PCI 00@00:02:0 (this is the intel controller)No devices detected.
    i had to try to install and uninstall drivers up 10 times..
    The only trouble with the whole situation is i can't use the settings i want for my laptop(screen res,power management) and that i cannot overlock my card to my whilings...Ay ideas????thnks!!!

    xorg.log First time
    Code:
    X.Org X Server 1.7.6
    Release Date: 2010-03-17
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-30-server x86_64 Ubuntu
    Current Operating System: Linux bt 3.2.6 #1 SMP Fri Feb 17 10:34:20 EST 2012 x86_64
    Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.6 root=UUID=7ad5288a-ab33-49cd-a2f3-3fcc104a5845 ro text splash vga=791
    Build Date: 25 February 2012  06:57:33AM
    xorg-server 2:1.7.6-2ubuntu7.11 (For technical support please see http://www.ubuntu.com/support) 
    Current version of pixman: 0.16.4
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar  9 00:18:15 2012
    (==) Using config file: "/etc/X11/xorg.conf"
    (==) Using config directory: "/usr/lib/X11/xorg.conf.d"
    (==) ServerLayout "Layout0"
    (**) |-->Screen "Screen0" (0)
    (**) |   |-->Monitor "Monitor0"
    (**) |   |-->Device "Device0"
    (**) |-->Input Device "Keyboard0"
    (**) |-->Input Device "Mouse0"
    (**) Option "Xinerama" "0"
    (==) Automatically adding devices
    (==) Automatically enabling devices
    (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    	Entry deleted from font path.
    (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    	Entry deleted from font path.
    (==) FontPath set to:
    	/usr/share/fonts/X11/misc,
    	/usr/share/fonts/X11/Type1,
    	/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType,
    	built-ins
    (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    (WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
    (WW) Disabling Keyboard0
    (WW) Disabling Mouse0
    (II) Loader magic: 0x7cb840
    (II) Module ABI versions:
    	X.Org ANSI C Emulation: 0.4
    	X.Org Video Driver: 6.0
    	X.Org XInput driver : 7.0
    	X.Org Server Extension : 2.0
    (--) using VT number 8
    
    (--) PCI:*(0:0:2:0) 8086:0116:1043:1682 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller rev 9, Mem @ 0xdc400000/4194304, 0xb0000000/268435456, I/O @ 0x0000e000/64
    (--) PCI: (0:1:0:0) 10de:1051:1043:1762 nVidia Corporation rev 161, Mem @ 0xdb000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000d000/128, BIOS @ 0x????????/524288
    (II) Open ACPI successful (/var/run/acpid.socket)
    (II) LoadModule: "extmod"
    (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    (II) Module extmod: vendor="X.Org Foundation"
    	compiled for 1.7.6, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension MIT-SCREEN-SAVER
    (II) Loading extension XFree86-VidModeExtension
    (II) Loading extension XFree86-DGA
    (II) Loading extension DPMS
    (II) Loading extension XVideo
    (II) Loading extension XVideo-MotionCompensation
    (II) Loading extension X-Resource
    (II) LoadModule: "dbe"
    (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    (II) Module dbe: vendor="X.Org Foundation"
    	compiled for 1.7.6, module version = 1.0.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DOUBLE-BUFFER
    (II) LoadModule: "glx"
    (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    (II) Module glx: vendor="NVIDIA Corporation"
    	compiled for 4.0.2, module version = 1.0.0
    	Module class: X.Org Server Extension
    (II) NVIDIA GLX Module  295.20  Mon Feb  6 21:28:16 PST 2012
    (II) Loading extension GLX
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    	compiled for 1.7.6, module version = 1.13.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension RECORD
    (II) LoadModule: "dri"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    (II) Module dri: vendor="X.Org Foundation"
    	compiled for 1.7.6, module version = 1.0.0
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension XFree86-DRI
    (II) LoadModule: "dri2"
    (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    (II) Module dri2: vendor="X.Org Foundation"
    	compiled for 1.7.6, module version = 1.1.0
    	ABI class: X.Org Server Extension, version 2.0
    (II) Loading extension DRI2
    (II) LoadModule: "nvidia"
    (WW) Warning, couldn't open module nvidia
    (II) UnloadModule: "nvidia"
    (EE) Failed to load module "nvidia" (module does not exist, 0)
    (EE) No drivers available.
    
    Fatal server error:
    no screens found
    
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    
     ddxSigGiveUp: Closing log
    here is the default creation of nvidia-xconfig
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 295.20  (buildd@rhenium)  Wed Feb 15 05:03:58 UTC 2012
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: builtin, VertRefresh source: builtin
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "CRT-0"
        HorizSync       28.0 - 55.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GT 520MX"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  3. #13
    Just burned his ISO
    Join Date
    Mar 2012
    Location
    Serbia
    Posts
    2

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    Hi. I have problem with my 64-bit edition. I have installed first BT5 edition, than installed NVIDIA-Linux-x86_64-173.14.31-pkg2.run driver following instructions from this page, and it was all OK untill today I've updated and upgraded to the newest kernel (3.2.6). Now I simply can't install this driver again, although I've installed newest kernel headers and I've typed this in command line:

    sh NVIDIA-Linux-x86_64-173.14.31-pkg2.run --kernel-source-path /usr/src/linux-headers-3.2.6/


    What should I do? Thanks in advance.

  4. #14
    Junior Member
    Join Date
    Feb 2012
    Location
    over here!
    Posts
    30

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    Hi,

    Slightly out of my depth here but have you tried:

    prepare-kernel-sources
    cd /usr/src/linux
    cp -rf include/generated/* include/linux/

    hit ctrl+alt+f1 to stop xserver

    apt-get --purge remove xserver-xorg-video-nouveau

    nano /etc/default/grub

    add "...vga=791 nouveau.modeset=0"

    exit and save then

    update-grub

    reboot

    before installing drivers?

    Also, some appear to have more success with the 285 driver for 64 bit edition when trying to pyrit / cuda going so trying the 285 drivers may help?


    before installing driver
    Last edited by twocents; 03-11-2012 at 11:15 AM.

  5. #15
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    5

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    Quote Originally Posted by twocents View Post
    Hi,

    Slightly out of my depth here but have you tried:

    prepare-kernel-sources
    cd /usr/src/linux
    cp -rf include/generated/* include/linux/

    hit ctrl+alt+f1 to stop xserver

    apt-get --purge remove xserver-xorg-video-nouveau

    nano /etc/default/grub

    add "...vga=791 nouveau.modeset=0"

    exit and save then

    update-grub

    reboot

    before installing drivers?

    Also, some appear to have more success with the 285 driver for 64 bit edition when trying to pyrit / cuda going so trying the 285 drivers may help?


    before installing driver
    Yes i ve tried this as well as the official tutorial here http://www.backtrack-linux.org/wiki/...A_On_BackTrack n' some others as well... the problem is on nvidia-xconfig.....
    So any settings cannot be saved so to apply when X restarts!!
    i havent tried 285...but i m able to use cuda + sdk and pyrit cuda cause the use of bumblebee.Isnt that ODD??

  6. #16
    Just burned his ISO
    Join Date
    Mar 2012
    Location
    Serbia
    Posts
    2

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    Quote Originally Posted by twocents View Post
    Hi,

    Slightly out of my depth here but have you tried:

    prepare-kernel-sources
    cd /usr/src/linux
    cp -rf include/generated/* include/linux/

    hit ctrl+alt+f1 to stop xserver

    apt-get --purge remove xserver-xorg-video-nouveau

    nano /etc/default/grub

    add "...vga=791 nouveau.modeset=0"

    exit and save then

    update-grub

    reboot

    before installing drivers?

    Also, some appear to have more success with the 285 driver for 64 bit edition when trying to pyrit / cuda going so trying the 285 drivers may help?


    before installing driver
    I've tried everything that was recommended in this thread, I've tried installing driver 285 and 295, but still without success.

  7. #17
    Just burned his ISO
    Join Date
    Mar 2012
    Posts
    5

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    To sputnix,

    what system do you have?
    if u have an optimus system (intel & nvidia gpu) try this Part II with bbswitch http://www.backtrack-linux.org/forum...ad.php?t=48331 or you can use bumblebee to use your nvidia gpu here https://wiki.ubuntu.com/Bumblebee
    Although its strange u have been able to install the driver on BT r1 without problems...

  8. #18
    Just burned his ISO
    Join Date
    Mar 2010
    Posts
    5

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    I tried this version of install, but unfortunatelly is not CUDA enabled. I highly recommend the latest original driver from nVidia and latest Cuda package.

  9. #19
    Just burned his ISO
    Join Date
    May 2012
    Posts
    1

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    grub --> recovery mode ---> root console
    #echo options nouveau modeset=0 | sudo tee -a /etc/modprobe.d/nouveau-kms.conf
    #update-initramfs -u

    reboot

    # sh <filename_nvidia_driver>.run
    # startx

    have a nice day =)

  10. #20
    Just burned their ISO
    Join Date
    Feb 2010
    Posts
    18

    Default Re: Nvidia driver install on BT5r2 Kernel 3.2.6

    I introduce more shorten how-to than your method. mine is the following:
    #add-apt-repository ppa:ubuntu-x-swat/x-updates
    #apt-get update

    #apt-get install nvidia-current nvidia-current-modaliases nvidia-settings
    after reboot, type the command "nvidia-xconfig"(without quotation) in the shell. and then startx
    Last edited by linou; 05-03-2012 at 03:39 AM.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. nvidia driver installation impossible after upgrading to kernel 3.2.6
    By softize in forum BackTrack 5 Beginners Section
    Replies: 3
    Last Post: 03-06-2012, 11:47 PM
  2. NVIDIA driver install - Error: Unable to find the kernel source tree......
    By Chinese in forum BackTrack 5 Beginners Section
    Replies: 45
    Last Post: 07-21-2011, 12:31 AM
  3. nVidia driver wont install after upgrading to kernel 2.6.35.8
    By Ducati1098R in forum Beginners Forum
    Replies: 0
    Last Post: 01-22-2011, 04:36 PM
  4. Nvidia graphic driver on 64 bit kernel.
    By hacup in forum Beginners Forum
    Replies: 1
    Last Post: 04-26-2010, 08:29 AM
  5. kernel 2.6.30-7 y driver de video nvidia
    By imported_hackmaf in forum Soporte en Hardware
    Replies: 3
    Last Post: 04-07-2010, 06:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •