Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Pyrit Cuda Nvidia Optimus Power Drain

  1. #21
    Just burned his ISO
    Join Date
    Jul 2012
    Posts
    1

    Default Re: Pyrit Cuda Nvidia Optimus Power Drain

    It might be worth noting that due to a bug, some Optimus laptop (that has customized N-card) will have problem recognizing the NV card. Upon loading nVidia's driver/dmesg, you'll see error "NVRM: failed to copy vbios to system memory."

    A hack can be found here:https://github.com/Bumblebee-Project...novo/README.md

    BTW, thanks for the awesome guide.

  2. #22
    Just burned his ISO
    Join Date
    Oct 2012
    Posts
    1

    Default Re: Pyrit Cuda Nvidia Optimus Power Drain

    snafu777,

    first of all thanks for the great job you did, and thanks to it i got pyrit successfuly working with Cuda, so i've managed to install well the new 304.51 drivers and so on, but what i can't get now is my system to work on Nvidia drivers permanently. When i go on System settings -> Nvidia X server settings and click on it i get error message saying:

    "You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

    If i do run the command : "nvidia-xconfig" as root i get the /etc/X11/xorg.conf doesn't exist it will be created, but after when i try to start X on the next session i can't do it till i don't remove the file /etc/X11/xorg.conf created.

    my system is :

    Samsung np-rc530
    Graphic card: nvidia gt 540 M
    Backtrack 5R3 64bit KDE

    Thanks in advance,

    Alex

  3. #23
    Just burned their ISO
    Join Date
    Dec 2012
    Posts
    1

    Default Re: Pyrit Cuda Nvidia Optimus Power Drain

    i got everything working on my alienware m14xr2 laptop
    pyrit gives me 1 cuda core + i7 @ 8407pmk
    the optirun works fine + gears test

    i can open nvidia settings, but get the error below

    i get the error :
    you do not appear to be using the nvidia x driver please edit your X configuration file (just run nvidia-xconfig ) as root and restart the x server

    but there is no nvidia-xconfig file found only nvidia-settings
    if i do modprobe nvidia . i get fatal error inserting nvdia (lib/modules/3.2.6/updates/dkms/nvidia.ko) no such device

    my system is :
    alienware M14X R2
    Graphic card: nvidia gt 650 M 2gig
    Backtrack 5R3 64bit GNOME

    Thanks in advance,

  4. #24
    Senior Member
    Join Date
    Jul 2011
    Posts
    236

    Default Gr33tz

    Sorry I don't really respond like I used to on here. I pissed off one of the moderators a while back, and as you can see I am "Permanently Moderated".

    That aside, the guide was never meant to make it the nvidia card work from the true GPU standpoint. It was only meant to enable the user to be able to
    1) Control the power drain from having two GPUs

    2) Enable them to use cuda

    For anything else, I never really bothered because when I want GPU eye candy I stick with Linux Mint or Windows..... Remember, BT is not for everyday usage =)


    I am glad to see that people truly enjoyed the guides I have made on here. Maybe one day again I'll get back into writing on here again.

    Thanks for the support =)

    I am always happy to talk hacking.


    --Snafu
    V/r,
    Snafu
    Pffbt..[quote]I made a discovery today. I found a computer. Wait a second, this is cool. It does what I want it to. If it makes a mistake, it's because I screwed it up. Not because it doesn't like me... Or feels threatened by me.. Or thinks I'm a smart ass.. [/quote]

Page 3 of 3 FirstFirst 123

Similar Threads

  1. Nvidia Optimus problem
    By s0me0ne in forum BackTrack 5 Beginners Section
    Replies: 8
    Last Post: 07-17-2011, 02:48 PM
  2. Nvidia 64 drivers / Cuda and pyrit
    By vvpalin in forum BackTrack 5 Beginners Section
    Replies: 7
    Last Post: 07-07-2011, 12:11 AM
  3. Nvidia optimus
    By amithiel in forum Beginners Forum
    Replies: 2
    Last Post: 02-10-2011, 09:26 AM
  4. pyrit with CUDA support not showing CUDA cores
    By kill_box001 in forum Beginners Forum
    Replies: 7
    Last Post: 08-14-2010, 06:29 PM
  5. pyrit CUDA nvidia Tutorial + Nvidia overclock instructions
    By purehate in forum OLD BT4beta HowTo's
    Replies: 155
    Last Post: 01-26-2010, 12:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •