Results 1 to 4 of 4

Thread: Backtrack 5 Distribution upgrade from R1 to R2 leads to display problems

Hybrid View

  1. #1
    Just burned his ISO
    Join Date
    Feb 2012
    Posts
    2

    Default Backtrack 5 Distribution upgrade from R1 to R2 leads to display problems

    I know that Backtrack 5 R2 distribution upgrade has been available for only a few days, but I seemed to run into an issue after coducting an apt-get dist-upgrade from Backtrack R1. I now am running the 3.2.6 kernel on my Acer Aspire 722 netbook. For some reason, my display is not loading right anymore. My graphics adapter is an AMD Radeon HD 6250. R1 had a perfect and clear display. Anyone have thoughts on how i can fix this? I have tried downloading the latest drivers from AMD site but still doesn't fix it. I maybe missing something. I appreciate the help in advance.

  2. #2
    Member
    Join Date
    Jan 2011
    Posts
    63

    Default Re: Backtrack 5 Distribution upgrade from R1 to R2 leads to display problems

    Here's a thread in the "Bug" section of the forums that people are reporting issues such as this. I had a problem with my Intel HD graphics only working at 1024x768 when on R1 they work perfectly out of the box.

    http://www.backtrack-linux.org/forum...ad.php?t=48243

  3. #3
    My life is this forum Snayler's Avatar
    Join Date
    Jan 2010
    Posts
    1,418

    Default Re: Backtrack 5 Distribution upgrade from R1 to R2 leads to display problems

    Check if the solution on the following link fixes the problem: http://www.tuxgarage.com/2011/01/ubu...n-problem.html

  4. #4
    Just burned his ISO
    Join Date
    Feb 2012
    Posts
    2

    Default Re: Backtrack 5 Distribution upgrade from R1 to R2 leads to display problems AMD ATI

    Hi All,
    Thanks for the suggestions. I actually just figured it out and fixed it!

    1.) First - go to this link which applies to many AMD ATI Radeon adapters. http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    2.) Using the link as a guide above a few things need to be different to be able to get this to work with the lucid release with Kernel 3.2.6. In the section that references "sh amd-driver-installer-12-1-x86.x86_64.run --buildpkg Ubuntu/maverick" change this to "sh amd-driver-installer-12-1-x86.x86_64.run --buildpkg Ubuntu/lucid".

    3.) Also - YOU MUST run "prepare-kernel-sources" prior to running the command "dpkg -i fglrx*.deb" or it will not find your 3.2.6 kernel source. This is where I ran into my problem initially.

    4.) Once you run that and setup the initial xorg.conf file with "amdconfig --initial -f" and reboot to the 3.2.6 kernel, all worked well!

    Hope this will help others!


Similar Threads

  1. kernel upgrade display error
    By teloris in forum Beginners Forum
    Replies: 0
    Last Post: 08-20-2010, 08:04 AM
  2. distribution upgrade??
    By idrez in forum Beginners Forum
    Replies: 3
    Last Post: 02-19-2010, 05:24 AM
  3. Toshiba Satelilite pro 4600 display problems
    By JackNco in forum OLD BT3beta NON-WORKING HARDWARE
    Replies: 7
    Last Post: 12-20-2007, 07:18 AM
  4. X Window Display Problems
    By =KoG= in forum OLD Newbie Area
    Replies: 1
    Last Post: 12-14-2007, 11:01 PM
  5. BackTrack Display Problems
    By cowgerbs in forum OLD BackTrack v2.0 Final
    Replies: 1
    Last Post: 03-19-2007, 05:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •