I follow Google code instructions on how to update BeEF (beef-ng) in BackTrack 5 R1 and I got the same error everytime

Google repository instructions
Code:
http://code.google.com/p/beef/wiki/UsingTheLatestBeEFInBT5
Following the next steps you will be able to use use the latest BeEF on your pentests using BT5:

rm -rf /pentest/web/beef-ng
svn checkout http://beef.googlecode.com/svn/trunk/ /pentest/web/beef
GEM PATHS defined in the Gem Environment are wrong, so: add export GEM_PATH=/var/lib/gems/1.9.2/gems and export GEM_HOME=/var/lib/gems/1.9.2/gems to /etc/profile
source /etc/profile
cd /pentest/web/beef, then run ruby install , and press 2 to list all the required gems
install these required gems with gem install 'gem list from previous step'
to see if everything went ok:

root@bt:~# irb
irb(main):001:0> require 'rubygems'
=> false
irb(main):002:0> require 'dm-core'
=> true
irb(main):003:0> Gem.path
=> ["/var/lib/gems/1.9.2/gems"]
irb(main):004:0> quit

Start BeEF with the default SQLite DB: ruby beef -x

Now BeEF is up-and-running and can be updated to the latest trunk version with the usual svn update command from the /pentest/web/beef directory.
I'm getting a /core/loader.rb no such file to load error

I must admit I'm new to backtrack but my team and I need to write a paper about BeEF

I found this video on YouTube, after following the instructions I ended getting the same problem

Can anyone help us