Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: ar9271 and BT5r1 Fully working! Reg_Domain change APmode full power! ^_^

  1. #11
    Just burned his ISO
    Join Date
    Oct 2009
    Posts
    4

    Default Re: ar9271 and BT5r1 Fully working! Reg_Domain change APmode full power! ^_^

    Quote Originally Posted by dishit View Post
    This Script seems to work for the Old Alfa AWUS036H just make a File and copy this into it. Then right click
    on the file and change the permissions to executable. Then to run just double click on the File you made on the Desktop.

    #!/bin/sh
    airmon-ng check killall
    ifconfig wlan0 down
    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up
    ls -l /sys/class/net/wlan0/device/driver
    lsmod | grep -i rtl8187
    ifconfg wlan0 down
    iw reg set BO
    iwconfig wlan0 txpower 30
    ifconfig wlan0 up
    airmon-ng start wlan0

    That Country Code BO must already have a txpower of 30 set in the CRDA so NO CHANGES TO SYSTEM ARE NEEDED.
    If you would like to see what is going on go to System/Preferences/Log File Viewwer Once you stat Log Viewer now your ready to see what is goin on. Open a Terminal Window and type COUNTRY=GB
    press Enter Key Now type iw reg set GB press the Enter Key. Now enter iw reg get and press the Enter Key. If you do not see it change in the terminal window look and see if it changed in the Log File Viewer. If it did not unplug your USB WIFI DEVICE run the commands again then plug in your wifi device and type iw reg get it should show the change to COUNTRY CODE GB you can can difference country codes if you have installed crda.

  2. #12
    Just burned his ISO
    Join Date
    May 2009
    Posts
    16

    Default Re: ar9271 and BT5r1 Fully working! Reg_Domain change APmode full power! ^_^

    Quote Originally Posted by dishit View Post
    This Script seems to work for the Old Alfa AWUS036H just make a File and copy this into it. Then right click
    on the file and change the permissions to executable. Then to run just double click on the File you made on the Desktop.

    #!/bin/sh
    airmon-ng check killall
    ifconfig wlan0 down
    rmmod rtl8187
    rfkill block all
    rfkill unblock all
    modprobe rtl8187
    rfkill unblock all
    ifconfig wlan0 up
    ls -l /sys/class/net/wlan0/device/driver
    lsmod | grep -i rtl8187
    ifconfg wlan0 down
    iw reg set BO
    iwconfig wlan0 txpower 30
    ifconfig wlan0 up
    airmon-ng start wlan0

    That Country Code BO must already have a txpower of 30 set in the CRDA so NO CHANGES TO SYSTEM ARE NEEDED.
    LOL you newb....

    FIRST US is at 35 txpower not 30

    SECOND BO wont unlock as many frequencies or by pass the EEprom lock.

    THIRD The only reason you setup works is due to the fact that you have a fake ALFA, the ar9271 would never light up with the RTL8187 module....

  3. #13
    Just burned his ISO
    Join Date
    Jul 2008
    Location
    earth
    Posts
    16

    Default Re: ar9271 and BT5r1 Fully working! Reg_Domain change APmode full power! ^_^

    Should this allow me to change the reg set in BT5r2 or is this only tested/working on r1?

  4. #14
    Just burned his ISO
    Join Date
    Aug 2012
    Posts
    1

    Default Re: ar9271 and BT5r1 Fully working! Reg_Domain change APmode full power! ^_^

    Quote Originally Posted by internet_Dude View Post
    Should this allow me to change the reg set in BT5r2 or is this only tested/working on r1?

    I had to do this on the latest download of BT5R2, but the LIVE version spit out indiscernible compile errors when trying to compile the 2nd portion (CRDA) until I executed the make install on the persistent installation. I still encountered compile errors until performing specific development package updates, specifically:

    sudo apt-get install -y python-dev
    sudo apt-get install -y python-M2Crypto
    sudo apt-get install -y libnl-dev
    sudo apt-get install -y libc-dev
    sudo apt-get install -y libssl-dev
    sudo apt-get install -y libgcrypt-dev
    git clone git://git.kernel.org/pub/scm/linux/kernel/git/linville/wireless-regdb.git
    mkdir /etc/wireless-regdb/pubkeys/

    Afterwards, it made the original instructions in this post easier to implement.

    Maybe it is obvious, but it also seems necessary to dispel any misconceptions based on some of the odd questions and even outlandish claims across the Internet, these patches/modifications won't magically exceed the WiFi adapter's nor physical power limitation of the PC. I've read some strange claims of those who insist they're achieving 10 watts of WiFi from a 500mw USB port or people claiming to set their cards on literally on fire or other things such as 10 miles of Kismet visibility and these are ridiculous claims.

    Signal strength is affected by more than just wattage and too many factors for this posting and already adequately addressed elsewhere.

  5. #15
    Just burned his ISO
    Join Date
    Sep 2012
    Posts
    1

    Question Re: ar9271 and BT5r1 Fully working! Reg_Domain change APmode full power! ^_^

    Quote Originally Posted by hellmonger View Post
    You should do some reading on your ar9271 card....
    http://linuxwireless.org/en/users/Drivers/ath
    We have the ar9271 btw....
    Lss We have a 2Watt capable WIFI card but due to FCC restrictions... can only run it at 500mW..... or 27dBm.
    see here http://www.giangrandi.ch/electronics...l/decibel.html
    http://en.wikipedia.org/wiki/List_of_WLAN_channels
    The EEprom overrides driver settings...

    I worked on modding the EEprom all week-end....
    Got it injecting just fine doing this ^_^.
    !EDIT!
    First!
    Update Kernel to latest, reboot then dist-upgrade, reboot. No need to update at all.... Actually updating breaks some pkg and cause more issues than they resolve.
    No need to update at all this tutorial will work with a fresh install of BT5r1
    !EDIT
    Code:
    cd /usr/src
    wget http://www.orbit-lab.org/kernel/compat-wireless-2.6-stable/v2.6.39/compat-wireless-2.6.39-1.tar.bz2
    tar -xvjf compat-wireless-2.6.39-1.tar.bz2
    cd compat-wireless-2.6.39-1
    wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch
    wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
    patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
    patch -p1 < channel-negative-one-maxim.patch
    Chose the driver you want to compile, i have an AR9271 so i chose "atheros".
    Code:
    ./scripts/driver-select atheros
    Compile the pkg.
    Code:
    make && make install
    Then for AR9271 just or reboot.
    Code:
    modprobe ath9k_hw
    Voila! fakeauth, injection the works ^_^.

    I found a hole in the eeprom!!!

    Get essentials:
    Code:
    apt-get install libgcrypt11-dev python-m2crypto libnl1 libnl-dev
    Download and install regdb:
    Code:
    cd ~
    mkdir custom-rdb && cd custom-rdb
    wget http://wireless.kernel.org/download/wireless-regdb/wireless-regdb-2011.04.28.tar.bz2
    tar -xvjf wireless-regdb-2011.04.28.tar.bz2
    cd wireless-regdb-2011.04.28
    Now edit db.txt and place this info in your country code:
    My EEPROM defaults to US so i modified US lol <----------- the hole

    country US:
    (2402 - 2494 @ 40), (N/A, 35)
    (4910 - 5835 @ 40), (N/A, 35)


    Save and compile
    Code:
    make && make install
    Backup and copy new key.
    Code:
    cp /usr/lib/crda/regulatory.bin /usr/lib/crda/regulatory.bin.bak
    cp regulatory.bin /usr/lib/crda/
    Download crda:
    Code:
    cd ~/custom-rdb
    wget http://wireless.kernel.org/download/crda/crda-1.1.2.tar.bz2
    tar -xvjf crda-1.1.2.tar.bz2
    cd crda-1.1.2
    Copy the generated keys from regdb folder:
    Code:
    cp ~/custom-rdb/wireless-regdb-2011.04.28/*.key.pub.pem pubkeys
    Compile and install:
    Code:
    make && make install
    Unplug the Ar9271.
    Reboot
    Now witness the firepower of this fully armed and operational Wireless card!

    Some useful commands

    X= your card so either 0 1 2 3, what ever, usually wlan1 on a laptop wlan0 on a desktop
    Code:
    iw dev wlanX set power_save off 
    iw dev wlanX set txpower auto
    iwlist wlanX chan
    iwlist wlanX frequency
    One last thing...

    For some reason installing this version of compat breaks the iwl** driver.... FML!
    Took me for ever to figure out why, still haven't but i was able to restore the original iwl*** module.
    Code:
    iwl-enable
    iwl-load
    that will fix the module....

    Big thanx to the MODS <3 i am truly honored that my post made the tutorials ^_^
    Also Thanks to joker, he pointed me in the right direction
    Hey man can you please help me i know that this is old topic but please heelp everything work until i come to this command


    make && make install shell stay for some seconds than some text and there is some text that says
    No such file or directory but i follow or this commands and every command work until this faill so please please help ?

Page 2 of 2 FirstFirst 12

Similar Threads

  1. How to get AR9271 USB wifi working
    By csuzlee in forum Beginners Forum
    Replies: 2
    Last Post: 03-28-2011, 05:47 PM
  2. getting full power from awus036h
    By cain#1 in forum OLD Newbie Area
    Replies: 3
    Last Post: 01-22-2010, 08:29 PM
  3. win2k3 dns not fully working
    By compaq in forum OLD General IT Discussion
    Replies: 2
    Last Post: 09-05-2008, 07:07 PM
  4. Ubiquity card to full POWER ???
    By kungfuserge in forum OLD Tutorials and Guides
    Replies: 2
    Last Post: 03-31-2007, 11:02 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •