This error means exactly what it says. Since 11.13.11, Armitage's dependencies have changed. BackTrack 5 has an install of Metasploit 3.7.x. This install does not contain the MessagePack Ruby Gem that Armitage requires and the Java used by Metasploit is missing cryptographic extensions necessary to connect over SSL. BackTrack 5r1 has a Metasploit 4.0 install. If you have BackTrack 5r1 then you're fine and you won't see this dialog.
The solution: get BackTrack 5r1 (reinstall it/download the new VM) or delete Metasploit and install it using a Metasploit 4.0 or greater full setup installer. Using apt to update the distribution isn't always the same as downloading the latest BackTrack. Please download the latest BackTrack.
Why the changes? Metasploit 4.2 (under development right now) is a big house cleaning release. db_autopwn was taken out, the methods Armitage uses to talk to the database are likely deprecated, and the XMLRPC server is going away too. I rewrote Armitage's backend to take these things into account. The only problem is the dependency changes. I'm a big (x 10) fan of BackTrack and because I care about this user community, I put messages like this one in the software to help point you in the right direction.
If you're ever lost: click Help in the Armitage setup dialog, read the change log (whatsnew.txt), read the FAQ, or read the manual. I updated all of these resources to explain this dependency change. You can find this stuff at http://www.fastandeasyhacking.com/
I hope this explanation helps.
-- Raphael, Armitage Developer