Results 1 to 3 of 3

Thread: Linksys WMP54G (Broadcom - b43)

  1. #1
    Moderator g0tmi1k's Avatar
    Join Date
    Feb 2010
    Posts
    1,771

    Default Linksys WMP54G (Broadcom - b43)

    OS: BackTrack 5 R1 GNOME 64bit
    Make & Model: Linksys WMP54G
    Chipset: Broadcom
    Driver: b43
    Injection: Yes
    Method: Worked out of the box
    Code:
    root@bt:~# ifconfig wlan0
    wlan0     Link encap:Ethernet  HWaddr 00:12:17:94:90:xx  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    root@bt:~# iwconfig wlan0
    wlan0     IEEE 802.11bg  ESSID:off/any  
              Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              
    root@bt:~# lspci | grep -i network
    05:00.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
    root@bt:~# ls -l /sys/class/net/wlan0/device/driver
    lrwxrwxrwx 1 root root 0 2011-10-11 14:31 /sys/class/net/wlan0/device/driver -> ../../../../../bus/ssb/drivers/b43
    root@bt:~# lsmod | grep -i b43
    b43                   326324  0 
    mac80211              277511  2 rtl8187,b43
    cfg80211              165732  3 rtl8187,b43,mac80211
    ssb                    43273  1 b43
    root@bt:~# airmon-ng 
    
    
    Interface    Chipset        Driver
    
    wlan0        Broadcom    b43 - [phy0]
    
    root@bt:~# airmon-ng start wlan0 13
    
    
    Found 5 processes that could cause trouble.
    If airodump-ng, aireplay-ng or airtun-ng stops working after
    a short period of time, you may want to kill (some of) them!
    
    PID    Name
    878    NetworkManager
    926    wpa_supplicant
    1154    dhclient
    1306    dhclient3
    1375    dhclient3
    Process with PID 1375 (dhclient3) is running on interface wlan0
    
    
    Interface    Chipset        Driver
    
    wlan0        Broadcom    b43 - [phy0]
                    (monitor mode enabled on mon0)
    
    root@bt:~# aireplay-ng -9 mon0
    15:30:31  Trying broadcast probe requests...
    15:30:32  Injection is working!
    15:30:33  Found 1 APs
    
    15:30:33  Trying directed probe requests...
    15:30:33  00:19:5B:E7:52:xx - channel: 13 - 'SSID'
    15:30:33  Ping (min/avg/max): 1.291ms/14.471ms/61.321ms Power: -65.23
    15:30:33  30/30: 100%
    
    root@bt:~#
    Last edited by g0tmi1k; 10-11-2011 at 05:19 PM.
    Have you...g0tmi1k?

  2. #2
    Just burned his ISO
    Join Date
    Nov 2011
    Posts
    2

    Default Re: Linksys WMP54G (Broadcom - b43)

    I have the Broadcom b43 - [phy0] i am trying to use gerix, have you been succesfull, i am able to get the card into monitor mode, but fails to get enough ack's

  3. #3
    Moderator g0tmi1k's Avatar
    Join Date
    Feb 2010
    Posts
    1,771

    Default Re: Linksys WMP54G (Broadcom - b43)

    Its fine for me.
    Try changing the location of the access point and/or the client.
    Have you...g0tmi1k?

Similar Threads

  1. Linksys WMP54G
    By FenixZ2 in forum OLD Newbie Area
    Replies: 1
    Last Post: 05-18-2008, 05:11 AM
  2. wmp54g injecting packets sloww
    By vtsguard in forum OLD Newbie Area
    Replies: 2
    Last Post: 05-18-2008, 05:07 AM
  3. Wmp54g V4.1
    By khirz in forum OLD Newbie Area
    Replies: 1
    Last Post: 01-30-2008, 07:18 AM
  4. Linksys WMP54G
    By PWnNO in forum OLD BT3beta NON-WORKING HARDWARE
    Replies: 0
    Last Post: 12-15-2007, 07:23 AM
  5. Replies: 2
    Last Post: 05-30-2007, 06:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •