I am trying to install a printer Brother MFC4550-CN in 64-bit KDE Backtrack5, without satisfactory results. I tried installing the drivers for the brother page but are 32bit. I have already tried many things, including solutions in the ubuntu forums.
- Backtrack version 5:
Linux bt version 2.6.39.4 (root@builder64) (gcc version 4.4.3 (Ubuntu 4.4.3-4ubuntu5) ) #1 SMP Wed Aug 17 21:42:30 EDT 2011 x86_64 GNU/Linux
DMI: Hewlett-Packard Compaq Presario CQ71 Notebook PC/306C, BIOS F.23 12/21/2010

- Backtrack installation HDD on /dev/sda5
- lspci
Code:
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
00:1f.6 Signal processing controller: Intel Corporation 82801I (ICH9 Family) Thermal Subsystem (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G98M [GeForce G 103M] (rev a1)
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x / AR542x Wireless Network Adapter (PCI-Express) (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
-lsusb: ( see other devices installed and working )
Code:
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 010: ID 1131:1004 Integrated System Solution Corp. Bluetooth Device
Bus 002 Device 008: ID 04f9:016d Brother Industries, Ltd MFC-5440CN
Bus 002 Device 007: ID 0603:00f2 Novatek Microelectronics Corp. 
Bus 002 Device 006: ID 045e:074f Microsoft Corp. 
Bus 002 Device 005: ID 2040:7060 Hauppauge Nova-T Stick 2
Bus 002 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 003: ID 0408:03f4 Quanta Computer, Inc. 
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
What I've done so far is:
apt-get install tcsh
dpkg -i --force-all mfc5440cnlpr-1.0.2-1.i386.deb
dpkg -i --force-all cupswrapperMFC5440CN-1.0.2-3.i386.deb
cp /usr/share/cups/model/brmfc5440cn_cups.ppd /usr/share/ppd/
apt-get install cupsys cupsys-bsd gs-esp
apt-get install ia32-libs
ln -sf /etc/init.d/cupsys /etc/init.d/cups

dpkg: error processing force-all (- install):
can not access file: No such file or directory
dpkg: error processing-1.0.2-1.i386.deb mfc5440cnlpr (- install):
package architecture (i386) does not correspond with the system (amd64)
Errors were encountered while processing:
force-all
mfc5440cnlpr-1.0.2-1.i386.deb
I've done so many things that are hardly or what is wrong.
I have also tried dpkg -i mfc5440cnlpr-1.0.2-1.i386.deb has and this is the error message:
dpkg: error processing-1.0.2-1.i386.deb mfc5440cnlpr (- install):
package architecture (i386) does not correspond with the system (amd64)

as it is logical to have a 64bit system this is not solution, but also have the necessary dependencies installed on it to use 32 bit libraries to no avail

Links I have followed and tried to no avail:
http://contactium.net/linux/mfc5440cn.txt
http://ubuntuforums.org/archive/index.php/t-933265.htmlhttp://ubuntuforums.org/archive/index.php/t-933265.html

Any help for this?
I would not be changing windows to print the results or any report you need to print.
Thanks